Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » Importing from Enterprise Architect
Importing from Enterprise Architect [message #1631115] Mon, 23 February 2015 15:51 Go to next message
Capt Frank is currently offline Capt FrankFriend
Messages: 11
Registered: April 2012
Junior Member
First to start I have never used modeling tools before so please excuse if I ask some basic quesitons.

I got a model (EAP file) that I believe was created in enterprise architect. I got a trial version and they opened up fine. But this is not something that I will use very much so can't justify the costs of EA as I just want to view and understand the models at this point. I'm not looking to change it. At least at this time. I have tried to export from EA to xmi and create a new EMF project importing it but keep getting errors no matter what I do export wise. Usally some java error like:



org.eclipse.emf.ecore.xmi.IllegalValueException: Value 'complete' is not legal. (file:/home/demo/sca/model_sca41_uml21_xmi21.xmi, 28, 329)



First is this the right thing to do? Should I be looking at some other SW to do this/view these models?
Re: Importing from Enterprise Architect [message #1632071 is a reply to message #1631115] Tue, 24 February 2015 04:30 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30351
Registered: July 2009
Senior Member
It's best to ask about this in the UML2 forum, or maybe it's something
supported by the Papyrus tools.

On 23.02.2015 16:51, Capt Frank wrote:
> First to start I have never used modeling tools before so please excuse
> if I ask some basic quesitons.
>
> I got a model (EAP file) that I believe was created in enterprise
> architect. I got a trial version and they opened up fine. But this is
> not something that I will use very much so can't justify the costs of EA
> as I just want to view and understand the models at this point. I'm not
> looking to change it. At least at this time. I have tried to export
> from EA to xmi and create a new EMF project importing it but keep
> getting errors no matter what I do export wise. Usally some java error
> like:
>
>
>
> org.eclipse.emf.ecore.xmi.IllegalValueException: Value 'complete' is not
> legal. (file:/home/demo/sca/model_sca41_uml21_xmi21.xmi, 28, 329)
>
>
>
> First is this the right thing to do? Should I be looking at some other
> SW to do this/view these models?
Re: Importing from Enterprise Architect [message #1636710 is a reply to message #1631115] Thu, 26 February 2015 10:30 Go to previous message
Eclipse UserFriend
As far as our experience goes, XMI files exported from Enterprise
Architect can not properly be opened/imported in Eclipse UML. The EA
uses a lot of proprietary information that cannot be loaded. Maybe the
YAKINDU EA-Bridge (www.yakindu.com/eabridge, free trial available) is of
interest for you, it loads eap-files inside Eclipse without
import/export and even without the need to install the Enterprise
Architect. If you have further questions, please feel free to contact me
directly.


Am 23.02.2015 um 16:51 schrieb Capt Frank:
> First to start I have never used modeling tools before so please excuse
> if I ask some basic quesitons.
>
> I got a model (EAP file) that I believe was created in enterprise
> architect. I got a trial version and they opened up fine. But this is
> not something that I will use very much so can't justify the costs of EA
> as I just want to view and understand the models at this point. I'm not
> looking to change it. At least at this time. I have tried to export
> from EA to xmi and create a new EMF project importing it but keep
> getting errors no matter what I do export wise. Usally some java error
> like:
>
>
>
> org.eclipse.emf.ecore.xmi.IllegalValueException: Value 'complete' is not
> legal. (file:/home/demo/sca/model_sca41_uml21_xmi21.xmi, 28, 329)
>
>
>
> First is this the right thing to do? Should I be looking at some other
> SW to do this/view these models?
Previous Topic:ECP and element links inside widgets
Next Topic:[CDO] Uninitialized cannot be cast to CDOID
Goto Forum:
  


Current Time: Sun Aug 18 10:49:23 GMT 2019

Powered by FUDForum. Page generated in 0.01985 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top