PTP 1.1.1 Release Notes

Note: Release 2.0 preview release notes are here

New and Noteworthy

Release 1.1.1 includes a few bug fixes and improvements over Release 1.1:

  • Bug #173142 - passing multiple arguments to application
  • Bug #194952 - automatically select first debugger in list
  • Fixed bug in hash function
  • Improvements to debugger variable handling
  • PLDT: Bug # 200623 - blank compiler and linker defaults for MPI
  • PLDT: Bug # 181846 - MPI new project wizard page correctly handles differently-named toolchains (e.g. Mac)

In addition, PTP Release 1.1.1 can be installed via an update site, right from the Eclipse workbench.

Parallel Tools Platform

The PTP plug-in provides the following functionality

  • The PTP Runtime perspective, including an abstract parallel machine view, jobs view and parallel launch configuration
  • The PTP Debug perspective, Parallel Debug view and scalable debug manager (SDM)
  • Parallel Language Development Tools (PLDT) [Note: these tools are installed as a separate plug-in below]

Prerequisites

  • OS: Linux or Mac OS X 10.4.x (for PTP Core only; PLDT should run anywhere Eclipse runs, including Windows.)
  • Java 1.5 or later (Note: for Linux, must be Sun or IBM's. See below.)
  • Eclipse 3.2.x
  • CDT 3.1.x
  • OpenMPI 1.2 (the earlier 1.0.2 version is also supported)
  • gdb 6.3 or later (earlier versions may also work)

Installation

  • Java requirement: If you are using the Linux operating system, download and install either the Sun Java Runtime Environment or the IBM Java Runtime Environment. The version of Java that ships with Linux will not work with PTP. See the Trouble Shooting section for more information.
  • Install Eclipse 3.2.x (SDK or Platform Runtime Binary) and CDT 3.1.x for your architecture.

    If you plan to do Java or Eclipse development, get the Eclipse SDK. If you just want C/C++ (or Fortran via Photran) then the Platform runtime Binary only is smaller and less complex. It's on the "Other downloads" page for the release.

    See Installing Eclipse and PTP for detailed instructions on downloading Eclipse, installing CDT, etc. If you plan to install PTP from the update site, you can do it at this point also.

  • Download and unpack OpenMPI 1.2. If you download a pre-built binary for OpenMPI, you MUST obtain the developer version. If there is no developer version available, then you will need to build from source instead.
  • Configure, build and install OpenMPI (if necessary)
    • In the main OpenMPI source directory, run the configure command:

      ./configure --with-devel-headers

      and any other options required for your installation.

    • Build and install OpenMPI using:

      make install

    • Note that if you install OpenMPI in a nonstandard location, you may need to build PTP differently. See the troubleshooting section below.
  • Test your MPI installation by running a small MPI job, e.g.
            mpicc test.c -o test
            mpirun -np 4 test
            
  • If you didn't install PTP from the update site while installing CDT,
    • Install it from the update site now, or
    • Download the PTP plug-in and unzip (or un-tar) into the same directory into which Eclipse has been installed. Do the same with the PLDT download as well, if you want the development tools.
  • Locate the plug-in org.eclipse.ptp.os.arch_x.y.z in the plugins directory, where os and arch correspond to your operating system and architecture respectively, and x.y.z (if present) corresponds to the release version of that particular plugin, e.g. 1.1.0 or 1.1.1. Change to this directory.
  • Run the command:

    sh BUILD

    This should build and install the executables. If you see any errors here, please refer to the Trouble Shooting section below.
    If you installed OpenMPI in a non-standard location, see below also for an alternate build command.

  • Start Eclipse. (You may need to use the -clean parameter to force it to recognize new features and plug-ins).
  • Open the PTP Runtime perspective (Window>Open Perspective>Other...). The runtime service will start and you should see a machine and one or more nodes appear in the 'Machines View'.
  • More details on using PTP can be found in Help>Help Contents. Click on "PTP: Parallel Tools Platform ".

Trouble Shooting

  • I get lots of error messages about missing include files when running the BUILD script.

    This is because OpenMPI was not configured to include the development headers. You need to re-run the configure command for the OpenMPI installation specifying the --with-devel-headers option.

  • Switching to the PTP Runtime perspective hangs in a dialog with the message 'Starting OMPI proxy runtime...'

    If this dialog is replaced with an error dialog after a delay, and you are running PTP on a Linux system, then it is likely that you have not installed either the Sun or IBM Java Runtime Environments. The Java that is shipped with Linux will not work with PTP.

    In all other cases, this is almost always a problem with the location of the OpenMPI shared libraries on Linux systems. The proxy server is dynamically linked against the OpenMPI libraries, so needs to be able to locate your OpenMPI libraries in order to run.

    You can check this by manually running the proxy server using the command eclipse/plugins/org.eclipse.ptp.os.arch/bin/ptp_orte_proxy (replace eclipse with the locatation of your Eclipse installation and os and arch with your operating system and architecture respectively). If you see anything other than the message "proxy_svr_connect returned." then this is likely to be the problem.

    • If you are starting Eclipse from a shell make sure the OpenMPI libraries are located in /usr/local/lib, /usr/lib or /lib, or you have set your LD_LIBRARY_PATH environment variable correctly.
    • If you are starting Eclipse from a window manager (Gnome, KDE, etc.) then it is usual that the window manager and shell get their environment from different places. This means that setting the LD_LIBRARY_PATH in your .profile may not be sufficient; even if you can run an MPI program using mpirun successfully from a shell it does not necessarily mean that the window manager is set up correctly. Consult your window manager documentation for information on how to set environment variables.
  • Switching to the PTP Runtime perspective results in a dialog with the message:

    "There was an error starting the OMPI proxy runtime. The path to 'ptp_orte_proxy' or 'orted' may have been incorrect. The 'orted' binary MUST be in your PATH to be found by 'ptp_orte_proxy'. Try checking the console log or error logs for more detailed information."

    This is a similar problem to the shared library issue above. Make sure that your PATH is set to correctly include the location of the OpenMPI bin directory.

    • If you are starting Eclipse from a shell add the path to the OpenMPI binaries to the PATH environment variable in your login script.
    • If you are starting Eclipse from a Linux window manager (Gnome, KDE, etc.) then consult your window manager documentation for information on how to set environment variables.
    • If you are starting Eclipse from the MacOS X window manager (Aqua), the PATH must be set by creating a file called environment.plist in a directory called .MacOSX in your home directory.

      The file should look like this, with [path_to_ompi_binaries] replaced with the correct path:

      <?xml version="1.0" encoding="UTF-8"?>
      <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN"
      "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
      <plist version="1.0">
      <dict>
        <key>PATH</key>
        <string>[path_to_ompi_binaries]</string>
        </dict>
      </plist>
                     

    • I installed OpenMPI in a non-standard location. Do I need to do anything differently?

      Yes. The standard location is /usr/local. If you install it to, e.g., /usr/local/openmpi, then when you build the platform-specific PTP code, instead of sh BUILD you should use the following command:
      CFLAGS=-I/usr/local/openmpi/include LDFLAGS="-L/usr/local/openmpi/lib -Wl,-rpath,/usr/local/openmpi/lib" sh BUILD

  • I forgot to switch to the PTP Runtime perspective before launching a job. Now I see no machines and get messages in the console about simulation.

    Try opening PTP preferences, and assuring runtime control system and monitoring system are set to ORTE. If they are, change them to something else and change them back. This should reset ORTE as the runtime system.

Parallel Language Development Tools

The Parallel Language Development Tools require an MPI installation to be available on the machine running Eclipse. Unlike PTP, any MPI installation should work (MPICH, LAM-MPI, etc.) The Parallel Language Development Tools only requires access to the MPI header files to be able to recognize the MPI artifacts.

Note: a beta version of PLDT 2.0 (for Eclipse 3.3 and CDT 4.0) is available on the builds page.

Prerequisites for PLDT 1.1

  • Eclipse 3.2.x
  • CDT 3.1.x
  • An MPI installation

Installation

  1. Install Eclipse 3.2.x and CDT 3.1.x for your architecture.
  2. Download the 'Parallel Language Development Tools' distribution.
  3. Unzip (or un-tar) into same directory into which Eclipse has been installed (or use the update site).
  4. Start Eclipse. (You may need to use the "-clean" parameter to force it to recognize new features and plug-ins).
  5. You should see the two new "MPI" buttons, and two new "OpenMP" buttons, in the toolbar.
  6. Follow the instructions in Help > Help Contents. Click on "PTP Parallel Language Development Tools".
  7. Setup and running instructions include a small sample C MPI file for testing.

Fortran Development Tools

See the Photran project.