PTP Release Notes

PTP Release Notes for Release 1.0

Parallel Tools Platform

Note: installation of the PTP component is not required if you just want to use the MPI Development Tools or Fortran Development Tools components. Please see the appropriate sections below for release notes on these components.

The main PTP components are split into three parts:

  • a set of Eclipse plug-ins
  • an architecture-specific runtime plug-in
  • an architecture-specific debugger plug-in

Prerequisites

  • Java 1.4.2 or later
  • Eclipse 3.1.x
  • CDT 3.0.x
  • OpenMPI 1.0.2
  • gdb 6.3 (earlier versions may also work)

Installation

  1. Install Eclipse SDK 3.1.x and CDT 3.0.x SDK for your architecture.
  2. Download, build and install OpenMPI 1.0.2. (Note: as of February 2006, this is still a "pending alpha" release of OpenMPI 1.0.2, but it works fine for us.) If you intend to build PTP from source, instead of downloading it pre-built from the downloads page, make sure you supply the --with-devel-headers argument to the configure command.
  3. Test your MPI installation by running a small MPI job.
  4. Download PTP core and the runtime and debugger plug-ins that suit your architecture.
  5. Unzip (or un-tar) into the same directory into which Eclipse has been installed.
  6. Start Eclipse. (You may need to use the "-clean" parameter to force it to recognize new features and plug-ins).
  7. Open the PTP Runtime perspective (Window>Open Perspective>Other...). This should automatically select the Open MPI runtime preference and start the runtime service. If you have a problem here, please refer to the Troubleshooting section.
  8. More details on using PTP can be found in Help > Help Contents. Click on "PTP: Parallel Tools Platform ".

Troubleshooting

PTP session hangs in 'Refresh runtime system' dialog.

This is usually one of the following things:

  1. OpenMPI lock problem: (See also a handy shell script for doing this cleanup)
    • Quit out of Eclipse
    • Check there are no orted, orte_server or sdm programs running with the 'ps ax' command.
    • If there are, kill them off.
    • Check for any directories in /tmp starting with 'openmpi-sessions-<username>' . Remove the directory and all its contents.
    • Restart Eclipse
  2. Unable to locate OpenMPI libraries:
    • The orte_server is dynamically linked against the OpenMPI libraries, so needs to be able to locate your OpenMPI installation to run.
    • You can check this by manually running the orte_server. If you see anything other than the message "proxy_svr_connect returned." then this is likely to be the problem.
    • On Linux, make sure the OpenMPI libraries are located in /usr/local/lib, /usr/lib or /lib, or you have set your LD_LIBRARY_PATH correctly.
    • On Mac OS X, make sure the OpenMPI libraries are located in $(HOME)/lib, /usr/local/lib, /usr/lib or /lib, or you have set your DYLD_LIBRARY_PATH correctly.
  3. Window manager path problem:
    • The window manager and shell get their paths from different places.
    • If you are launching Eclipse using a window manager, you need to make sure that the OpenMPI installation is in the window manager path.
    • Even if you can use 'mpirun' successfully from a shell it does not necessary mean that the window manager path is correct.
    • Mac OS X:
      • The path is set by creating an environment.plist file in a directory called .MacOSX in your home directory.
      • The file should look like this, with [path_including_ompi_installation] replaced with the correct path:
        <?xml version="1.0" encoding="UTF-8"?>
        <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
        <plist version="1.0">
        <dict>
        <key>PATH</key>
        <string>[path_including_ompi_installation]</string>
        </dict>
        </plist>
    • Linux/KDE:
      • Anybody know?
    • Linux/Gnome:
      • Anybody know?

MPI Development Tools

The MPI Development Tools require an MPI installation to be available on the machine running Eclipse. Unlike PTP, any MPI installation should work (MPICH, LAM-MPI, etc.) The MPI Development Tools only requires access to the MPI header files to be able to recognize the MPI artifacts.

Prerequisites

  • Eclipse 3.1.x
  • CDT 3.0.x
  • An MPI installation

Installation

  1. Install Eclipse 3.1.x and CDT 3.0.x for your architecture.
  2. Download the 'MPI Development Tools' distribution from from here.
  3. Unzip (or un-tar) into same directory into which Eclipse has been installed (or use the update site).
  4. Start Eclipse. (You may need to use the "-clean" parameter to force it to recognize new features and plug-ins).
  5. You should see the two new "MPI" buttons in the toolbar.
  6. Follow the instructions in Help > Help Contents. Click on "PTP MPI Tools".
  7. Setup and running instructions include a small sample C MPI file for testing.

Fortran Development Tools

Prerequisites

  • Eclipse 3.1.x
  • CDT 3.0

Installation

  1. Install Eclipse 3.1.x and CDT 3.0 for your architecture.
  2. Download the 'CDT with mixed-language projects' and 'Fortran Development Tools' distributions from here.
  3. Unzip (or un-tar) into same directory into which Eclipse has been installed (or use the update site).
  4. Start Eclipse. (You may need to use the "-clean" parameter to force it to recognize new features and plug-ins).

Notes

The installation of the Fortran Development Tools will replace some of your existing CDT 3.0 components. This adds support for mixed language projects (i.e. combining C, C++ and Fortran into a single project), and also introduces some changes necessary to support the FDT plug-ins. These changes will be included in CDT release 3.1 (June 2006)