Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Subject: x86_64 Eclipse does not start up
Subject: x86_64 Eclipse does not start up [message #179880] Mon, 13 November 2006 16:45
Eclipse UserFriend
Originally posted by: AndreHasekamp.netscape.net

Trying to make my first time startup of the Eclipse Platform on a 64-bit
machine.

No luck, so, on a 32-bit machine under SuSe 10.0, I tried the 32-bit
version coming from:

eclipse-SDK-3.2.1-linux-gtk.tar.gz

Runs fine (or rather: starts up fine, because that's all I did up to now).

Something seems to be the matter with the 64-bit Eclipse version on my
64-bit machine under SuSe 10.0, x86_64 (yes I saw the Release Notes, it
is not a reference platform). Or I do something wrong. Looking through
the first 500 threads of this Newsgroup I seem to be the only one having
this problem.

The 64-bit Eclipse version comes from:

eclipse-SDK-3.2.1-linux-gtk-x86_64.tar.gz

It has been installed in my /opt directory. That means that following
"tar zxvf eclipse-SDK-3.2.1-linux-gtk-x86_64.tar.gz" I get a directory
/opt/eclipse. The contents of that directory is:

total 480
drwxrwxr-x 7 root root 480 Nov 13 00:07 .
drwxr-xr-x 9 root root 224 Nov 12 22:43 ..
-rw-rw-r-- 1 root root 61 Nov 12 23:30 .eclipseproduct
-rw-rw-r-- 1 root root 11669 Sep 21 18:01 about.html
drwxrwxr-x 2 root root 152 Sep 21 18:01 about_files
drwxrwxr-x 2 root root 112 Nov 12 23:58 configuration
-rwxr-xr-x 1 root root 46033 Sep 21 18:01 eclipse
-rw-rw-r-- 1 root root 36 Nov 12 22:45 eclipse.ini
-rw-rw-r-- 1 root root 16536 Sep 21 18:01 epl-v10.html
drwxrwxr-x 11 root root 736 Sep 21 18:01 features
-rw-rw-r-- 1 root root 9022 Sep 21 18:01 icon.xpm
-rwxr-xr-x 1 root root 332224 Sep 21 18:01 libcairo-swt.so
-rw-rw-r-- 1 root root 6506 Sep 21 18:01 notice.html
drwxrwxr-x 24 root root 7336 Sep 21 18:01 plugins
drwxrwxr-x 2 root root 88 Sep 21 18:01 readme
-rw-rw-r-- 1 root root 33049 Sep 21 18:01 startup.jar

The contents of .eclipseproduct is the same as for the 32-bit version:

name=Eclipse Platform
id=org.eclipse.platform
version=3.2.0

Of course I tried several modifications to
/opt/eclipse/configuration/config.ini, all to no avail so far. This is
probably where my beginners knowledge still falls short. The original
one (on which the error log below is based) contained a.o. the following
lines:

....
eclipse.product=org.eclipse.sdk.ide
#eclipse.application=
....

Then, when I run "eclipse" as an ordinary user, I see the splash screen.
A little later it crashes and tells me to look in the error log. The
following error log is produced:

!SESSION 2006-11-13 00:20:45.155
-----------------------------------------------
eclipse.buildId=M20060921-0945
java.version=1.5.0_09
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.core.runtime 2006-11-13 00:20:46.306
!MESSAGE Product org.eclipse.sdk.ide could not be found.

!ENTRY org.eclipse.osgi 4 0 2006-11-13 00:20:46.311
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at
org.eclipse.core.internal.runtime.PlatformActivator$1.run(Pl atformActivator.java:56)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:9
2)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:68)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:400)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:177)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336 )
at org.eclipse.core.launcher.Main.basicRun(Main.java:280)
at org.eclipse.core.launcher.Main.run(Main.java:977)
at org.eclipse.core.launcher.Main.main(Main.java:952)

You see that I have a jre version 1.5.0. It is the 64-bit version
(jre-1_5_0_09-linux-amd64.bin from the Sun site).

Indeed, there is no directory org.eclipse.sdk.ide_... in the directory
/opt/eclipse/plugins. There is a directory org.eclipse.sdk_..., but it
does not help specifying org.eclipse.sdk as the eclipse.product in
/opt/eclipse/configuration/config.ini.

Whatever I do, I keep getting the message that no Application id has
been found. When I define something that looks like an Application id to
me (a directory name in the directory /opt/eclipse/plugins) I
get an additional message that says something like "application ids in
registry: NONE". It looks like some configuration info is missing.

It seems to me that anyone who has installed the same Eclipse SDK
version on his 64-bit machine, will have run into this problem,
regardless of the 64-bit Linux distro. It wouldn't surprise me if the
solution is so simple that Eclipse experts do not bother to make a note
of it. However, for a first-time user, this is not a trivial matter.

Would appreciate your help,
Andre Hasekamp.
Previous Topic:Import cannot be resolved
Next Topic:Debug
Goto Forum:
  


Current Time: Mon Dec 22 11:27:49 GMT 2014

Powered by FUDForum. Page generated in 0.01662 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software