Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Very Basic C question(I haven't found a C specific tutorial, and am new enough at this to be having difficulty.)
Very Basic C question [message #730248] Wed, 28 September 2011 01:32 Go to next message
Michael Sprague is currently offline Michael SpragueFriend
Messages: 4
Registered: September 2011
Junior Member
I have been through the C/C++ Development User Guide "Getting Started" 'folder' at * (aitch tee tee pee colon slash slash help dot eclipse dot org slash indigo slash index dot jsp) and was able to successfully create a Hello World app that ran, but now I have been stymied by creating my own, from my textbook for my class in C.

Am I missing some obvious C only section there, due to my cluelessness and virginal newbieness?

I typed in the code from page 35 of C By Discovery and tried to follow the same procedures detailed in the tutorial that directed me to use mostly canned code, but Eclipse finds nothing to build or run.

What am I doing wrong?

Thanks for any help.

Newbie Newberson
Hopelessly Lost, But Making Good Time

P.S. I am on a MacBook running OS X 10.6.x and I would go to the school for help with this, but IT there is almost all Windows and largely clueless. Honest. Very nice people, but not a good source for help with basic questions, I fear this one might give them nightmares.

* P.P.S. Sorry, no links allowed in first five posts.

P.P.P.S. Here are error msgs:

======================================
When I try to build.
======================================
**** Build of configuration Debug for project CbyDpg35 ****

Nothing to build for project CbyDpg35


======================================
When I try to run
======================================

The selection cannot be launched, and there are no recent launches.

[Updated on: Wed, 28 September 2011 01:38]

Report message to a moderator

Re: Very Basic C question [message #730421 is a reply to message #730248] Wed, 28 September 2011 11:19 Go to previous message
Axel Mueller is currently offline Axel MuellerFriend
Messages: 1968
Registered: July 2009
Senior Member
I don't know how you did setup your project and what's wrong with it. But I would suggest that you create a simple Hello World project (File->New Project...) and then replace the code in hello.c with your sample code.

Before you ask
- search this forum
- see the FAQ http://wiki.eclipse.org/CDT/User/FAQ
- google
Previous Topic:Remote debug embedded linux angstrom board
Next Topic:remote C/C++ project debugging
Goto Forum:
  


Current Time: Thu Nov 27 11:00:57 GMT 2014

Powered by FUDForum. Page generated in 0.02324 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software