Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Permission Denied Problems(I have this issue in Eclipse and Visual Studio!)
icon9.gif  Permission Denied Problems [message #557199] Mon, 06 September 2010 04:32 Go to next message
Nathan  is currently offline Nathan Friend
Messages: 1
Registered: September 2010
Junior Member
Hello everyone:

I am having a frustrating problem developing for C\C++. Every IDE\Compiler I use for some reason will not let me compile correctly.

So lets start with Eclipse.

I have the basic hello world program. I go ahead and click build and get success. Then Run. Success.

At this point I go ahead and make a slight change to the source code file, like add a '\n' or something along those lines. I go to build the project and I get the following:

c:/mingw/bin/../lib/gcc/mingw32/4.5.0/../../../../mingw32/bi n/ld.exe: cannot open output file HelloWorld.exe: Permission denied

So I figured that HelloWorld.exe was running. It wasn't. So now I'm confused. I went ahead and manually deleted HelloWorld.exe. I get the following message: You must be the computer administrator to do this... blah blah blah. Even though I have disabled UAC and I am running as an administrator.

I checked other forums for the issue, and I can't find any. I am beginning to think its my security software. I posted on MSDN for the exact same problem in Visual Studio 2010, and they recommended I use Microsoft Security Essentials in stead of Norton... big help they were. So I tried running in safe mode and success!

Therefore, I thought it had to be my antivirus. I removed it completely and cleaned the computer using CCleaner\Revo uninstaller.

Trying to build again does not work. I get the same error as before.

Please help guys! I am really frustrated!
Re: Permission Denied Problems [message #629624 is a reply to message #557199] Wed, 29 September 2010 01:45 Go to previous message
Igor Bitny is currently offline Igor BitnyFriend
Messages: 1
Registered: September 2010
Location: Russia
Junior Member
Hello !
I meet the same problem today Sad But the problem is solved when I run eclipse in Windows XP compatibility mode Smile
Seems it is strange feature of Windows 7: exe file cannot be deleted right after execution. But I notes that exe file disappear from some time (roughly 2-5 min) and I can successfuly compile my program again. Of course it is inconvenient to wait so long to each compile, fortunately in XP mode all works fine.
Previous Topic:How to use command line arguments?
Next Topic:selecting compiler options?
Goto Forum:
  


Current Time: Thu Dec 18 01:01:20 GMT 2014

Powered by FUDForum. Page generated in 0.01517 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software