Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » How to disable Javascript validation in Helios J2EE IDE(javascript validation helios )
How to disable Javascript validation in Helios J2EE IDE [message #548176] Tue, 20 July 2010 19:32 Go to next message
Joe Chung is currently offline Joe Chung
Messages: 3
Registered: July 2010
Junior Member
I'd like to disable Javascript validation because I am getting many javascript errors. These aren't even my error but errors from libraries like jquery, so I definitely don't want to tamper with these files. I am guessing that the Javascript validator is very strict, so even a popular library like jquery fails. Every time I clean the workspace and do an automatic build, I get bombarded by a series of "Problem Occurred" pop-ups with details saying "Errors running builder 'Javascript Validator' on project 'ProjectName'. java.lang.NullPointerException" (where ProjectName is actually the name of the project). Because I build my workspace regularly, these error pop-ups get very annoying. I am using Mac OS X (does it even matter since eclipse (Java) is platform independent?). I went to Properties->Javascript->Validation, but everything there is locked, and it has ECMAScript compliance level of "ECMAScript 3" locked. I tried clicking various checkboxes, but none allow me to do anything with the locked settings. I tried going to Properties->Validation and go to the extreme of disabling all validation, but that doesn't seem to work either (still gets javascript errors and validation still runs). Please help, and thank you in advance!
Re: How to disable Javascript validation in Helios J2EE IDE [message #549000 is a reply to message #548176] Fri, 23 July 2010 12:14 Go to previous messageGo to next message
Vinicius Isola is currently offline Vinicius Isola
Messages: 40
Registered: March 2010
Location: Brazil
Member
Did you try to disable the checkbox under:
Javascript > Validator > Errors/Warnings (Enable JavaScript semantic validation)?
I did this and it worked for me.


Re: How to disable Javascript validation in Helios J2EE IDE [message #551882 is a reply to message #548176] Mon, 09 August 2010 19:49 Go to previous messageGo to next message
John Bocalig is currently offline John Bocalig
Messages: 2
Registered: August 2010
Junior Member
I'm getting this same error when it tries to build my workspace and it eventually crashes Helios - out of memory error.
Re: How to disable Javascript validation in Helios J2EE IDE [message #551886 is a reply to message #548176] Mon, 09 August 2010 20:32 Go to previous messageGo to next message
Joe Chung is currently offline Joe Chung
Messages: 3
Registered: July 2010
Junior Member
Looks like my problem is fixed when I go to the project's preference->Builders and uncheck the Javascript Validator.
Re: How to disable Javascript validation in Helios J2EE IDE [message #551887 is a reply to message #548176] Mon, 09 August 2010 20:38 Go to previous messageGo to next message
John Bocalig is currently offline John Bocalig
Messages: 2
Registered: August 2010
Junior Member
Awesome, that works for me too, but what kind of side effects can happen with this workaround?
Re: How to disable Javascript validation in Helios J2EE IDE [message #558165 is a reply to message #551887] Fri, 10 September 2010 07:53 Go to previous messageGo to next message
No real name is currently offline No real name
Messages: 2
Registered: September 2010
Junior Member
Up, please!

I have unchecked in the preferences: Javascript > Validator > Errors/Warnings (Enable JavaScript semantic validation), but some times, not always, when I open a project there is javascript problems. Sad
Re: How to disable Javascript validation in Helios J2EE IDE [message #558171 is a reply to message #558165] Fri, 10 September 2010 08:04 Go to previous messageGo to next message
No real name is currently offline No real name
Messages: 2
Registered: September 2010
Junior Member
I found with a right click on the project -> properties -> Builders a "Javascript Validator" and here it is checked.... Maybe! Rolling Eyes
Re: How to disable Javascript validation in Helios J2EE IDE [message #558579 is a reply to message #551887] Mon, 13 September 2010 10:54 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2238
Registered: July 2009
Senior Member
On 8/9/2010 8:38 PM, John Bocalig wrote:
> Awesome, that works for me too, but what kind of side effects can happen
> with this workaround?

Standalone .js files will not be validated at all as part of the Build.
The entry for the Client script validator on the Validation
preference/property page affects JS within web page files.

All JavaScript questions should be directed to the eclipse.webtools
forum instead of this one. JavaScript != Java and JSDT != JDT.

news://news.eclipse.org/eclipse.webtools
http://eclipse.org/forums/eclipse.webtools

--
Nitin Dahyabhai
Eclipse WTP Source Editing and JSDT
IBM Rational


---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: How to disable Javascript validation in Helios J2EE IDE [message #558588 is a reply to message #558579] Mon, 13 September 2010 11:29 Go to previous message
Joe Chung is currently offline Joe Chung
Messages: 3
Registered: July 2010
Junior Member
Sorry. I understand that javascript is not java. It's just that it's part of the J2EE IDE, and it's my fault for not checking the names of all existing forums for the best fit.
Previous Topic:[SOLVED] Eclipse crash on startup
Next Topic:problems to install eclipse software windows 7
Goto Forum:
  


Current Time: Thu Jul 31 19:59:08 EDT 2014

Powered by FUDForum. Page generated in 0.01827 seconds