Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » SWTBot » example (SWTBot and ANT)
example (SWTBot and ANT) [message #30504] Thu, 26 March 2009 07:57 Go to next message
Brice Laurel is currently offline Brice Laurel
Messages: 72
Registered: July 2009
Member
Hi list,

I want to generate report of my SWTBot's test. I have
org.eclipse.swtbot.junit4_x on my dependencies.
But when I run this I have this on console.


Buildfile: C:\Documents and Settings\Carole
Béatrice\Bureau\TestJasmine\workspace\org.ow2.jasmine.mod el.diagram.ui.test\build.xml
init:
suite:

BUILD FAILED
C:\Documents and Settings\Carole
Béatrice\Bureau\TestJasmine\workspace\org.ow2.jasmine.mod el.diagram.ui.test\build.xml:27:
The following error occurred while executing this line:
java.io.FileNotFoundException: C:\Documents and Settings\Carole
Béatrice\Bureau\TestJasmine\plugins\org.eclipse.swtbot.ec lipse.junit4\headless_${all.buildId}\library.xml
(Le chemin d'accÚs spécifié est introuvable)

Total time: 218 milliseconds

Someone can help me ? Thanks in advance
Re: example (SWTBot and ANT) [message #30573 is a reply to message #30504] Thu, 26 March 2009 08:45 Go to previous messageGo to next message
Ketan Padegaonkar is currently offline Ketan Padegaonkar
Messages: 873
Registered: July 2009
Senior Member
On 26/3/09 04:57, Brice Laurel wrote:
> Béatrice\Bureau\TestJasmine\plugins\org.eclipse.swtbot.ec lipse.junit4\headless_${all.buildId}\library.xml

all.buildId needs to be substituted with the actual version number of
the plugin you're using.

-- Ketan
Re: example (SWTBot and ANT) [message #30643 is a reply to message #30573] Thu, 26 March 2009 09:44 Go to previous message
Brice Laurel is currently offline Brice Laurel
Messages: 72
Registered: July 2009
Member
Thanks Ketan,

I see the dependency tab and the version of my plugin is "2.0.0"
I set de ${all.build} property

<property name="all.buildId" value="2.0.0"/>

But I have the same error

plugins\org.eclipse.swtbot.eclipse.junit4\headless_2.0.0\lib rary.xml (Le
chemin d'accÚs spécifié est introuvable)

I don't know what I miss. Thanks in advance for your help.
Previous Topic:value of property "all.buildId"
Next Topic:generate a report with ANT
Goto Forum:
  


Current Time: Fri Aug 29 16:21:20 EDT 2014

Powered by FUDForum. Page generated in 0.02512 seconds