Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Mobile Tools for Java (MTJ) » An Error during importing nokia sdk into MTJþ
An Error during importing nokia sdk into MTJþ [message #29591] Thu, 21 May 2009 09:38 Go to next message
caoyong is currently offline caoyongFriend
Messages: 2
Registered: July 2009
Junior Member
I have installed eclipse 3.4.1 and mtj. And I installed the
S60_3rd_MIDP_SDK_FP1 of nokia. But when i import device from

'S60_3rd_MIDP_SDK_FP1' , there is exception below.


java.lang.NullPointerException'


So can MTJ integrate with 'S60_3rd_MIDP_SDK_FP1' ,or not?

Please help me to solve this problem.
Re: An Error during importing nokia sdk into MTJþ [message #29611 is a reply to message #29591] Thu, 21 May 2009 13:24 Go to previous messageGo to next message
Gustavo de Paula is currently offline Gustavo de PaulaFriend
Messages: 118
Registered: July 2009
Senior Member
hi,

which mtj version are you using? are you using windows xp?

:)
gep

caoyong wrote:

> I have installed eclipse 3.4.1 and mtj. And I installed the
> S60_3rd_MIDP_SDK_FP1 of nokia. But when i import device from

> 'S60_3rd_MIDP_SDK_FP1' , there is exception below.


> java.lang.NullPointerException'


> So can MTJ integrate with 'S60_3rd_MIDP_SDK_FP1' ,or not?

> Please help me to solve this problem.
Re: An Error during importing nokia sdk into MTJþ [message #30036 is a reply to message #29591] Fri, 22 May 2009 10:28 Go to previous messageGo to next message
Brian J. Sayatovic is currently offline Brian J. SayatovicFriend
Messages: 2
Registered: July 2009
Junior Member
I'm also having trouble, leading me to the same question: does MTJ support
the Nokia S60 SDK?

When I installed MTJ from the update site
(http://download.eclipse.org/dsdp/mtj/updates/1.0/stable/) into my eclipse
3.4.1 installation, Pulsar wouldn't install saying it couldn't work out
the dependencies right. But it did install "Mobile Tools for Java".

Then when I try to import the Nokia SDK, it simply thinks there is none
there in the folder where the SDK is installed (I also tried parent and
child directories).

If anyone has gotten this working, can they described the exact versions
of everything they tried?
Re: An Error during importing nokia sdk into MTJþ [message #30491 is a reply to message #30036] Tue, 26 May 2009 11:29 Go to previous messageGo to next message
Gustavo de Paula is currently offline Gustavo de PaulaFriend
Messages: 118
Registered: July 2009
Senior Member
i did some tests and you guys are right. MTJ cannot import
nS60_jme_sdk_3rd_e / nS60_jme_sdk_3rd_e_FP1.

i was able to use S60_5th_Edition_SDK_v1.0, but i still need to do more
tests (we usually use nokia serie40 sdks during our tests).

:)
gep
Re: An Error during importing nokia sdk into MTJþ [message #30560 is a reply to message #30036] Wed, 27 May 2009 21:41 Go to previous messageGo to next message
No real name is currently offline No real nameFriend
Messages: 16
Registered: July 2009
Junior Member
I tried the same thing with Eclipse 3.4.2 + MTJ 1.0 RC2. (Nokia S60 3rd
SDK FP1). I don't think it is possible at the moment to work with a
Nokia SDK.


Brian J. Sayatovic schrieb:
> I'm also having trouble, leading me to the same question: does MTJ
> support the Nokia S60 SDK?
>
> When I installed MTJ from the update site
> (http://download.eclipse.org/dsdp/mtj/updates/1.0/stable/) into my
> eclipse 3.4.1 installation, Pulsar wouldn't install saying it couldn't
> work out the dependencies right. But it did install "Mobile Tools for
> Java".
>
> Then when I try to import the Nokia SDK, it simply thinks there is none
> there in the folder where the SDK is installed (I also tried parent and
> child directories).
>
> If anyone has gotten this working, can they described the exact versions
> of everything they tried?
>
Re: An Error during importing nokia sdk into MTJþ [message #30595 is a reply to message #30560] Thu, 28 May 2009 08:34 Go to previous message
Eclipse UserFriend
Originally posted by: gercan.NO_SPAM_acm.org

The statement that "it is not possible to work with a Nokia SDK" is not
true. It is only the S60 3rd Ed. FP1 SDK that has a problem. Later S60
SDKs (S60 3.2, S60 5.0 and the late N97 SDK) have no problems.

I have opened a bug report[1] regarding this problem. I also have a
solution proposal please comment/vote on this bug if it is important to you.

[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=278171
--
Gorkem


Wolfgang Grossinger wrote:
> I tried the same thing with Eclipse 3.4.2 + MTJ 1.0 RC2. (Nokia S60 3rd
> SDK FP1). I don't think it is possible at the moment to work with a
> Nokia SDK.
>
>
> Brian J. Sayatovic schrieb:
>> I'm also having trouble, leading me to the same question: does MTJ
>> support the Nokia S60 SDK?
>>
>> When I installed MTJ from the update site
>> (http://download.eclipse.org/dsdp/mtj/updates/1.0/stable/) into my
>> eclipse 3.4.1 installation, Pulsar wouldn't install saying it couldn't
>> work out the dependencies right. But it did install "Mobile Tools for
>> Java".
>>
>> Then when I try to import the Nokia SDK, it simply thinks there is
>> none there in the folder where the SDK is installed (I also tried
>> parent and child directories).
>>
>> If anyone has gotten this working, can they described the exact
>> versions of everything they tried?
>>
Re: An Error during importing nokia sdk into MTJþ [message #572902 is a reply to message #29591] Thu, 21 May 2009 13:24 Go to previous message
Gustavo de Paula is currently offline Gustavo de PaulaFriend
Messages: 118
Registered: July 2009
Senior Member
hi,

which mtj version are you using? are you using windows xp?

:)
gep

caoyong wrote:

> I have installed eclipse 3.4.1 and mtj. And I installed the
> S60_3rd_MIDP_SDK_FP1 of nokia. But when i import device from

> 'S60_3rd_MIDP_SDK_FP1' , there is exception below.


> java.lang.NullPointerException'


> So can MTJ integrate with 'S60_3rd_MIDP_SDK_FP1' ,or not?

> Please help me to solve this problem.
Re: An Error during importing nokia sdk into MTJþ [message #572929 is a reply to message #29591] Fri, 22 May 2009 10:28 Go to previous message
Brian J. Sayatovic is currently offline Brian J. SayatovicFriend
Messages: 2
Registered: July 2009
Junior Member
I'm also having trouble, leading me to the same question: does MTJ support
the Nokia S60 SDK?

When I installed MTJ from the update site
(http://download.eclipse.org/dsdp/mtj/updates/1.0/stable/) into my eclipse
3.4.1 installation, Pulsar wouldn't install saying it couldn't work out
the dependencies right. But it did install "Mobile Tools for Java".

Then when I try to import the Nokia SDK, it simply thinks there is none
there in the folder where the SDK is installed (I also tried parent and
child directories).

If anyone has gotten this working, can they described the exact versions
of everything they tried?
Re: An Error during importing nokia sdk into MTJþ [message #573417 is a reply to message #30036] Tue, 26 May 2009 11:29 Go to previous message
Gustavo de Paula is currently offline Gustavo de PaulaFriend
Messages: 118
Registered: July 2009
Senior Member
i did some tests and you guys are right. MTJ cannot import
nS60_jme_sdk_3rd_e / nS60_jme_sdk_3rd_e_FP1.

i was able to use S60_5th_Edition_SDK_v1.0, but i still need to do more
tests (we usually use nokia serie40 sdks during our tests).

:)
gep
Re: An Error during importing nokia sdk into MTJþ [message #573498 is a reply to message #30036] Wed, 27 May 2009 21:41 Go to previous message
No real name is currently offline No real nameFriend
Messages: 16
Registered: July 2009
Junior Member
I tried the same thing with Eclipse 3.4.2 + MTJ 1.0 RC2. (Nokia S60 3rd
SDK FP1). I don't think it is possible at the moment to work with a
Nokia SDK.


Brian J. Sayatovic schrieb:
> I'm also having trouble, leading me to the same question: does MTJ
> support the Nokia S60 SDK?
>
> When I installed MTJ from the update site
> (http://download.eclipse.org/dsdp/mtj/updates/1.0/stable/) into my
> eclipse 3.4.1 installation, Pulsar wouldn't install saying it couldn't
> work out the dependencies right. But it did install "Mobile Tools for
> Java".
>
> Then when I try to import the Nokia SDK, it simply thinks there is none
> there in the folder where the SDK is installed (I also tried parent and
> child directories).
>
> If anyone has gotten this working, can they described the exact versions
> of everything they tried?
>
Re: An Error during importing nokia sdk into MTJþ [message #573533 is a reply to message #30560] Thu, 28 May 2009 08:34 Go to previous message
Gorkem Ercan is currently offline Gorkem ErcanFriend
Messages: 61
Registered: July 2009
Member
The statement that "it is not possible to work with a Nokia SDK" is not
true. It is only the S60 3rd Ed. FP1 SDK that has a problem. Later S60
SDKs (S60 3.2, S60 5.0 and the late N97 SDK) have no problems.

I have opened a bug report[1] regarding this problem. I also have a
solution proposal please comment/vote on this bug if it is important to you.

[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=278171
--
Gorkem


Wolfgang Grossinger wrote:
> I tried the same thing with Eclipse 3.4.2 + MTJ 1.0 RC2. (Nokia S60 3rd
> SDK FP1). I don't think it is possible at the moment to work with a
> Nokia SDK.
>
>
> Brian J. Sayatovic schrieb:
>> I'm also having trouble, leading me to the same question: does MTJ
>> support the Nokia S60 SDK?
>>
>> When I installed MTJ from the update site
>> (http://download.eclipse.org/dsdp/mtj/updates/1.0/stable/) into my
>> eclipse 3.4.1 installation, Pulsar wouldn't install saying it couldn't
>> work out the dependencies right. But it did install "Mobile Tools for
>> Java".
>>
>> Then when I try to import the Nokia SDK, it simply thinks there is
>> none there in the folder where the SDK is installed (I also tried
>> parent and child directories).
>>
>> If anyone has gotten this working, can they described the exact
>> versions of everything they tried?
>>
Previous Topic:Mobile Tools for Java 1.0RC2 is now available
Next Topic:hover issue with MTJ
Goto Forum:
  


Current Time: Sun Dec 21 22:31:57 GMT 2014

Powered by FUDForum. Page generated in 0.02432 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software