Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » Versions problem
Versions problem [message #29451] Fri, 27 July 2007 23:47 Go to next message
Tarek is currently offline Tarek
Messages: 19
Registered: July 2009
Junior Member
Dear Paul:

I have used Eclipse 3.2.2, EMF 2.2 and GMF 1.0 to produce my X-machine
plugins.

The problem is the latest JET2 build requires Eclipse 3.3 and EMF 2.3(as
written in the download page).

I've downloaded Eclipse 3.3, EMF 2.3, GMF 2.0 as well as the latest JET2
build with the fixed bugs,and I created EMF editor to test my model.

I was able to generate the code I want from the model produced by the
editor.

The problem is GMF 2.0 is quite different from the one I used. I tried to
produce GMF editot but I got strange errors!.

also, one of the project requirements is to use Eclipse 3.2.2 as the
development platform.

So, is it possible to produce a JET2 version with the fixed bugs
compatible with Eclipse 3.2.2 and ENF 2.2?

Thanks

Tarek
Re: Versions problem [message #29603 is a reply to message #29451] Mon, 30 July 2007 15:31 Go to previous messageGo to next message
Paul Elder is currently offline Paul Elder
Messages: 849
Registered: July 2009
Senior Member
Tarek:

Don't trust those download pages! JET 0.8.0 works perfectly well with
Eclipse 3.2/EMF2.2. The download page just indicates which binaries I built
against - I test against Eclipse 3.2/EMF 2.2 all the time. (JET Editor,
however, does require Eclipse 3.3).

Paul

"Tarek" <howaj2002@yahoo.co.uk> wrote in message
news:11260864d974f10d2e0a28ed4f8a36fd$1@www.eclipse.org...
> Dear Paul:
>
> I have used Eclipse 3.2.2, EMF 2.2 and GMF 1.0 to produce my X-machine
> plugins.
>
> The problem is the latest JET2 build requires Eclipse 3.3 and EMF 2.3(as
> written in the download page).
>
> I've downloaded Eclipse 3.3, EMF 2.3, GMF 2.0 as well as the latest JET2
> build with the fixed bugs,and I created EMF editor to test my model.
>
> I was able to generate the code I want from the model produced by the
> editor.
>
> The problem is GMF 2.0 is quite different from the one I used. I tried to
> produce GMF editot but I got strange errors!.
>
> also, one of the project requirements is to use Eclipse 3.2.2 as the
> development platform.
>
> So, is it possible to produce a JET2 version with the fixed bugs
> compatible with Eclipse 3.2.2 and ENF 2.2?
>
> Thanks
>
> Tarek
>
>
Re: Versions problem [message #30099 is a reply to message #29603] Mon, 30 July 2007 17:16 Go to previous message
Tarek is currently offline Tarek
Messages: 19
Registered: July 2009
Junior Member
Dear Paul:

Thank you vey much for your help.

Best regards

Tarek
Previous Topic:Extending the template compiler
Next Topic:[JET2] Struggling with finding my files during runtime
Goto Forum:
  


Current Time: Thu Oct 30 13:19:51 GMT 2014

Powered by FUDForum. Page generated in 0.02313 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software