Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Service release 0.7.2
Service release 0.7.2 [message #28307] Mon, 04 August 2008 10:07 Go to next message
Eclipse User
Originally posted by: alexander.gurov.polarion.org

Hello All,


We have published Subversive service realease 0.7.2. This release supports
usage of important SVN 1.5 features. Unfortunately introducing this
features made new connectors incompatible with the Subversive version
which is included into the Ganymede simultaneous release because SVN 1.5
has major API changes in compare to 1.4 version.
So, we moved Ganymede-related update sites to the following URLs:
connectors to
http://www.polarion.org/projects/subversive/download/eclipse /2.0/ganymede-site/
and integrations to
http://www.polarion.org/projects/subversive/download/integra tions/ganymede-site/
in order to allows installing of the Ganymede's Subversive version.
Also please note that Subversive 0.7.2 contains lot of fixes in compare to
previous release and it is strongly recommended to update your Subversive
instance to the 0.7.2 one.
Re: Service release 0.7.2 [message #28382 is a reply to message #28307] Mon, 04 August 2008 18:40 Go to previous messageGo to next message
Eclipse User
Originally posted by: noah.roberts.eng-software.com

Alexander Gurov wrote:
> Hello All,
>
> We have published Subversive service realease 0.7.2. This release
> supports usage of important SVN 1.5 features. Unfortunately introducing
> this features made new connectors incompatible with the Subversive
> version which is included into the Ganymede simultaneous release because
> SVN 1.5 has major API changes in compare to 1.4 version.
> So, we moved Ganymede-related update sites to the following URLs:
> connectors to
> http://www.polarion.org/projects/subversive/download/eclipse /2.0/ganymede-site/
>
> and integrations to
> http://www.polarion.org/projects/subversive/download/integra tions/ganymede-site/
> in order to allows installing of the Ganymede's Subversive version. Also
> please note that Subversive 0.7.2 contains lot of fixes in compare to
> previous release and it is strongly recommended to update your
> Subversive instance to the 0.7.2 one.
>

Well, updating this completely broke it. The sites you list above (for
connectors and integrations) do not appear to have anything of a later
date than 20080612, which I have installed.

I added the update site listed here:
http://www.eclipse.org/subversive/downloads.php

It had the 0.7.2 update. I selected the following packages to update:

JavaHL 1.5.0 binaries
Subversion Native Library Adapter
Subversive integration for mylyn
subversive svn connectors
SVN Team Provider
SVNKit 1.2.0
SVNKit Cliend Adapter
SVNKit Library

The versions on these are now respectively:

2.0.1.I20080612-1500
1.5.1
0.7.2.I20080801-1500
2.0.1.I20080612-1500
0.7.2.I20080801-1500
2.0.1.I20080612-1500
1.5.1
1.2.0.4583

I get this error:

SVN: '0x00400006: Validate Repository Location' operation finished with
error: Selected SVN connector library is not available or cannot be loaded.
If you selected native JavaHL connector, please check if binaries are
available or install and select pure Java Subversion connector from the
plug-in connectors update site.
If connectors already installed then you can change the selected one at:
Window->Preferences->Team->SVN->SVN Client.
Selected SVN connector library is not available or cannot be loaded.
If you selected native JavaHL connector, please check if binaries are
available or install and select pure Java Subversion connector from the
plug-in connectors update site.
If connectors already installed then you can change the selected one at:
Window->Preferences->Team->SVN->SVN Client.

The correct path appears to be Preferences->Team->SVN

Select SVN Connector tab.

The list of SVN Connector plugins is then entirely empty.

My bet would be that the 20080612 connectors are not compatible with
0.7.2 but there is nothing more recent in the sites you list nor in any
others I can find. Alternatively there may be a conflict with Subclipse?
Re: Service release 0.7.2 [message #28451 is a reply to message #28382] Mon, 04 August 2008 19:04 Go to previous messageGo to next message
Eclipse User
Originally posted by: noah.roberts.eng-software.com

Noah Roberts wrote:

> My bet would be that the 20080612 connectors are not compatible with
> 0.7.2 but there is nothing more recent in the sites you list nor in any
> others I can find. Alternatively there may be a conflict with Subclipse?

I tried a completely fresh install from the Ganymede CDT installation.
Same results. No SVN connector in the list of connectors.
Re: Service release 0.7.2 [message #28881 is a reply to message #28451] Mon, 04 August 2008 19:20 Go to previous messageGo to next message
Eclipse User
Originally posted by: pazu.pazu.com.br

I can see all conectors, extensions and whatnot, but eclipse can't find
the core plugin (org.eclipse.team.svn.core). Screenshot:

http://screencast.com/t/7ZjrZordmh7
Re: Service release 0.7.2 [message #28894 is a reply to message #28881] Mon, 04 August 2008 19:47 Go to previous messageGo to next message
Eclipse User
Originally posted by: noah.roberts.eng-software.com

Pazu wrote:
> I can see all conectors, extensions and whatnot, but eclipse can't find
> the core plugin (org.eclipse.team.svn.core). Screenshot:
>
> http://screencast.com/t/7ZjrZordmh7
>

WTF?? What site are you using for "Subversive Adapters"? I am NOT
seeing those.

Here's my screenshot:

http://i42.photobucket.com/albums/e306/nroberts-photos/subve rsive.png?t=1217879207
Re: Service release 0.7.2 [message #28916 is a reply to message #28894] Mon, 04 August 2008 19:55 Go to previous messageGo to next message
Eclipse User
Originally posted by: pazu.pazu.com.br

I'm using the following update sites:

Subversive:
http://download.eclipse.org/technology/subversive/0.7/update -site/

Subversive Adapters
http://www.polarion.org/projects/subversive/download/eclipse /2.0/update-site/

I'm on Eclipse 3.3.2 (Europa), by the way. Maybe this explains why we're
seeing different things... yet neither of us can install it :(
Re: Service release 0.7.2 [message #28952 is a reply to message #28916] Mon, 04 August 2008 20:46 Go to previous messageGo to next message
Eclipse User
Originally posted by: pazu.pazu.com.br

Finally managed to install 0.7.2 by building subversive itself from source
and exporting the relevant projects to an extension location. Connectors
were then successfully installed from the updated site.

Something must be wrong with the update site descriptors, preventing the
right plugins from showing up.

I was supposed to be training a team in subversion (using subversive)
tomorrow, and the new merge features in 1.5 (and subversive 0.7.2) are
probably the most interesting part of the training. Hmm... maybe I should
wait a couple days before referring them to the new version, or maybe just
pretend my local copy installed OK, and hope everything will be alright
before the students try to install it by themselves :)
Re: Service release 0.7.2 [message #28990 is a reply to message #28894] Tue, 05 August 2008 03:03 Go to previous messageGo to next message
Eclipse User
Originally posted by: micky_lee.cyberpowersystems.com.tw

I have the same issues as Noah Roberts and Pazu described.

The question is that at these two update-site
1. connectors to
http://www.polarion.org/projects/subversive/download/eclipse /2.0/ganymede-site/
2. integrations to
http://www.polarion.org/projects/subversive/download/integra tions/ganymede-site/

all the jar versions are dated as "2.0.1.I20080612-1500", it seem that it
can't be the compatible version to subversive 0.7.2.

I use newly downloaded ganymede and can't use subversion from ganymede
release date until now...

hope the svn compatible issues could be fixed soon.

thanks for any advice.

Sincerely,
Micky
Re: Service release 0.7.2 [message #29028 is a reply to message #28307] Tue, 05 August 2008 07:58 Go to previous messageGo to next message
Eclipse User
Originally posted by: alexander.gurov.polarion.org

Hello All,

Sorry, seems I should try to describe situation once again. Ganymede
simultaneous release contains Subversive version which build ID is
I20080612-1500.
Ganymede simultaneous service release will be made somewhere in september.
Until this is happened we cannot update Subversive version which is
included to simultaneous release. So, in order to save Ganymede
installation working we moved connectors and integrations with build ID
I20080612-1500 to the new URLs:
http://www.polarion.org/projects/subversive/download/eclipse /2.0/ganymede-site/
and
http://www.polarion.org/projects/subversive/download/integra tions/ganymede-site/
correspondingly.

Newest version is available at the standard Subversive update site URLs:
http://download.eclipse.org/technology/subversive/0.7/update -site/
http://www.polarion.org/projects/subversive/download/eclipse /2.0/update-site/
http://www.polarion.org/projects/subversive/download/integra tions/update-site/

So, please use .../ganymede-site together with the Subversive version from
the Ganymede simultaneous release and .../update-site to get the latest
version.
Re: Service release 0.7.2 [message #29173 is a reply to message #29028] Tue, 05 August 2008 12:13 Go to previous messageGo to next message
Francois Cottet is currently offline Francois Cottet
Messages: 19
Registered: July 2009
Junior Member
Hi all,

Am I the only to find this a bit painful?

I mean 1 month ago the developers updated their eclipse installation
with Ganymede, and I'm pretty sure lot of them also installed the
Subversive plug-in.
And now the update smooth update process is broken because of some new
features in a plug-in??
If there was a need for incompatible versions why didn't you create
another update site like:
http://download.eclipse.org/technology/subversive/0.8/update -site/
http://www.polarion.org/projects/subversive/download/eclipse /2.1/update-site/

http://www.polarion.org/projects/subversive/download/integra tions/2.1/update-site/

Forcing the layman user to modify his configuration is definitely a
practice to avoid.

I'm really thankful for all the work accomplished in Subversive, but
also a bit disappointed by the latest update policy.

Best regards,
Francois


Alexander Gurov wrote:
> Hello All,
> Sorry, seems I should try to describe situation once again. Ganymede
> simultaneous release contains Subversive version which build ID is
> I20080612-1500.
> Ganymede simultaneous service release will be made somewhere in
> september. Until this is happened we cannot update Subversive version
> which is included to simultaneous release. So, in order to save Ganymede
> installation working we moved connectors and integrations with build ID
> I20080612-1500 to the new URLs:
> http://www.polarion.org/projects/subversive/download/eclipse /2.0/ganymede-site/
> and
> http://www.polarion.org/projects/subversive/download/integra tions/ganymede-site/
> correspondingly.
>
> Newest version is available at the standard Subversive update site URLs:
> http://download.eclipse.org/technology/subversive/0.7/update -site/
> http://www.polarion.org/projects/subversive/download/eclipse /2.0/update-site/
> http://www.polarion.org/projects/subversive/download/integra tions/update-site/
>
> So, please use .../ganymede-site together with the Subversive version
> from the Ganymede simultaneous release and .../update-site to get the
> latest version.
>
Re: Service release 0.7.2 [message #29211 is a reply to message #29173] Tue, 05 August 2008 12:23 Go to previous messageGo to next message
Eclipse User
Originally posted by: alexander.gurov.polarion.org

Hello Francois,


>Am I the only to find this a bit painful?
No, we also think that the installation process is to hard, but at this
moment this is the best that we can propose. Following is citation from
the bug 241135:

"I agree with you, but unfortunately we have two conflicting requirements:
the first point is that we should provide users with support of the SVN
1.5 features (exactly merge tracking) as soon as possible (because SVN 1.5
is released a few days later than Eclipse Ganymede), the second point is
that we should graduate our project and this step requires a major changes
in the plug-in functionality. We made these changes while implementing SVN
1.5 support, but if we perform release review in order to make 0.8.0
version, we will lose our chance to graduate Subversive in the nearest
time. So, regarding to this situation we should leave existing major and
minor numbers until plug-in is graduated to 1.0.0 version that also will
point to API changes."

Direct link to the bug:
Build 0.7.1 seems broken, invoking abstract methods
https://bugs.eclipse.org/bugs/show_bug.cgi?id=241135
Re: Service release 0.7.2 [message #29437 is a reply to message #29173] Tue, 05 August 2008 15:24 Go to previous messageGo to next message
Eclipse User
Originally posted by: noah.roberts.eng-software.com

Francois Cottet wrote:
> Hi all,
>
> Am I the only to find this a bit painful?
>
> I mean 1 month ago the developers updated their eclipse installation
> with Ganymede, and I'm pretty sure lot of them also installed the
> Subversive plug-in.
> And now the update smooth update process is broken because of some new
> features in a plug-in??
> If there was a need for incompatible versions why didn't you create
> another update site like:
> http://download.eclipse.org/technology/subversive/0.8/update -site/
> http://www.polarion.org/projects/subversive/download/eclipse /2.1/update-site/
>
> http://www.polarion.org/projects/subversive/download/integra tions/2.1/update-site/
>
>
> Forcing the layman user to modify his configuration is definitely a
> practice to avoid.
>
> I'm really thankful for all the work accomplished in Subversive, but
> also a bit disappointed by the latest update policy.

We're not laymen. We're all software developers, right?
Re: Service release 0.7.2 [message #29508 is a reply to message #29028] Tue, 05 August 2008 16:02 Go to previous messageGo to next message
Eclipse User
Originally posted by: noah.roberts.eng-software.com

Alexander Gurov wrote:

> Newest version is available at the standard Subversive update site URLs:
> http://download.eclipse.org/technology/subversive/0.7/update -site/
> http://www.polarion.org/projects/subversive/download/eclipse /2.0/update-site/
> http://www.polarion.org/projects/subversive/download/integra tions/update-site/

These ones worked for me. Still has my bug, I had remote hopes it wouldn't.
Re: Service release 0.7.2 [message #30014 is a reply to message #29211] Wed, 06 August 2008 06:06 Go to previous messageGo to next message
Francois Cottet is currently offline Francois Cottet
Messages: 19
Registered: July 2009
Junior Member
Alexander Gurov wrote:
> Hello Francois,
>
>> Am I the only to find this a bit painful?
> No, we also think that the installation process is to hard, but at this
> moment this is the best that we can propose.
>
> Direct link to the bug:
> Build 0.7.1 seems broken, invoking abstract methods
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=241135

Actually I understand your will to provide users the best possible
experience of SVN by adding 1.5 features ASAP. But IMHO the first rule
is "do not brake the existing installations", even if this implies some
delays.
Thanks for the direct link to the bug, it helps to understand the pros
and cons. As always it's all about trade-off.

Noah Roberts wrote:
> We're not laymen. We're all software developers, right?

Sorry Noah but even if most of us are developers, not all of us.
And the Eclipse foundation is pushing forward the idea that Eclipse
Platform is much more than an IDE.

Regards,
Francois
Re: Service release 0.7.2 [message #30413 is a reply to message #28307] Wed, 06 August 2008 14:50 Go to previous messageGo to next message
Eclipse User
Originally posted by: afbagwe.sandia.gov

OK, problem with the update.

I'm using Europa (v3.3.2)

The standard update site URL when viewed through my Firefox web browser
clearly shows that the latest 0.7.2 plugin released on Aug 1 is there.

But using both "update installed features" or "search for new features"
inside of Eclipse stubbornly insists that no new software is available.
Yes I've checked the URL... in fact I'm using the remote site URL that
Subversive creates after it is installed the first time.

The upgraded connectors (via the Polarion site) are the only updates
showing as available, but they are blocked from install due to a
dependency error about the missing plugin upgrade.

When will this issue be fixed?

Thanks,
Allen
Re: Service release 0.7.2 [message #30454 is a reply to message #30413] Wed, 06 August 2008 15:40 Go to previous messageGo to next message
Eclipse User
Originally posted by: alexander.gurov.polarion.org

Hello Allen,

I have no issue in the same environment and I've successfully installed
Subversive 0.7.2 into the my Eclipse 3.3.2 instance. The possible reason
for this issue is the proxy (if applicable) which have stale information
cached or any other network issue. In order to avoid the problem you also
can try to download zipped update site and use it in order to install
newest Subversive version.
Re: Service release 0.7.2 [message #30659 is a reply to message #30454] Thu, 07 August 2008 13:45 Go to previous messageGo to next message
Eclipse User
Originally posted by: afbagwe.sandia.gov

I found the source of the problem. I was letting the Eclipse software
install feature automatically select mirrors. It appears that one or maybe
more of the site mirrors were not updated. I just re-tried, picking a
different mirror until I hit one that had the new plugin update.

Thanks!
Re: Service release 0.7.2 [message #30694 is a reply to message #30014] Thu, 07 August 2008 22:42 Go to previous messageGo to next message
Juan Cadavid is currently offline Juan Cadavid
Messages: 49
Registered: July 2009
Location: Rennes, France
Member

Hi all,

I'd like to agree with Francois. I know there's a trade off; I know there
are benefits, and the people who use the advanced features of SVN will
certainly enjoy the new stuff. But these are not certainly all of us. Some
of us are really basic users, who just want to enjoy the simplicity that a
release train like Ganymede offers - download the platform and install
everything you need with a couple of clicks.

By forcing people to lurk newsgroups to know at all times where you want
to move the connectors that should work with the original release, you are
breaking the whole Ganymede experience. Basic users are the ones who end
up screwed. I guess there's not too many of us who just want to connect to
a repository, work on code, and commit it, right?

Besides causing damage to the ones you should satisfy the most, I think
you also broke your commitment to the Eclipse foundation. A release train
only works when each one of the components in it sticks to the build and
update policies, and it seems you have failed to do so. I'm not Ganymede
expert, but isn't the september release supposed to be a maintenance
release, which basically means "No more features; just fix bugs"?
Moreover, why do you call this a "Service Release" and mention at the same
time that you're adding new features?

Thanks a lot for your attention.

-Juan Cadavid
Re: Service release 0.7.2 [message #30796 is a reply to message #30659] Fri, 08 August 2008 16:27 Go to previous messageGo to next message
Andrew Ochsner is currently offline Andrew Ochsner
Messages: 5
Registered: July 2009
Junior Member
Hello Allen,

> I found the source of the problem. I was letting the Eclipse software
> install feature automatically select mirrors. It appears that one or
> maybe more of the site mirrors were not updated. I just re-tried,
> picking a different mirror until I hit one that had the new plugin
> update.
>
> Thanks!
>

Any solution for Eclipse 3.4 users? I don't see anywhere that I can tell
it to look for different mirrors, and I seem to have the same problem you do.

Thanks
Andy O
Re: Service release 0.7.2 [message #31503 is a reply to message #28307] Wed, 13 August 2008 01:42 Go to previous messageGo to next message
Kal Sze is currently offline Kal Sze
Messages: 7
Registered: July 2009
Junior Member
I'm using Ganymede and somehow got the Update Manager to update the
Subversive SVN Connectors and SVN Team Provider plug-ins to
2.0.2.I20080801-1500 and 0.7.2.I20080801-1500 respectively.

Do you mean that these newer versions will fail to operate correctly in
Ganymede even if they can be installed?
Re: Service release 0.7.2 [message #31680 is a reply to message #31503] Wed, 13 August 2008 08:14 Go to previous message
Eclipse User
Originally posted by: alexander.gurov.polarion.org

Kal Sze wrote:

> I'm using Ganymede and somehow got the Update Manager to update the
> Subversive SVN Connectors and SVN Team Provider plug-ins to
> 2.0.2.I20080801-1500 and 0.7.2.I20080801-1500 respectively.

> Do you mean that these newer versions will fail to operate correctly in
> Ganymede even if they can be installed?
No. The configuration described by you will works fine.
Previous Topic:Team>Update not updating recursively
Next Topic:eclipse-jee-ganymede link with subversive
Goto Forum:
  


Current Time: Tue Sep 16 13:36:38 GMT 2014

Powered by FUDForum. Page generated in 0.04824 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software