Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » GEF » Installing GEF in eclipse 3.4
Installing GEF in eclipse 3.4 [message #244500] Wed, 23 July 2008 04:01 Go to next message
Graham is currently offline Graham
Messages: 9
Registered: July 2009
Junior Member
I have been trying to install GEF under eclipse 3.4 without success. I
install from the downloaded zip file rather than using the update site for
several reasons (as detailled at the end of this post).

We are using Eclipse 3.4 RCP as we are developing plugins, and have tried
installing GEF 3.4 into it. I have followed the instructions at
http://wiki.eclipse.org/index.php/GEF_Developer_FAQ#How_do_I _Install_GEF.3F
but they don't work.

I have also tried putting it in the "dropins" directory as detailled in
http://wiki.eclipse.org/Equinox_p2_Getting_Started
but it doesn't pick it up (although it picks up our internally built
plugins)

I know that the RCP version comes with the same version of GEF that I am
trying to install, but it doesn't include the source code (depsite the
Eclipse version info saying that it does) and I need access to that.

How do I install GEF under Eclipse 3.4?



The reasons we use the ZIP file as opposed to the update site are...
1) GEF is used by many people from a single download.
2) Not all users here have an internet connection.
3) We need to ensure that we can survive if for some reason the update
site goes offline as has happened with previous open source projects we
have used.
Re: Installing GEF in eclipse 3.4 [message #244692 is a reply to message #244500] Tue, 29 July 2008 04:39 Go to previous message
Graham is currently offline Graham
Messages: 9
Registered: July 2009
Junior Member
OK, There seems to be some sort of bug in Eclipse where if you put the
same version of GEF in the dropins directory as the one which came with
Eclipse, then it doesn't pick it up... Despite the one in the dropins
directory having more features which are not already in Eclipse.

This can be fixed by either... installing a slightly newer maintenance
release of GEF, or not downloading the RCP version of eclipse, just
install the classic version and download GEF manually.
Previous Topic:How do you use BendPoints with Zest?
Next Topic:custom container
Goto Forum:
  


Current Time: Thu Jul 31 21:50:39 EDT 2014

Powered by FUDForum. Page generated in 0.01502 seconds