Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Hudson » Hudson/Ant issue with Websphere Application Server 7
Hudson/Ant issue with Websphere Application Server 7 [message #1357286] Thu, 15 May 2014 08:56 Go to next message
Keith Zalinger is currently offline Keith Zalinger
Messages: 3
Registered: May 2014
Junior Member
Hello,

Trying to start up Hudson3 war which is installed on WAS 7.0.0.25. I'm seeing the following error message:

"We detected that your servlet container is loading an older version of Ant by itself, thereby preventing Hudson from loading its own newer copy. (Ant classes are loaded from bundleresource://64/org/apache/tools/ant/types/FileSet.class)
Perhaps can you override Ant in your container by copying one from Hudson's WEB-INF/lib, or can you set up the classloader delegation to child-first so that Hudson sees its own copy first?"

Previous searches have pointed out that setting the classloader to child-first will resolve this, at least for WAS6. This does not work for me with WAS7.

Has anyone else run into this that may have discovered another solution? I don't manage the WAS environment, and am not entirely sure how to get at the Ant classes.

Thanks,

-Keith
Re: Hudson/Ant issue with Websphere Application Server 7 [message #1387247 is a reply to message #1357286] Tue, 24 June 2014 17:20 Go to previous messageGo to next message
Pankaj Patni is currently offline Pankaj Patni
Messages: 1
Registered: June 2014
Junior Member
I am facing the same issue, when installed hudson-3.1.2.war on IBM Websphere 8.5.5.0 Crying or Very Sad

Below is the error message shown on the screen :

We detected that your servlet container is loading an older version of Ant by itself, thereby preventing Hudson from loading its own newer copy. (Ant classes are loaded from bundleresource://129.fwk1485515211:4/org/apache/tools/ant/types/FileSet.class)
Perhaps can you override Ant in your container by copying one from Hudson's WEB-INF/lib, or can you set up the classloader delegation to child-first so that Hudson sees its own copy first?



Please let me know, if we have a solution for this here.
Thanks in advance.
Pankaj
Re: Hudson/Ant issue with Websphere Application Server 7 [message #1387771 is a reply to message #1387247] Wed, 25 June 2014 11:15 Go to previous message
Keith Zalinger is currently offline Keith Zalinger
Messages: 3
Registered: May 2014
Junior Member
Hi Pankaj,

I was able to resolve this by having Hudson reference it's Ant jars in a sharedLib. The Websphere server was grabbing old Ant jars from somewhere, but not of my WAS support people could find them, so having the sharedLib with the jars I wanted and child first (or Parent-last, if you prefer) solved the problem.

-Keith
Previous Topic:Install Slave as Windows Service
Next Topic:Improve messages logging for slave nodes
Goto Forum:
  


Current Time: Wed Aug 27 11:15:17 EDT 2014

Powered by FUDForum. Page generated in 0.02033 seconds