Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Strange Launcher Behavior
Strange Launcher Behavior [message #233679] Wed, 15 July 2009 02:38
Steve Cohen is currently offline Steve CohenFriend
Messages: 43
Registered: July 2009
Member
I don't know where to go with this, it seems like it might be a bug but I
can't even understand what I'm seeing, so maybe someone can help me
explain that first.

I have a web application which I launch in development in Tomcat from
Eclipse using the wtp system.

Until recently I always launched it from the server tab by selecting the
server and pressing the start button. This always worked without problem.
Then I decided to persist the configuration using the Common tab of the
Run->Run Configurations menu.

The two launches should be identical since they come from the same root
but they aren't. Only the persisted launch script now works (as the start
button worked before). Open or click on launch script - then Run ->
Tomcat v 6.0 Server at localhost. The old method of clicking the start
button from the Servers window fails soon after it launches with
ClassLoader errors. In my logging right before it fails, I also see
unfamiliar things. In the log4j log entries, the part that shows the name
of the Thread now shows
[ContainerBackgroundProcessor[StandardEngine[Catalina]]] which is
something I've not seen before. In the working version, the same log
entries show [main] as the thread.

How could saving a launch configuration to a .launch file corrupt the
original launch configuration and what might be happening here? Any ideas
on how to fix it?

Platform JDK 1.6 Running on Ubuntu 9.04 in Eclipse Galileo.

Thanks in advance
Previous Topic:Glassfishv3 Startup Failure
Next Topic:Elipse WTP OC4J Redeployment Problem i.e Unable to find/read file META-INF/appli
Goto Forum:
  


Current Time: Sun Nov 23 04:54:50 GMT 2014

Powered by FUDForum. Page generated in 0.01812 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software