Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » ATL » [ATL] Translate BPMN models into UML
[ATL] Translate BPMN models into UML [message #1324035] Wed, 30 April 2014 15:23
abdush mohd is currently offline abdush mohd
Messages: 35
Registered: April 2014
Member
Hi,

This is my first post! I am still new to the world of Eclipse Modeling, so please bear with me Smile

I am trying to generate UML state charts from BPMN 2 process models. I have created an ATL project and added the following metamodel files :

- BPMN20.ecore file from org.eclipse.bpmn2_0.7.0.201308220617.jar as the input metamodel. (I had to add the other BPMNDiagram, DC, DI ecore files also.)
- UML.ecore file from org.eclipse.uml2_4.1.0.v20130902-0826.jar as the output metamodel.

I created a sample process model using Eclipse BPMN project in MDT as the input model for the transformation. The generated file is always serialized as XML and not XMI, is there a way to export the model as XMI or there is no need for it? I have read that the BPMN ecore created in Eclipse is a merge of the two XSD and MOF metamodels specified by OMG, so does that mean that the same ATL transformation module can accept both input files (XML and XMI)?

The transformation file is really simple now, it has one rule to transform the root element of the input model to the root element of the output model. However, the output generated is an empty xmi file. I tried to debug the transformation and it seems that it always terminates and does not execute the rule.

The console output shows:
Metamodel contains several classifiers with same name: DocumentRoot
Metamodel contains several classifiers with same name: DocumentRoot
Metamodel contains several classifiers with same name: di::DocumentRoot
Metamodel contains several classifiers with same name: DocumentRoot

but I guess this is not the issue.
I have checked the input file and it looks fine, I don't know what's wrong.
I have noticed that the Ns URI in the Ecore files is different from the ones in the XML input file ( it has -XMI at the end of the URI) and i tried by removing the XMI part in the ecore files or adding it to the input xml file but still didn't work.

I am using ATL 3.4 and BPMN2 Diagram editor 1.02.

Thanks.
Previous Topic:[EMFTVM] Problem with Back Slash character
Next Topic:[EMFTVM] Exception while loading metamodel
Goto Forum:
  


Current Time: Fri Oct 31 06:31:49 GMT 2014

Powered by FUDForum. Page generated in 0.03004 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software