Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Tomcat 6
Tomcat 6 [message #224256] Tue, 25 November 2008 16:32 Go to next message
Eclipse UserFriend
Originally posted by: nowhere.a.com

I just installed Tomcat 6 to Ganymede 3.4

Now when I start Tomcat from the debug view I get:

----------------------------------
25-Nov-2008 8:30:01 AM
org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context}
Setting property 'source' to 'org.eclipse.jst.j2ee.server:myapp' did
not find a matching property.
25-Nov-2008 8:30:01 AM org.apache.catalina.core.AprLifecycleListener
init
INFO: The APR based Apache Tomcat Native library which allows optimal
performance in production environments was not found on the
java.library.path: C:\Program
Files\Java\jre1.6.0_07\bin;.;C:\Windows\Sun\Java\bin;
25-Nov-2008 8:30:01 AM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
25-Nov-2008 8:30:01 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 357 ms
25-Nov-2008 8:30:01 AM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
25-Nov-2008 8:30:01 AM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.18
25-Nov-2008 8:30:02 AM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
25-Nov-2008 8:30:02 AM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
25-Nov-2008 8:30:02 AM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/47 config=null
25-Nov-2008 8:30:02 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 776 ms
----------------------------------

The only place I found "org.eclipse.jst.j2ee.server:myapp" was in the
web.xml file:
----------------------------------
<Server>
<Service>
<Engine>
<Host>
<Context docBase="myapp"
path="/myapp" reloadable="true"
source="org.eclipse.jst.j2ee.server:myapp"/>
</Host>
</Engine>
</Service>
</Server>
----------------------------------

And there is the "performance in production environments" information
message. This causes an error when a JSP is compiled. It seems to run
OK, but I should not be getting errors.

Tomcat 5 did not show any of these errors.

--
Wojtek :-)
Re: Tomcat 6 [message #224266 is a reply to message #224256] Tue, 25 November 2008 17:08 Go to previous messageGo to next message
Larry Isaacs is currently offline Larry IsaacsFriend
Messages: 1310
Registered: July 2009
Senior Member
Wojtek wrote:
> I just installed Tomcat 6 to Ganymede 3.4
>
> Now when I start Tomcat from the debug view I get:
>
> ----------------------------------
> 25-Nov-2008 8:30:01 AM org.apache.tomcat.util.digester.SetPropertiesRule
> begin
> WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting
> property 'source' to 'org.eclipse.jst.j2ee.server:myapp' did not find a
> matching property.
> 25-Nov-2008 8:30:01 AM org.apache.catalina.core.AprLifecycleListener init
> INFO: The APR based Apache Tomcat Native library which allows optimal
> performance in production environments was not found on the
> java.library.path: C:\Program
> Files\Java\jre1.6.0_07\bin;.;C:\Windows\Sun\Java\bin;
> 25-Nov-2008 8:30:01 AM org.apache.coyote.http11.Http11Protocol init
> INFO: Initializing Coyote HTTP/1.1 on http-8080
> 25-Nov-2008 8:30:01 AM org.apache.catalina.startup.Catalina load
> INFO: Initialization processed in 357 ms
> 25-Nov-2008 8:30:01 AM org.apache.catalina.core.StandardService start
> INFO: Starting service Catalina
> 25-Nov-2008 8:30:01 AM org.apache.catalina.core.StandardEngine start
> INFO: Starting Servlet Engine: Apache Tomcat/6.0.18
> 25-Nov-2008 8:30:02 AM org.apache.coyote.http11.Http11Protocol start
> INFO: Starting Coyote HTTP/1.1 on http-8080
> 25-Nov-2008 8:30:02 AM org.apache.jk.common.ChannelSocket init
> INFO: JK: ajp13 listening on /0.0.0.0:8009
> 25-Nov-2008 8:30:02 AM org.apache.jk.server.JkMain start
> INFO: Jk running ID=0 time=0/47 config=null
> 25-Nov-2008 8:30:02 AM org.apache.catalina.startup.Catalina start
> INFO: Server startup in 776 ms
> ----------------------------------
>
> The only place I found "org.eclipse.jst.j2ee.server:myapp" was in the
> web.xml file:
> ----------------------------------
> <Server>
> <Service>
> <Engine>
> <Host>
> <Context docBase="myapp"
> path="/myapp" reloadable="true"
> source="org.eclipse.jst.j2ee.server:myapp"/>
> </Host>
> </Engine>
> </Service>
> </Server>
> ----------------------------------
>
> And there is the "performance in production environments" information
> message. This causes an error when a JSP is compiled. It seems to run
> OK, but I should not be getting errors.
>
> Tomcat 5 did not show any of these errors.
>

The "source" attribute on the context is how the WTP Tomcat support
tracks which context belongs to which project in your workspace. The
_warning_ is normal and may be ignored. The "source" attribute is
managed internally by WTP and does not need to be included in anything
you would deploy to production. It would not be responsible for any
errors, though differences between Tomcat 5 and Tomcat 6 could.

Cheers,
Larry
Re: Tomcat 6 [message #224274 is a reply to message #224266] Tue, 25 November 2008 17:19 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: nowhere.a.com

Larry Isaacs wrote :
> Wojtek wrote:
>> I just installed Tomcat 6 to Ganymede 3.4
>>
>> Now when I start Tomcat from the debug view I get:
>>
>> ----------------------------------
>> 25-Nov-2008 8:30:01 AM org.apache.tomcat.util.digester.SetPropertiesRule
>> begin
>> WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting
>> property 'source' to 'org.eclipse.jst.j2ee.server:myapp' did not find a
>> matching property.
>> 25-Nov-2008 8:30:01 AM org.apache.catalina.core.AprLifecycleListener init
>> INFO: The APR based Apache Tomcat Native library which allows optimal
>> performance in production environments was not found on the
>> java.library.path: C:\Program
>> Files\Java\jre1.6.0_07\bin;.;C:\Windows\Sun\Java\bin;
>> 25-Nov-2008 8:30:01 AM org.apache.coyote.http11.Http11Protocol init
>> INFO: Initializing Coyote HTTP/1.1 on http-8080
>> 25-Nov-2008 8:30:01 AM org.apache.catalina.startup.Catalina load
>> INFO: Initialization processed in 357 ms
>> 25-Nov-2008 8:30:01 AM org.apache.catalina.core.StandardService start
>> INFO: Starting service Catalina
>> 25-Nov-2008 8:30:01 AM org.apache.catalina.core.StandardEngine start
>> INFO: Starting Servlet Engine: Apache Tomcat/6.0.18
>> 25-Nov-2008 8:30:02 AM org.apache.coyote.http11.Http11Protocol start
>> INFO: Starting Coyote HTTP/1.1 on http-8080
>> 25-Nov-2008 8:30:02 AM org.apache.jk.common.ChannelSocket init
>> INFO: JK: ajp13 listening on /0.0.0.0:8009
>> 25-Nov-2008 8:30:02 AM org.apache.jk.server.JkMain start
>> INFO: Jk running ID=0 time=0/47 config=null
>> 25-Nov-2008 8:30:02 AM org.apache.catalina.startup.Catalina start
>> INFO: Server startup in 776 ms
>> ----------------------------------
>>
>> The only place I found "org.eclipse.jst.j2ee.server:myapp" was in the
>> web.xml file:
>> ----------------------------------
>> <Server>
>> <Service>
>> <Engine>
>> <Host>
>> <Context docBase="myapp"
>> path="/myapp" reloadable="true"
>> source="org.eclipse.jst.j2ee.server:myapp"/>
>> </Host>
>> </Engine>
>> </Service>
>> </Server>
>> ----------------------------------
>>
>> And there is the "performance in production environments" information
>> message. This causes an error when a JSP is compiled. It seems to run OK,
>> but I should not be getting errors.
>>
>> Tomcat 5 did not show any of these errors.
>>
>
> The "source" attribute on the context is how the WTP Tomcat support tracks
> which context belongs to which project in your workspace. The _warning_ is
> normal and may be ignored. The "source" attribute is managed internally by
> WTP and does not need to be included in anything you would deploy to
> production. It would not be responsible for any errors, though differences
> between Tomcat 5 and Tomcat 6 could.

So I can ignore this "red ink" in the console.

Thanks.

--
Wojtek :-)
Re: Tomcat 6 [message #224454 is a reply to message #224266] Wed, 26 November 2008 15:45 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: nowhere.a.com

Larry Isaacs wrote :
> The "source" attribute on the context is how the WTP Tomcat support tracks
> which context belongs to which project in your workspace. The _warning_ is
> normal and may be ignored. The "source" attribute is managed internally by
> WTP and does not need to be included in anything you would deploy to
> production. It would not be responsible for any errors, though differences
> between Tomcat 5 and Tomcat 6 could.

Could you not place this parameter into its own file? Named eclipse.xml
or something? That way Tomcat would not read it and report
warning/errors/info messages etc.

I am assuming that prior to Tomcat 6, the Tomcat xml parser simply
ignored extraneous parameters.

--
Wojtek :-)
Re: Tomcat 6 [message #224477 is a reply to message #224454] Wed, 26 November 2008 17:35 Go to previous messageGo to next message
Larry Isaacs is currently offline Larry IsaacsFriend
Messages: 1310
Registered: July 2009
Senior Member
Wojtek wrote:
> Larry Isaacs wrote :
>> The "source" attribute on the context is how the WTP Tomcat support
>> tracks which context belongs to which project in your workspace. The
>> _warning_ is normal and may be ignored. The "source" attribute is
>> managed internally by WTP and does not need to be included in anything
>> you would deploy to production. It would not be responsible for any
>> errors, though differences between Tomcat 5 and Tomcat 6 could.
>
> Could you not place this parameter into its own file? Named eclipse.xml
> or something? That way Tomcat would not read it and report
> warning/errors/info messages etc.
>
> I am assuming that prior to Tomcat 6, the Tomcat xml parser simply
> ignored extraneous parameters.
>

Unfortunately that would be a fair amount of work for very little
benefit. It's too annoying, modify the catalina.properties file to
include a new location (such as ${catalina.home}/classes) at the
beginning of the common.loader list. Then under that location, create a
compiled version of the org.apache.catalina.core.StandardContext which
has a setSource() method added. The warning should disappear. If you
didn't mind this customization affecting all instances of your Tomcat 6
installation, put the modified class under "${catalina.home}/lib" and
skip modifying catalina.properties.

Cheers,
Larry
Re: Tomcat 6 [message #224783 is a reply to message #224477] Mon, 08 December 2008 18:37 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: nowhere.a.com

Larry Isaacs wrote :
> Wojtek wrote:
>> Larry Isaacs wrote :
>>> The "source" attribute on the context is how the WTP Tomcat support tracks
>>> which context belongs to which project in your workspace. The _warning_
>>> is normal and may be ignored. The "source" attribute is managed
>>> internally by WTP and does not need to be included in anything you would
>>> deploy to production. It would not be responsible for any errors, though
>>> differences between Tomcat 5 and Tomcat 6 could.
>>
>> Could you not place this parameter into its own file? Named eclipse.xml or
>> something? That way Tomcat would not read it and report warning/errors/info
>> messages etc.
>>
>> I am assuming that prior to Tomcat 6, the Tomcat xml parser simply ignored
>> extraneous parameters.
>>
>
> Unfortunately that would be a fair amount of work for very little benefit.

I do not understand why it would be a lot of work. You already have an
XML parser, and the code to extract the parameter. You would only need
to feed it a different file. Same for the config writer, simply point
it at a different file.

I am not trying to be snippy, I just do not understand.

> It's too annoying, modify the catalina.properties file to include a new
> location (such as ${catalina.home}/classes) at the beginning of the
> common.loader list. Then under that location, create a compiled version of
> the org.apache.catalina.core.StandardContext which has a setSource() method
> added. The warning should disappear. If you didn't mind this customization
> affecting all instances of your Tomcat 6 installation, put the modified class
> under "${catalina.home}/lib" and skip modifying catalina.properties.

I cannot locate org.apache.catalina.core.StandardContext. Do I need the
Tomcat source?

BTW, I also get:

Dec 8, 2008 10:19:06 AM org.apache.tomcat.util.http.Parameters
processParameters
WARNING: Parameters: Invalid chunk ignored.

For every JSP which is compiled. Is this related?

--
Wojtek :-)
Re: Tomcat 6 [message #224849 is a reply to message #224783] Tue, 09 December 2008 15:36 Go to previous messageGo to next message
Larry Isaacs is currently offline Larry IsaacsFriend
Messages: 1310
Registered: July 2009
Senior Member
Wojtek wrote:
> Larry Isaacs wrote :
>> Wojtek wrote:
>>> Larry Isaacs wrote :
>>>> The "source" attribute on the context is how the WTP Tomcat support
>>>> tracks which context belongs to which project in your workspace.
>>>> The _warning_ is normal and may be ignored. The "source" attribute
>>>> is managed internally by WTP and does not need to be included in
>>>> anything you would deploy to production. It would not be
>>>> responsible for any errors, though differences between Tomcat 5 and
>>>> Tomcat 6 could.
>>>
>>> Could you not place this parameter into its own file? Named
>>> eclipse.xml or something? That way Tomcat would not read it and
>>> report warning/errors/info messages etc.
>>>
>>> I am assuming that prior to Tomcat 6, the Tomcat xml parser simply
>>> ignored extraneous parameters.
>>>
>>
>> Unfortunately that would be a fair amount of work for very little
>> benefit.
>
> I do not understand why it would be a lot of work. You already have an
> XML parser, and the code to extract the parameter. You would only need
> to feed it a different file. Same for the config writer, simply point it
> at a different file.
>
> I am not trying to be snippy, I just do not understand.

I wouldn't say a "fair amount" is necessarily "a lot", but it's not a
trivial code change. With the few cycles I have to work on the WTP
tomcat support, this would take a while to get to the top of the to-do
list. If you would like to look into creating a patch for this, I'll
try to point you to the right places in the source code.

>
>> It's too annoying, modify the catalina.properties file to include a
>> new location (such as ${catalina.home}/classes) at the beginning of
>> the common.loader list. Then under that location, create a compiled
>> version of the org.apache.catalina.core.StandardContext which has a
>> setSource() method added. The warning should disappear. If you
>> didn't mind this customization affecting all instances of your Tomcat
>> 6 installation, put the modified class under "${catalina.home}/lib"
>> and skip modifying catalina.properties.
>
> I cannot locate org.apache.catalina.core.StandardContext. Do I need the
> Tomcat source?

Yes, you would need to grab the source zip or tar.gz that corresponds to
the version of Tomcat you are using.

>
> BTW, I also get:
>
> Dec 8, 2008 10:19:06 AM org.apache.tomcat.util.http.Parameters
> processParameters
> WARNING: Parameters: Invalid chunk ignored.
>
> For every JSP which is compiled. Is this related?
>

This is unrelated. It would seem to be related to request processing,
when something tries to get request parameter values.

Cheers,
Larry
Re: Tomcat 6 (Parameters: Invalid chunk ignored) [message #224931 is a reply to message #224849] Thu, 11 December 2008 01:57 Go to previous message
Eclipse UserFriend
Originally posted by: nowhere.a.com

Larry Isaacs wrote :
>> BTW, I also get:
>>
>> Dec 8, 2008 10:19:06 AM org.apache.tomcat.util.http.Parameters
>> processParameters
>> WARNING: Parameters: Invalid chunk ignored.
>>
>> For every JSP which is compiled. Is this related?
>>
>
> This is unrelated. It would seem to be related to request processing, when
> something tries to get request parameter values.

You fix one thing, another breaks...

IE has a nasty habit of trying to resend form information if the second
of two calls to the same URL does not have any parameters.

So if you have a page with a form and it is submitted, parameters are
passed to the server. If the user chooses the same page again from a
menu (and the menu URL does not have any parameters), then IE will
resend the same parameters as from the original submission, but only
after a warning you that you need a page refresh:

Submit:
/app/servlet?myfield=yes

Menu:
/app/servlet

IE will actually try to send:
/app/servlet?myfield=yes

for the menu call

To get around this, I use an empty parameter string. IE sees something
that looks like a parameter and does not resend the old parameters:

Menu
/app/servlet?=

And this is what TomCat 6 is complaining about. It is harmless, but it
fills up the error log.

So now I need an actual parameter, such as:
/app/servlet?a=a

in the menu.

Posted for anyone else who runs into this.

Explanation:
http://www.nabble.com/Log-warning-after-URL-Querystring-incl ude-%22--%22-td15758085.html

--
Wojtek :-)
Previous Topic:Should I use modelHandler or modelQueryExtensions extension point for enhanced content assist?
Next Topic:Maven2 and WTP
Goto Forum:
  


Current Time: Sun Nov 23 12:17:37 GMT 2014

Powered by FUDForum. Page generated in 0.20619 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software