Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Can't launch servlet
Can't launch servlet [message #221326] Fri, 12 September 2008 20:59 Go to next message
Thomas Lawless is currently offline Thomas Lawless
Messages: 3
Registered: July 2009
Junior Member
I'm having a problem launching a servlet into a web browser (internal or
external) using the Run as > Run on Server context menu. I checked the
eclipse log file and found there is a null pointer exception. I have
pasted the entry from the log file below. Has anyone else seen this issue?

eclipse 3.4
Linux OS (CentOS 5.2)
WebSphere Community Edition (Server)


Entry in eclipse log file:

!SESSION 2008-09-12 16:33:49.877
-----------------------------------------------
eclipse.buildId=I20080617-2000
java.fullversion=J2RE 1.5.0 IBM J9 2.3 Linux x86-32 j9vmxi3223ifx-20080811
(JIT enabled)
J9VM - 20080809_21892_lHdSMr
JIT - 20080620_1845_r8
GC - 200806_19
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86

!ENTRY org.eclipse.ui 2 0 2008-09-12 16:34:01.498
!MESSAGE Warnings while parsing the key bindings from the
'org.eclipse.ui.commands' extension point
!SUBENTRY 1 org.eclipse.ui 2 0 2008-09-12 16:34:01.498
!MESSAGE Cannot bind to an undefined command:
plug-in='org.eclipse.tm.terminal', id='org.eclipse.tm.terminal.command1'
!SUBENTRY 1 org.eclipse.ui 2 0 2008-09-12 16:34:01.498
!MESSAGE Cannot bind to an undefined command:
plug-in='org.eclipse.tm.terminal', id='org.eclipse.tm.terminal.command1'
!SUBENTRY 1 org.eclipse.ui 2 0 2008-09-12 16:34:01.498
!MESSAGE Cannot bind to an undefined command:
plug-in='org.eclipse.tm.terminal', id='org.eclipse.tm.terminal.command1'
!SUBENTRY 1 org.eclipse.ui 2 0 2008-09-12 16:34:01.498
!MESSAGE Cannot bind to an undefined command:
plug-in='org.eclipse.tm.terminal', id='org.eclipse.tm.terminal.command1'
!SUBENTRY 1 org.eclipse.ui 2 0 2008-09-12 16:34:01.498
!MESSAGE Cannot bind to an undefined command:
plug-in='org.eclipse.tm.terminal', id='org.eclipse.tm.terminal.command1'
!SUBENTRY 1 org.eclipse.ui 2 0 2008-09-12 16:34:01.499
!MESSAGE Cannot bind to an undefined command:
plug-in='org.eclipse.tm.terminal', id='org.eclipse.tm.terminal.command1'
!SUBENTRY 1 org.eclipse.ui 2 0 2008-09-12 16:34:01.499
!MESSAGE Cannot bind to an undefined command:
plug-in='org.eclipse.tm.terminal', id='org.eclipse.tm.terminal.command1'
!SUBENTRY 1 org.eclipse.ui 2 0 2008-09-12 16:34:01.499
!MESSAGE Cannot bind to an undefined command:
plug-in='org.eclipse.tm.terminal', id='org.eclipse.tm.terminal.command1'
!SUBENTRY 1 org.eclipse.ui 2 0 2008-09-12 16:34:01.499
!MESSAGE Cannot bind to an undefined command:
plug-in='org.eclipse.tm.terminal', id='org.eclipse.tm.terminal.command1'
!SUBENTRY 1 org.eclipse.ui 2 0 2008-09-12 16:34:01.499
!MESSAGE Cannot bind to an undefined command:
plug-in='org.eclipse.tm.terminal', id='org.eclipse.tm.terminal.command1'

!ENTRY org.eclipse.wst.server.ui 4 0 2008-09-12 16:35:03.171
!MESSAGE Error opening browser
!STACK 0
java.lang.NullPointerException
at
org.eclipse.wst.server.ui.internal.WebLaunchableClient.launc h(WebLaunchableClient.java:39)
at org.eclipse.wst.server.core.internal.Client.launch(Client.ja va:114)
at
org.eclipse.wst.server.ui.internal.LaunchClientJob$1.run(Lau nchClientJob.java:79)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:3 5)
at
org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchr onizer.java:133)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.jav a:3378)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3036)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:2382)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2346)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:21 98)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:493)
at
org.eclipse.core.databinding.observable.Realm.runWithDefault (Realm.java:288)
at
org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:488)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)
at
org.eclipse.ui.internal.ide.application.IDEApplication.start (IDEApplication.java:113)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:193)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:382)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:79)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:618)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
Re: Can't launch servlet [message #222362 is a reply to message #221326] Mon, 29 September 2008 14:50 Go to previous message
Angel Vera is currently offline Angel Vera
Messages: 63
Registered: July 2009
Member

It looks like your browser had problems opening.

What browser are you using? I will try to configure a different browser
using: Preferences > General > Web Browser

Angel

tglawles@us.ibm.com (Thomas Lawless) wrote in
news:69c8026b17b48f83a8a45f8183c66eaa$1@www.eclipse.org:

> I'm having a problem launching a servlet into a web browser (internal
> or external) using the Run as > Run on Server context menu. I checked
> the eclipse log file and found there is a null pointer exception. I
> have pasted the entry from the log file below. Has anyone else seen
> this issue?
>
> eclipse 3.4
> Linux OS (CentOS 5.2)
> WebSphere Community Edition (Server)
>
>
> Entry in eclipse log file:
>
> !SESSION 2008-09-12 16:33:49.877
> -----------------------------------------------
> eclipse.buildId=I20080617-2000
> java.fullversion=J2RE 1.5.0 IBM J9 2.3 Linux x86-32
> j9vmxi3223ifx-20080811 (JIT enabled)
> J9VM - 20080809_21892_lHdSMr
> JIT - 20080620_1845_r8
> GC - 200806_19
> BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
> Command-line arguments: -os linux -ws gtk -arch x86
>
> !ENTRY org.eclipse.ui 2 0 2008-09-12 16:34:01.498
> !MESSAGE Warnings while parsing the key bindings from the
> 'org.eclipse.ui.commands' extension point
> !SUBENTRY 1 org.eclipse.ui 2 0 2008-09-12 16:34:01.498
> !MESSAGE Cannot bind to an undefined command:
> plug-in='org.eclipse.tm.terminal',
> id='org.eclipse.tm.terminal.command1' !SUBENTRY 1 org.eclipse.ui 2 0
> 2008-09-12 16:34:01.498 !MESSAGE Cannot bind to an undefined command:
> plug-in='org.eclipse.tm.terminal',
> id='org.eclipse.tm.terminal.command1' !SUBENTRY 1 org.eclipse.ui 2 0
> 2008-09-12 16:34:01.498 !MESSAGE Cannot bind to an undefined command:
> plug-in='org.eclipse.tm.terminal',
> id='org.eclipse.tm.terminal.command1' !SUBENTRY 1 org.eclipse.ui 2 0
> 2008-09-12 16:34:01.498 !MESSAGE Cannot bind to an undefined command:
> plug-in='org.eclipse.tm.terminal',
> id='org.eclipse.tm.terminal.command1' !SUBENTRY 1 org.eclipse.ui 2 0
> 2008-09-12 16:34:01.498 !MESSAGE Cannot bind to an undefined command:
> plug-in='org.eclipse.tm.terminal',
> id='org.eclipse.tm.terminal.command1' !SUBENTRY 1 org.eclipse.ui 2 0
> 2008-09-12 16:34:01.499 !MESSAGE Cannot bind to an undefined command:
> plug-in='org.eclipse.tm.terminal',
> id='org.eclipse.tm.terminal.command1' !SUBENTRY 1 org.eclipse.ui 2 0
> 2008-09-12 16:34:01.499 !MESSAGE Cannot bind to an undefined command:
> plug-in='org.eclipse.tm.terminal',
> id='org.eclipse.tm.terminal.command1' !SUBENTRY 1 org.eclipse.ui 2 0
> 2008-09-12 16:34:01.499 !MESSAGE Cannot bind to an undefined command:
> plug-in='org.eclipse.tm.terminal',
> id='org.eclipse.tm.terminal.command1' !SUBENTRY 1 org.eclipse.ui 2 0
> 2008-09-12 16:34:01.499 !MESSAGE Cannot bind to an undefined command:
> plug-in='org.eclipse.tm.terminal',
> id='org.eclipse.tm.terminal.command1' !SUBENTRY 1 org.eclipse.ui 2 0
> 2008-09-12 16:34:01.499 !MESSAGE Cannot bind to an undefined command:
> plug-in='org.eclipse.tm.terminal',
> id='org.eclipse.tm.terminal.command1'
>
> !ENTRY org.eclipse.wst.server.ui 4 0 2008-09-12 16:35:03.171
> !MESSAGE Error opening browser
> !STACK 0
> java.lang.NullPointerException
> at
> org.eclipse.wst.server.ui.internal.WebLaunchableClient.launc h
(WebLaunch
> ableClient.java:39)
> at
> org.eclipse.wst.server.core.internal.Client.launch
(Client.java:114
> ) at
> org.eclipse.wst.server.ui.internal.LaunchClientJob$1.run
(LaunchClientJo
> b.java:79)
> at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:3 5)
> at
> org.eclipse.swt.widgets.Synchronizer.runAsyncMessages
(Synchronizer.java
> :133)
> at
> org.eclipse.swt.widgets.Display.runAsyncMessages
(Display.java:3378
> ) at
> org.eclipse.swt.widgets.Display.readAndDispatch
(Display.java:3036)
> at
> org.eclipse.ui.internal.Workbench.runEventLoop
(Workbench.java:2382
> ) at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2346)
> at
> org.eclipse.ui.internal.Workbench.access$4(Workbench.java:21 98)
> at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:493)
> at
> org.eclipse.core.databinding.observable.Realm.runWithDefault
(Realm.java
> :288)
> at
> org.eclipse.ui.internal.Workbench.createAndRunWorkbench
(Workbench.java:
> 488)
> at
> org.eclipse.ui.PlatformUI.createAndRunWorkbench
(PlatformUI.java:14
> 9) at
> org.eclipse.ui.internal.ide.application.IDEApplication.start
(IDEApplica
> tion.java:113)
> at
> org.eclipse.equinox.internal.app.EclipseAppHandle.run
(EclipseAppHandle.
> java:193)
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplic
a
> tion(EclipseAppLauncher.java:110)
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start
(Ecli
> pseAppLauncher.java:79)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run
(EclipseStarter.java
> :382)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run
(EclipseStarter.java
> :179)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke
(NativeMethodAccessorImpl.ja
> va:79)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke
(DelegatingMethodAccesso
> rImpl.java:43)
> at java.lang.reflect.Method.invoke(Method.java:618)
> at
> org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 549)
> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
> at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
>
>
>


Regards,
--
Angel Vera
WTP Server Tools Developer
Previous Topic:Is there a WTP R3.1 p2 repository?
Next Topic:How does one reuse the StructuredTextEditor in an RCP?
Goto Forum:
  


Current Time: Sun Oct 26 05:53:32 GMT 2014

Powered by FUDForum. Page generated in 0.02669 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software