Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » NPE with Classic Update trying to install Aptana plugin
NPE with Classic Update trying to install Aptana plugin [message #219556] Thu, 21 August 2008 23:46 Go to next message
David M. Karr is currently offline David M. KarrFriend
Messages: 355
Registered: July 2009
Senior Member
This may be both the right place and the wrong place to ask this. :)

I'm trying to install the Aptana plugin in Eclipse 3.4 (which effectively
replaces most of the out-of-the-box webtools functionality). Aptana
appears to be slightly behind on getting this to work with Eclipse 3.4, as
they require enabling "Classic Update".

Unfortunately, using Classic Update in 3.4 appears to bomb, for me at
least. When I select "Search for New Features to Install" and click OK,
it chugs for a bit and then the dialog goes away and nothing happens. I
then saw in the console the exception that follows this. I then tried
going through Update again, and it said "Another install/update job is in
progress. Please cancel it and then re-launch this action." As there
doesn't appear to be any way to cancel an install/update job that failed
with an exception, the only way to get rid of this particular error was to
restart Eclipse.

!ENTRY org.eclipse.ui 4 0 2008-08-21 16:24:20.272
!MESSAGE Unhandled event loop exception
!STACK 0
java.lang.NullPointerException
at
org.eclipse.update.internal.ui.model.DiscoveryFolder.contain s(DiscoveryFolder.java:139)
at
org.eclipse.update.internal.ui.model.DiscoveryFolder.addBook marks(DiscoveryFolder.java:130)
at
org.eclipse.update.internal.ui.model.DiscoveryFolder.initial ize(DiscoveryFolder.java:70)
at
org.eclipse.update.internal.ui.model.DiscoveryFolder.getChil dren(DiscoveryFolder.java:147)
at
org.eclipse.update.internal.ui.wizards.SitePage.getAllSiteBo okmarks(SitePage.java:542)
at
org.eclipse.update.internal.ui.wizards.SitePage.access$14(Si tePage.java:538)
at
org.eclipse.update.internal.ui.wizards.SitePage$10.getElemen ts(SitePage.java:304)
at
org.eclipse.jface.viewers.StructuredViewer.getRawChildren(St ructuredViewer.java:937)
at
org.eclipse.jface.viewers.ColumnViewer.getRawChildren(Column Viewer.java:703)
at
org.eclipse.jface.viewers.AbstractTableViewer.getRawChildren (AbstractTableViewer.java:1071)
at
org.eclipse.jface.viewers.StructuredViewer.getFilteredChildr en(StructuredViewer.java:871)
at
org.eclipse.jface.viewers.StructuredViewer.getSortedChildren (Structuriewer.java:994)
Re: NPE with Classic Update trying to install Aptana plugin [message #219565 is a reply to message #219556] Fri, 22 August 2008 00:42 Go to previous message
Eclipse UserFriend
Originally posted by: david_williams.linux.vnet.ibm.com

David Karr wrote:
> This may be both the right place and the wrong place to ask this. :)
>

I don't know what the problem is, or how to fix it, but I can confirm
that a conscious decision was made "to not worry about testing or
supporting Classic Update Manager". We had a hard enough time getting P2
to work!

That said, it _should_ work, and if anyone discovers the problem, a bug
report and patch would be appreciated.
Previous Topic:org.eclipse.wst.wsdl.util.WSDLParser status
Next Topic:How can I customize the Code Template for a new Servlet?
Goto Forum:
  


Current Time: Fri Dec 19 18:23:22 GMT 2014

Powered by FUDForum. Page generated in 0.02462 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software