Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » XText in combination wit ATL
XText in combination wit ATL [message #1297050] Tue, 15 April 2014 11:34 Go to next message
Timm Drevensek is currently offline Timm DrevensekFriend
Messages: 4
Registered: April 2014
Junior Member
Hello,

I already asked this here: http ://stackoverflow.com/questions/22841706/atl-transformation-empty-output but got no answer on how to solve this. Maybe you could help me?

I'm trying to use ATL model to model transformation on a Model, coming from a xText parsed DSL. My problem is, that the ATL does always produces empty output.

I believe that the cause of the problem is located here:
__matchFoobar:4 call MMOF!Classifier;.allInstancesFrom(S):QJ
locals: self=HDL2PAL : ASMModule Calling hdl!Model.allInstancesFrom('IN')
stack: OrderedSet {}
locals: self=HDL2PAL : ASMModule

So it seems that my Model is not connected to the Metamodel or it cannot extract the elements from it.
Fwd: XText in combination wit ATL [message #1297193 is a reply to message #1297050] Tue, 15 April 2014 13:44 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4184
Registered: July 2009
Senior Member
Forwarding to ATL newsgroup

-------- Original Message --------
Subject: XText in combination wit ATL
Date: Tue, 15 Apr 2014 09:30:50 -0400
From: Timm Drevensek <forums-noreply@xxxxxxxx>
Reply-To: Timm Drevensek <forums-noreply@xxxxxxxx>
Organisation: Eclipse Community Forums
Newsgroups: eclipse.modeling.tmf



Hello,

I already asked this here: http ://stackoverflow.com/questions/22841706/atl-transformation-empty-output but got no answer on how to solve this. Maybe you could help me?

I'm trying to use ATL model to model transformation on a Model, coming from a xText parsed DSL. My problem is, that the ATL does always produces empty output.

I believe that the cause of the problem is located here:
__matchFoobar:4 call MMOF!Classifier;.allInstancesFrom(S):QJ
locals: self=HDL2PAL : ASMModule Calling hdl!Model.allInstancesFrom('IN')
stack: OrderedSet {}
locals: self=HDL2PAL : ASMModule

So it seems that my Model is not connected to the Metamodel or it cannot extract the elements from it.
Re: Fwd: XText in combination wit ATL [message #1298620 is a reply to message #1297193] Wed, 16 April 2014 11:39 Go to previous message
Timm Drevensek is currently offline Timm DrevensekFriend
Messages: 4
Registered: April 2014
Junior Member
Might be xText / ATL combination issue?

https://www.eclipse.org/forums/index.php/t/696520/

[Updated on: Wed, 16 April 2014 11:40]

Report message to a moderator

Previous Topic:Can I use external compiler for Xtext?
Next Topic:xText allows to create a Prolog Parser?
Goto Forum:
  


Current Time: Wed Dec 17 23:09:21 GMT 2014

Powered by FUDForum. Page generated in 0.02096 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software