Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » WindowBuilder » Windows Builder erro in mac(Windows Builder erro in mac)
icon8.gif  Windows Builder erro in mac [message #1292436] Fri, 11 April 2014 20:26 Go to next message
Lucas Root is currently offline Lucas RootFriend
Messages: 1
Registered: April 2014
Junior Member
I install the windows builder in my eclipse juno 4.2, when I create a jform I receive a lot of error and at all the errors are this description:

Multiple markers at this line
- Access restriction: The type JFrame is not accessible due to restriction on required library /Library/Java/JavaVirtualMachines/jdk1.8.0.jdk/Contents/Home/jre/lib/rt.jar
- Access restriction: The method setDefaultCloseOperation(int) from the type JFrame is not accessible due to restriction on required library /Library/Java/JavaVirtualMachines/jdk1.8.0.jdk/Contents/Home/jre/
lib/rt.jar
- Access restriction: The field EXIT_ON_CLOSE from the type JFrame is not accessible due to restriction on required library /Library/Java/JavaVirtualMachines/jdk1.8.0.jdk/Contents/Home/jre/lib/rt.jar

How I fix?
Thanks
Re: Windows Builder erro in mac [message #1293896 is a reply to message #1292436] Sun, 13 April 2014 02:06 Go to previous messageGo to next message
Eric Clayberg is currently offline Eric ClaybergFriend
Messages: 886
Registered: July 2009
Location: Boston, MA
Senior Member
Sounds like a problem with your Java installation or your Eclipse setup.

This doesn't have anything to do with WindowBuilder.

Have you tried searching on "java access restriction"?
Re: Windows Builder erro in mac [message #1379091 is a reply to message #1293896] Sat, 24 May 2014 14:55 Go to previous message
a... t... is currently offline a... t...Friend
Messages: 1
Registered: May 2014
Junior Member
Ok , so ... I had a lot of those Access restrictions , too .... On my old notebook it all worked well and on my current machine it didnt (im using windows 7 on both btw).
Eclipse dedicates a default execution environment to your workspace - for me its jre7 / jre8 ! However when you create a project it doesnt even take the default workspace execution environment by default( Grin ) .... It took something other than the standard java jre (which is supposed to be workspace default).

This is how u fix it : right-click on your project - properties - java build path - libraries - select your system library ( for me its "JRE System Library" ) - edit... -
select "Workspace default JRE" (for me jre8 again).

And if you create a new Project and select "Use default JRE(currently 'jre8')" (for me) under "JRE" in the Project Creation Formular it will be automatically selected for every new project you create.

[Updated on: Sat, 24 May 2014 16:26]

Report message to a moderator

Previous Topic:How to resize ViewPart at runtime?
Next Topic:Data Binding to JComboBox
Goto Forum:
  


Current Time: Sun Dec 21 17:23:22 GMT 2014

Powered by FUDForum. Page generated in 0.01704 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software