Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Strange behaviour in creating PDF output(PDF output to file windows vs linux)
Strange behaviour in creating PDF output [message #1292104] Fri, 11 April 2014 14:17 Go to next message
Dirk van de Heetkamp is currently offline Dirk van de HeetkampFriend
Messages: 1
Registered: April 2014
Junior Member
I run and render a report and write it to a ByteArrayOutputStream using BirtRunAndRenderActionHandler.

After that i write the ByteArrayOutputStream to a FileOutputStream using toByteArray().

This should create a PDF with the rendered report.

I i run this on windows i get a PDF which is correct and can be shown by AcrobatReader.
When i run the same software on Linux the resultfile is about one third of the size of the one on windows and AcrobatReader states that the PDF is corrupt.

Can someone give a direction how to solve this please ?
Re: Strange behaviour in creating PDF output [message #1308994 is a reply to message #1292104] Tue, 22 April 2014 11:56 Go to previous message
Bianca D. is currently offline Bianca D.Friend
Messages: 17
Registered: February 2013
Junior Member
I use the IRunAndRenderTask as well and never had any issues on Linux. I don't use a FileOutputStream though. You can give the file name and location to the task with help of PDFRenderOptions.

PDFRenderOption options = new PDFRenderOption();			
options.setOutputFormat(IRenderOption.OUTPUT_FORMAT_PDF);
options.setOutputFileName(filePathAndName);


Hope that works for you as well.

If it doesn't I would recommend posting your code snippet as well as your BIRT and OS version. That always helps the people here to figure out what's wrong.

Best regards
Bianca
Previous Topic:Passing xml file dynamically to birt
Next Topic:no embedding
Goto Forum:
  


Current Time: Fri Nov 21 16:52:04 GMT 2014

Powered by FUDForum. Page generated in 0.10677 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software