Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Web Standard Tools (WST) Project SDK 3.0?
Web Standard Tools (WST) Project SDK 3.0? [message #216081] Wed, 25 June 2008 23:21 Go to next message
John J. Barton is currently offline John J. BartonFriend
Messages: 311
Registered: July 2009
Senior Member
On the ganymede page:
http://ganymede-mirror1.eclipse.org/webtools/downloads/drops /R3.0/R-3.0-20080616152118/
it says to look for updates on
http://download.eclipse.org/webtools/updates/
But that update site has no 3.0 stuff. Does anyone know where to get
WST SDK 3.0?

Thanks,
John.
Re: Web Standard Tools (WST) Project SDK 3.0? [message #216090 is a reply to message #216081] Wed, 25 June 2008 23:46 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3266
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

John J Barton wrote:
> On the ganymede page:
> http://ganymede-mirror1.eclipse.org/webtools/downloads/drops /R3.0/R-3.0-20080616152118/
>
> it says to look for updates on
> http://download.eclipse.org/webtools/updates/
> But that update site has no 3.0 stuff. Does anyone know where to get
> WST SDK 3.0?
>
> Thanks,
> John.
Maybe http://download.eclipse.org/webtools/downloads/ is what you're
looking for?

Russ Bateman
Re: Web Standard Tools (WST) Project SDK 3.0? [message #216104 is a reply to message #216090] Thu, 26 June 2008 00:32 Go to previous messageGo to next message
John J. Barton is currently offline John J. BartonFriend
Messages: 311
Registered: July 2009
Senior Member
Windofkeltia wrote:
> John J Barton wrote:
>> On the ganymede page:
>> http://ganymede-mirror1.eclipse.org/webtools/downloads/drops /R3.0/R-3.0-20080616152118/
>>
>> it says to look for updates on
>> http://download.eclipse.org/webtools/updates/
>> But that update site has no 3.0 stuff. Does anyone know where to get
>> WST SDK 3.0?
>>
>> Thanks,
>> John.
> Maybe http://download.eclipse.org/webtools/downloads/ is what you're
> looking for?
>
> Russ Bateman

Thanks, but the 3.0 link on that page just ends up on the site I
reference above.

The wst-sdk link on the referenced page seems promising but I don't know
how to use it. It seems to be a bunch of plugins and features, but then
what? I loaded it as a Local update site and tried to install Web
Developer Tools SDK, but I got a ton of not helpful errors (below).

Eclipse needs something like debian apt-get....

Cannot complete the request. See the details.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.100.v200 806172000,3.3.100.v200806172000]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.100.v200 806091311,3.3.100.v200806091311]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/[3.4.0 .v20080603-2000-7o7tEAXEFpPqqkXxfeBhgev,3.4.0.v20080603-2000 -7o7tEAXEFpPqqkXxfeBhgev]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/[3.4.0 .v20080603-2000-7o7tEAXEFpPqqoXxgaBhhhq,3.4.0.v20080603-2000 -7o7tEAXEFpPqqoXxgaBhhhq]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.doc.user/[3.4.0.v2 0080606-1215,3.4.0.v20080606-1215]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.doc.user/[3.4.0.v2 0080612-1340,3.4.0.v20080612-1340]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.0.v_872, 3.4.0.v_872]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.0.v_874, 3.4.0.v_874]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui.intro/[3.2.200.v200 80610,3.2.200.v20080610]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui.intro/[3.2.200.v200 80508,3.2.200.v20080508]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.doc.user/[3.4 .0.v20080612-1340,3.4.0.v20080612-1340]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.doc.user/[3.4 .0.v20080606-1625,3.4.0.v20080606-1625]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.debug.core/[3.4.0.v200 80612,3.4.0.v20080612]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.debug.core/[3.4.0.v200 80603,3.4.0.v20080603]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/[1.0 .100.v_872,1.0.100.v_872]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/[1.0 .100.v_874,1.0.100.v_874]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.jar/[ 3.4.0.v20080610-9I96EhtEm-T_5LxIsybz-3MdGZmOA3uwv7Ka_M,3.4.0 .v20080610-9I96EhtEm-T_5LxIsybz-3MdGZmOA3uwv7Ka_M]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.jar/[ 3.4.0.v20080606-9I96EhtEm-T_5LxHpAb07LaiZlo_suwudIZMM,3.4.0. v20080606-9I96EhtEm-T_5LxHpAb07LaiZlo_suwudIZMM]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.feature.jar/[1.0. 0.v20080603-7r7xEHJEJkZu5nE6Q4Qrtvu6JZ9L,1.0.0.v20080603-7r7 xEHJEJkZu5nE6Q4Qrtvu6JZ9L]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.feature.jar/[1.0. 0.v20080603-7r7xEHJEJkZu5mE6Q7QrtvtcHYLL,1.0.0.v20080603-7r7 xEHJEJkZu5mE6Q7QrtvtcHYLL]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.debug.core/[3.4.0.v200 80612,3.4.0.v20080612]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.debug.core/[3.4.0.v200 80603,3.4.0.v20080603]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/[1.0 .100.v_872,1.0.100.v_872]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/[1.0 .100.v_874,1.0.100.v_874]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.base/[3.3.100.v20 080617,3.3.100.v20080617]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.base/[3.3.100.v20 080603,3.3.100.v20080603]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/[3.4.0 .v20080603-2000-7o7tEAXEFpPqqkXxfeBhgev,3.4.0.v20080603-2000 -7o7tEAXEFpPqqkXxfeBhgev]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/[3.4.0 .v20080603-2000-7o7tEAXEFpPqqoXxgaBhhhq,3.4.0.v20080603-2000 -7o7tEAXEFpPqqoXxgaBhhhq]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.doc.user/[3.4.0.v2 0080606-1215,3.4.0.v20080606-1215]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.doc.user/[3.4.0.v2 0080612-1340,3.4.0.v20080612-1340]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.0.v_872, 3.4.0.v_872]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.0.v_874, 3.4.0.v_874]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.100.v200 806172000,3.3.100.v200806172000]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.100.v200 806091311,3.3.100.v200806091311]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui.intro/[3.2.200.v200 80610,3.2.200.v20080610]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui.intro/[3.2.200.v200 80508,3.2.200.v20080508]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.doc.user/[3.4 .0.v20080612-1340,3.4.0.v20080612-1340]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.doc.user/[3.4 .0.v20080606-1625,3.4.0.v20080606-1625]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.jar/[ 3.4.0.v20080610-9I96EhtEm-T_5LxIsybz-3MdGZmOA3uwv7Ka_M,3.4.0 .v20080610-9I96EhtEm-T_5LxIsybz-3MdGZmOA3uwv7Ka_M]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.jar/[ 3.4.0.v20080606-9I96EhtEm-T_5LxHpAb07LaiZlo_suwudIZMM,3.4.0. v20080606-9I96EhtEm-T_5LxHpAb07LaiZlo_suwudIZMM]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.feature.jar/[1.0. 0.v20080603-7r7xEHJEJkZu5nE6Q4Qrtvu6JZ9L,1.0.0.v20080603-7r7 xEHJEJkZu5nE6Q4Qrtvu6JZ9L]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.feature.jar/[1.0. 0.v20080603-7r7xEHJEJkZu5mE6Q7QrtvtcHYLL,1.0.0.v20080603-7r7 xEHJEJkZu5mE6Q7QrtvtcHYLL]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui/[3.4.0.I20080606-13 00,3.4.0.I20080606-1300]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui/[3.4.0.I20080610-12 00,3.4.0.I20080610-1200]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.debug.core/[3.4.0.v200 80612,3.4.0.v20080612]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.debug.core/[3.4.0.v200 80603,3.4.0.v20080603]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/[1.0 .100.v_872,1.0.100.v_872]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/[1.0 .100.v_874,1.0.100.v_874]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.base/[3.3.100.v20 080617,3.3.100.v20080617]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.base/[3.3.100.v20 080603,3.3.100.v20080603]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.ws_ui.feature.feat ure.jar/[3.0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8_SyLNZ,3. 0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8_SyLNZ]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.ws_ui.feature.feat ure.jar/[3.0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8BSyLPX,3. 0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8BSyLPX]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/[3.4.0 .v20080603-2000-7o7tEAXEFpPqqkXxfeBhgev,3.4.0.v20080603-2000 -7o7tEAXEFpPqqkXxfeBhgev]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/[3.4.0 .v20080603-2000-7o7tEAXEFpPqqoXxgaBhhhq,3.4.0.v20080603-2000 -7o7tEAXEFpPqqoXxgaBhhhq]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.doc.user/[3.4.0.v2 0080606-1215,3.4.0.v20080606-1215]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.doc.user/[3.4.0.v2 0080612-1340,3.4.0.v20080612-1340]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help/[3.3.100.v2008051 5,3.3.100.v20080515]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help/[3.3.100.v2008061 0,3.3.100.v20080610]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.0.v_872, 3.4.0.v_872]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.0.v_874, 3.4.0.v_874]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3 .4.0.v3448d,3.4.0.v3448d]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3 .4.0.v3448f,3.4.0.v3448f]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.jar/[3.4.0 .v20080324a-989JERhEk-jWncbGXKK6sjxB,3.4.0.v20080324a-989JER hEk-jWncbGXKK6sjxB]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.jar/[3.4.0 .v20080324a-989JERhEk-jWnd5IY8K5tjxB,3.4.0.v20080324a-989JER hEk-jWnd5IY8K5tjxB]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.0.v3448d,3.4. 0.v3448d]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.0.v3448f,3.4. 0.v3448f]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.100.v200 806172000,3.3.100.v200806172000]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.100.v200 806091311,3.3.100.v200806091311]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui.intro/[3.2.200.v200 80610,3.2.200.v20080610]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui.intro/[3.2.200.v200 80508,3.2.200.v20080508]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.doc.user/[3.4 .0.v20080612-1340,3.4.0.v20080612-1340]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.doc.user/[3.4 .0.v20080606-1625,3.4.0.v20080606-1625]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.jar/[ 3.4.0.v20080610-9I96EhtEm-T_5LxIsybz-3MdGZmOA3uwv7Ka_M,3.4.0 .v20080610-9I96EhtEm-T_5LxIsybz-3MdGZmOA3uwv7Ka_M]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.jar/[ 3.4.0.v20080606-9I96EhtEm-T_5LxHpAb07LaiZlo_suwudIZMM,3.4.0. v20080606-9I96EhtEm-T_5LxHpAb07LaiZlo_suwudIZMM]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.feature.jar/[1.0. 0.v20080603-7r7xEHJEJkZu5nE6Q4Qrtvu6JZ9L,1.0.0.v20080603-7r7 xEHJEJkZu5nE6Q4Qrtvu6JZ9L]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.feature.jar/[1.0. 0.v20080603-7r7xEHJEJkZu5mE6Q7QrtvtcHYLL,1.0.0.v20080603-7r7 xEHJEJkZu5mE6Q7QrtvtcHYLL]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui/[3.4.0.I20080606-13 00,3.4.0.I20080606-1300]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui/[3.4.0.I20080610-12 00,3.4.0.I20080610-1200]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.ws_core.feature.fe ature.jar/[3.0.0.v200806092130-7H7QECXED69XqKfulndY3l7C5J,3. 0.0.v200806092130-7H7QECXED69XqKfulndY3l7C5J]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.ws_core.feature.fe ature.jar/[3.0.0.v200806092130-7H7QECXED69XqKfwlnda1q7C5J,3. 0.0.v200806092130-7H7QECXED69XqKfwlnda1q7C5J]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.debug.core/[3.4.0.v200 80612,3.4.0.v20080612]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.debug.core/[3.4.0.v200 80603,3.4.0.v20080603]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/[1.0 .100.v_872,1.0.100.v_872]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/[1.0 .100.v_874,1.0.100.v_874]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.base/[3.3.100.v20 080617,3.3.100.v20080617]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.base/[3.3.100.v20 080603,3.3.100.v20080603]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.ws_ui.feature.feat ure.jar/[3.0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8_SyLNZ,3. 0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8_SyLNZ]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.ws_ui.feature.feat ure.jar/[3.0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8BSyLPX,3. 0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8BSyLPX]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/[3.4.0 .v20080603-2000-7o7tEAXEFpPqqkXxfeBhgev,3.4.0.v20080603-2000 -7o7tEAXEFpPqqkXxfeBhgev]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/[3.4.0 .v20080603-2000-7o7tEAXEFpPqqoXxgaBhhhq,3.4.0.v20080603-2000 -7o7tEAXEFpPqqoXxgaBhhhq]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.doc.user/[3.4.0.v2 0080606-1215,3.4.0.v20080606-1215]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.doc.user/[3.4.0.v2 0080612-1340,3.4.0.v20080612-1340]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help/[3.3.100.v2008051 5,3.3.100.v20080515]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help/[3.3.100.v2008061 0,3.3.100.v20080610]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.0.v_872, 3.4.0.v_872]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.0.v_874, 3.4.0.v_874]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3 .4.0.v3448d,3.4.0.v3448d]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3 .4.0.v3448f,3.4.0.v3448f]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.jar/[3.4.0 .v20080324a-989JERhEk-jWncbGXKK6sjxB,3.4.0.v20080324a-989JER hEk-jWncbGXKK6sjxB]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.jar/[3.4.0 .v20080324a-989JERhEk-jWnd5IY8K5tjxB,3.4.0.v20080324a-989JER hEk-jWnd5IY8K5tjxB]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.0.v3448d,3.4. 0.v3448d]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.0.v3448f,3.4. 0.v3448f]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.100.v200 806172000,3.3.100.v200806172000]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.100.v200 806091311,3.3.100.v200806091311]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui.intro/[3.2.200.v200 80610,3.2.200.v20080610]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui.intro/[3.2.200.v200 80508,3.2.200.v20080508]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.doc.user/[3.4 .0.v20080612-1340,3.4.0.v20080612-1340]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.doc.user/[3.4 .0.v20080606-1625,3.4.0.v20080606-1625]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.jar/[ 3.4.0.v20080610-9I96EhtEm-T_5LxIsybz-3MdGZmOA3uwv7Ka_M,3.4.0 .v20080610-9I96EhtEm-T_5LxIsybz-3MdGZmOA3uwv7Ka_M]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.jar/[ 3.4.0.v20080606-9I96EhtEm-T_5LxHpAb07LaiZlo_suwudIZMM,3.4.0. v20080606-9I96EhtEm-T_5LxHpAb07LaiZlo_suwudIZMM]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.feature.jar/[1.0. 0.v20080603-7r7xEHJEJkZu5nE6Q4Qrtvu6JZ9L,1.0.0.v20080603-7r7 xEHJEJkZu5nE6Q4Qrtvu6JZ9L]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.feature.jar/[1.0. 0.v20080603-7r7xEHJEJkZu5mE6Q7QrtvtcHYLL,1.0.0.v20080603-7r7 xEHJEJkZu5mE6Q7QrtvtcHYLL]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui/[3.4.0.I20080606-13 00,3.4.0.I20080606-1300]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui/[3.4.0.I20080610-12 00,3.4.0.I20080610-1200]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.ws_core.feature.fe ature.jar/[3.0.0.v200806092130-7H7QECXED69XqKfulndY3l7C5J,3. 0.0.v200806092130-7H7QECXED69XqKfulndY3l7C5J]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.ws_core.feature.fe ature.jar/[3.0.0.v200806092130-7H7QECXED69XqKfwlnda1q7C5J,3. 0.0.v200806092130-7H7QECXED69XqKfwlnda1q7C5J]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.debug.core/[3.4.0.v200 80612,3.4.0.v20080612]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.debug.core/[3.4.0.v200 80603,3.4.0.v20080603]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/[1.0 .100.v_872,1.0.100.v_872]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/[1.0 .100.v_874,1.0.100.v_874]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.base/[3.3.100.v20 080617,3.3.100.v20080617]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.base/[3.3.100.v20 080603,3.3.100.v20080603]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.ws_ui.feature.feat ure.jar/[3.0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8_SyLNZ,3. 0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8_SyLNZ]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.ws_ui.feature.feat ure.jar/[3.0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8BSyLPX,3. 0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8BSyLPX]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/[3.4.0 .v20080603-2000-7o7tEAXEFpPqqkXxfeBhgev,3.4.0.v20080603-2000 -7o7tEAXEFpPqqkXxfeBhgev]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/[3.4.0 .v20080603-2000-7o7tEAXEFpPqqoXxgaBhhhq,3.4.0.v20080603-2000 -7o7tEAXEFpPqqoXxgaBhhhq]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.doc.user/[3.4.0.v2 0080606-1215,3.4.0.v20080606-1215]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.doc.user/[3.4.0.v2 0080612-1340,3.4.0.v20080612-1340]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help/[3.3.100.v2008051 5,3.3.100.v20080515]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help/[3.3.100.v2008061 0,3.3.100.v20080610]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.0.v_872, 3.4.0.v_872]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.0.v_874, 3.4.0.v_874]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3 .4.0.v3448d,3.4.0.v3448d]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3 .4.0.v3448f,3.4.0.v3448f]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.jar/[3.4.0 .v20080324a-989JERhEk-jWncbGXKK6sjxB,3.4.0.v20080324a-989JER hEk-jWncbGXKK6sjxB]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.jar/[3.4.0 .v20080324a-989JERhEk-jWnd5IY8K5tjxB,3.4.0.v20080324a-989JER hEk-jWnd5IY8K5tjxB]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.0.v3448d,3.4. 0.v3448d]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.0.v3448f,3.4. 0.v3448f]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.100.v200 806172000,3.3.100.v200806172000]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.100.v200 806091311,3.3.100.v200806091311]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui.intro/[3.2.200.v200 80610,3.2.200.v20080610]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui.intro/[3.2.200.v200 80508,3.2.200.v20080508]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.doc.user/[3.4 .0.v20080612-1340,3.4.0.v20080612-1340]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.doc.user/[3.4 .0.v20080606-1625,3.4.0.v20080606-1625]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.jar/[ 3.4.0.v20080610-9I96EhtEm-T_5LxIsybz-3MdGZmOA3uwv7Ka_M,3.4.0 .v20080610-9I96EhtEm-T_5LxIsybz-3MdGZmOA3uwv7Ka_M]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.jar/[ 3.4.0.v20080606-9I96EhtEm-T_5LxHpAb07LaiZlo_suwudIZMM,3.4.0. v20080606-9I96EhtEm-T_5LxHpAb07LaiZlo_suwudIZMM]]
can be satisfied.
Unsatisfied dependency: [org.eclipse.wst.web_core.feature.feature.group
3.0.0.v200806110525-7G2EAWAM1n8CSCEz0VT3I8ung0SE] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.ws_core.feature.fe ature.group/[3.0.0.v200806092130-7H7QECXED69XqKfulndY3l7C5J, 3.0.0.v200806092130-7H7QECXED69XqKfulndY3l7C5J]
Unsatisfied dependency: [org.eclipse.wst.ws_ui.feature.feature.group
3.0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8_SyLNZ] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.ws_core.feature.fe ature.group/[3.0.0.v200806092130-7H7QECXED69XqKfulndY3l7C5J, 3.0.0.v200806092130-7H7QECXED69XqKfulndY3l7C5J]
Unsatisfied dependency: [org.eclipse.jst.web_core.feature.feature.group
3.0.0.v200806092130-7M7AERgEFp_acwcEhxa_fS] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.web_core.feature.f eature.group/[3.0.0,4.0.0)
Unsatisfied dependency: [org.eclipse.wst.web_ui.feature.feature.group
3.0.0.v200806110525-7R0ELQE8Krvy5z-NjIludKQn86QP] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.ws_ui.feature.feat ure.group/[3.0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8_SyLNZ, 3.0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8_SyLNZ]
Unsatisfied dependency: [org.eclipse.wst.web_ui.feature.feature.group
3.0.0.v200806110525-7R0ELQE8Krvy5z-NjIludKQn86QP] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.ws_ui.feature.feat ure.group/[3.0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8_SyLNZ, 3.0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8_SyLNZ]
Unsatisfied dependency: [org.eclipse.wst.web_ui.feature.feature.group
3.0.0.v200806110525-7R0ELQE8Krvy5z-NjIludKQn86QP] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.web_core.feature.f eature.group/[3.0.0.v200806110525-7G2EAWAM1n8CSCEz0VT3I8ung0 SE,3.0.0.v200806110525-7G2EAWAM1n8CSCEz0VT3I8ung0SE]
Unsatisfied dependency: [org.eclipse.help.feature.group
1.0.0.v20080603-7r7xEHJEJkZu5mE6Q7QrtvtcHYLL] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.feature.jar/[1.0. 0.v20080603-7r7xEHJEJkZu5mE6Q7QrtvtcHYLL,1.0.0.v20080603-7r7 xEHJEJkZu5mE6Q7QrtvtcHYLL]
Unsatisfied dependency: [org.eclipse.help.feature.group
1.0.0.v20080603-7r7xEHJEJkZu5mE6Q7QrtvtcHYLL] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.base/[3.3.100.v20 080603,3.3.100.v20080603]
Unsatisfied dependency: [org.eclipse.help.feature.group
1.0.0.v20080603-7r7xEHJEJkZu5mE6Q7QrtvtcHYLL] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.group/[3.4 .0.v20080324a-989JERhEk-jWncbGXKK6sjxB,3.4.0.v20080324a-989J ERhEk-jWncbGXKK6sjxB]
Unsatisfied dependency: [org.eclipse.wst.feature.group
3.0.0.v200806092130-7A-8Y8QqN2lf4VSWrI2ek5Pf4k7s] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.web_ui.feature.fea ture.group/[3.0.0.v200806110525-7R0ELQE8Krvy5z-NjIludKQn86QP ,3.0.0.v200806110525-7R0ELQE8Krvy5z-NjIludKQn86QP]
Unsatisfied dependency: [org.eclipse.jst.feature.group
3.0.0.v200806111800-7U-8Y9LIrwYBUV7sHGjhtz0LTrMd] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.web_ui.feature.fea ture.group/[3.0.0,4.0.0)
Unsatisfied dependency: [org.eclipse.jst.feature.group
3.0.0.v200806111800-7U-8Y9LIrwYBUV7sHGjhtz0LTrMd] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.web_ui.feature.fea ture.group/[3.0.0.v200806110525-7R0ELQE8Krvy5z-NjIludKQn86QP ,3.0.0.v200806110525-7R0ELQE8Krvy5z-NjIludKQn86QP]
Unsatisfied dependency: [org.eclipse.jst.feature.group
3.0.0.v200806111800-7U-8Y9LIrwYBUV7sHGjhtz0LTrMd] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jst.web_ui.feature.fea ture.group/[3.0.0.v200806092130-7E4E8ODgvOcQofh27nwFxdFiybAg ,3.0.0.v200806092130-7E4E8ODgvOcQofh27nwFxdFiybAg]
Unsatisfied dependency: [org.eclipse.rcp.feature.group
3.4.0.v20080324a-989JERhEk-jWncbGXKK6sjxB] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.jar/[3.4.0 .v20080324a-989JERhEk-jWncbGXKK6sjxB,3.4.0.v20080324a-989JER hEk-jWncbGXKK6sjxB]
Unsatisfied dependency: [org.eclipse.rcp.feature.group
3.4.0.v20080324a-989JERhEk-jWncbGXKK6sjxB] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3 .4.0.v3448d,3.4.0.v3448d]
Unsatisfied dependency: [org.eclipse.rcp.feature.group
3.4.0.v20080324a-989JERhEk-jWncbGXKK6sjxB] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.0.v3448d,3.4. 0.v3448d]
Unsatisfied dependency: [org.eclipse.wst.ws_ui.feature.feature.group
3.0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8BSyLPX] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.ws_ui.feature.feat ure.jar/[3.0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8BSyLPX,3. 0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8BSyLPX]
Unsatisfied dependency: [org.eclipse.sdk.ide 3.4.0.I20080609-1311]
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.sdk.feature.group/[3.4 .0.v20080522-7O7S-CHEp2gcoErlIGpiL1YNL9ZuBz-hwBrutLz-wGust,3 .4.0.v20080522-7O7S-CHEp2gcoErlIGpiL1YNL9ZuBz-hwBrutLz-wGust ]
Unsatisfied dependency: [org.eclipse.jst.web_ui.feature.feature.group
3.0.0.v200806092130-7E4E8ODgvOcQofh27nwFxdFiybAg] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jst.web_core.feature.f eature.group/[3.0.0.v200806092130-7M7AERgEFp_acwcEhxa_fS,3.0 .0.v200806092130-7M7AERgEFp_acwcEhxa_fS]
Unsatisfied dependency: [org.eclipse.jst.web_ui.feature.feature.group
3.0.0.v200806092130-7E4E8ODgvOcQofh27nwFxdFiybAg] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.web_ui.feature.fea ture.group/[3.0.0,4.0.0)
Unsatisfied dependency: [org.eclipse.platform.feature.group
3.4.0.v20080606-9I96EhtEm-T_5LxHpAb07LaiZlo_suwudIZMM]
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.jar/[ 3.4.0.v20080606-9I96EhtEm-T_5LxHpAb07LaiZlo_suwudIZMM,3.4.0. v20080606-9I96EhtEm-T_5LxHpAb07LaiZlo_suwudIZMM]
Unsatisfied dependency: [org.eclipse.platform.feature.group
3.4.0.v20080606-9I96EhtEm-T_5LxHpAb07LaiZlo_suwudIZMM]
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.debug.core/[3.4.0.v200 80603,3.4.0.v20080603]
Unsatisfied dependency: [org.eclipse.platform.feature.group
3.4.0.v20080606-9I96EhtEm-T_5LxHpAb07LaiZlo_suwudIZMM]
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.feature.group/[1. 0.0.v20080603-7r7xEHJEJkZu5mE6Q7QrtvtcHYLL,1.0.0.v20080603-7 r7xEHJEJkZu5mE6Q7QrtvtcHYLL]
Unsatisfied dependency: [org.eclipse.platform.feature.group
3.4.0.v20080606-9I96EhtEm-T_5LxHpAb07LaiZlo_suwudIZMM]
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui.intro/[3.2.200.v200 80508,3.2.200.v20080508]
Unsatisfied dependency: [org.eclipse.platform.feature.group
3.4.0.v20080606-9I96EhtEm-T_5LxHpAb07LaiZlo_suwudIZMM]
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.100.v200 806091311,3.3.100.v200806091311]
Unsatisfied dependency: [org.eclipse.platform.feature.group
3.4.0.v20080606-9I96EhtEm-T_5LxHpAb07LaiZlo_suwudIZMM]
requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.doc.user/[3.4 .0.v20080606-1625,3.4.0.v20080606-1625]
Unsatisfied dependency: [org.eclipse.jdt.feature.group
3.4.0.v20080603-2000-7o7tEAXEFpPqqkXxfeBhgev] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/[3.4.0 .v20080603-2000-7o7tEAXEFpPqqkXxfeBhgev,3.4.0.v20080603-2000 -7o7tEAXEFpPqqkXxfeBhgev]
Unsatisfied dependency: [org.eclipse.jdt.feature.group
3.4.0.v20080603-2000-7o7tEAXEFpPqqkXxfeBhgev] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.doc.user/[3.4.0.v2 0080606-1215,3.4.0.v20080606-1215]
Unsatisfied dependency: [org.eclipse.jdt.feature.group
3.4.0.v20080603-2000-7o7tEAXEFpPqqkXxfeBhgev] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.0.v_872, 3.4.0.v_872]
Unsatisfied dependency: [org.eclipse.jdt.feature.group
3.4.0.v20080603-2000-7o7tEAXEFpPqqkXxfeBhgev] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/[1.0 .100.v_872,1.0.100.v_872]
Unsatisfied dependency: [org.eclipse.wst.ws_sdk.feature.feature.group
3.0.0.v200805221406-78--9xR9LkMa9JqOqxKp6Khh1h_H] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.ws_ui.feature.feat ure.group/[3.0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8BSyLPX, 3.0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8BSyLPX]
Unsatisfied dependency: [org.eclipse.wst.ws_sdk.feature.feature.group
3.0.0.v200805221406-78--9xR9LkMa9JqOqxKp6Khh1h_H] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.ws_ui.feature.feat ure.group/[3.0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8BSyLPX, 3.0.0.v200806092130-7E2EFFC-2f8feIeqFPNkR8BSyLPX]
Unsatisfied dependency: [org.eclipse.wst.sdk.feature.group
3.0.0.v200806110645-7A-8Y8Pj5N752THM_Pk62dwkDiRH] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.feature.group/[3.0 .0.v200806092130-7A-8Y8QqN2lf4VSWrI2ek5Pf4k7s,3.0.0.v2008060 92130-7A-8Y8QqN2lf4VSWrI2ek5Pf4k7s]
Unsatisfied dependency: [org.eclipse.wst.sdk.feature.group
3.0.0.v200806110645-7A-8Y8Pj5N752THM_Pk62dwkDiRH] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.web_sdk.feature.fe ature.group/[3.0.0.v200806111800-7F--8Xt7e20X3s5q5K6ZCiA-O-t U,3.0.0.v200806111800-7F--8Xt7e20X3s5q5K6ZCiA-O-tU]
Unsatisfied dependency: [org.eclipse.wst.web_sdk.feature.feature.group
3.0.0.v200806111800-7F--8Xt7e20X3s5q5K6ZCiA-O-tU] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.web_ui.feature.fea ture.group/[3.0.0.v200806110525-7R0ELQE8Krvy5z-NjIludKQn86QP ,3.0.0.v200806110525-7R0ELQE8Krvy5z-NjIludKQn86QP]
Unsatisfied dependency: [org.eclipse.wst.web_sdk.feature.feature.group
3.0.0.v200806111800-7F--8Xt7e20X3s5q5K6ZCiA-O-tU] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.ws_sdk.feature.fea ture.group/[3.0.0.v200805221406-78--9xR9LkMa9JqOqxKp6Khh1h_H ,3.0.0.v200805221406-78--9xR9LkMa9JqOqxKp6Khh1h_H]
Unsatisfied dependency: [org.eclipse.wst.ws_core.feature.feature.group
3.0.0.v200806092130-7H7QECXED69XqKfulndY3l7C5J] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.wst.ws_core.feature.fe ature.jar/[3.0.0.v200806092130-7H7QECXED69XqKfulndY3l7C5J,3. 0.0.v200806092130-7H7QECXED69XqKfulndY3l7C5J]
Re: Web Standard Tools (WST) Project SDK 3.0? [message #216120 is a reply to message #216104] Thu, 26 June 2008 02:41 Go to previous messageGo to next message
David Williams is currently offline David WilliamsFriend
Messages: 701
Registered: July 2009
Senior Member
On Wed, 25 Jun 2008 20:32:17 -0400, John J Barton <johnjbarton@johnjbarton.com> wrote:

> Windofkeltia wrote:
>> John J Barton wrote:
>>> On the ganymede page:
>>> http://ganymede-mirror1.eclipse.org/webtools/downloads/drops /R3.0/R-3.0-20080616152118/
>>>
>>> it says to look for updates on
>>> http://download.eclipse.org/webtools/updates/
>>> But that update site has no 3.0 stuff. Does anyone know where to get
>>> WST SDK 3.0?
>>>
>>> Thanks,
>>> John.
>> Maybe http://download.eclipse.org/webtools/downloads/ is what you're
>> looking for?
>>
>> Russ Bateman
>
> Thanks, but the 3.0 link on that page just ends up on the site I
> reference above.
>
> The wst-sdk link on the referenced page seems promising but I don't know
> how to use it. It seems to be a bunch of plugins and features, but then
> what? I loaded it as a Local update site and tried to install Web
> Developer Tools SDK, but I got a ton of not helpful errors (below).
>
> Eclipse needs something like debian apt-get....
>
> Cannot complete the request. See the details.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.100.v200 806172000,3.3.100.v200806172000]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.100.v200 806091311,3.3.100.v200806091311]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/[3.4.0 .v20080603-2000-7o7tEAXEFpPqqkXxfeBhgev,3.4.0.v20080603-2000 -7o7tEAXEFpPqqkXxfeBhgev]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/[3.4.0 .v20080603-2000-7o7tEAXEFpPqqoXxgaBhhhq,3.4.0.v20080603-2000 -7o7tEAXEFpPqqoXxgaBhhhq]]
> can be satisfied.

Let's start at the beginning. And, if you don't mind ... I'll be a bit long winded, instead of giving a direct answer, then maybe you can help us figure out how to communicate better, for what people really need.

Do you _really_ need the SDK? Or, just WST 3.0?
I ask since you say "...The wst-sdk link on the referenced page seems promising but I don't know
how to use it. It seems to be a bunch of plugins and features, but then what?"
I suspect if you really needed the SDK, you would know what, but I could be wrong, so please correct.
(It is a zip file, not update site, and is used for constructing custom installs, along with many of
the pre-reqs earlier on the page by merely unzipping into the same or proscribed locations).

So, assuming WST suffices ... just to make sure ... do you really want "WST"?
We try not to use that term any more, instead calling it "Web Developer Tools" since it consist of the types of tools you need to develop non-java applications and "WST" is not longer a formal project but was re-organized into several pieces (but, I know we haven't cleaned up all our uses of the term).

So, assuming you really do want "Web Developer Tools" (and, only that, not the full Java EE Develoer tools) then the easiest way to get that, is from the Ganymede Update Site ... which comes built in as an update site in the base Eclipse. There you can browse for it, or try the text/type filter at the top ... try typing in "Web" to narrow the list.

The advantage of the Ganymede site, is it has available all the prereqs you might need, and gets them automatically, based on your selection of "Web Developer Tools".

The Webtools speccific update site (currently) assumes you have all the right pre-reqs already installed.
But, there should be plenty of 3.0 stuff there, so if you are not seeing that, then something else is amiss.

And, just to be sure ... you are starting with Eclipse 3.4 .. right? Not Eclipse 3.3? (You need to start with a fresh Eclipse 3.4 so all the update stuff works correclty).

So ... I'm sure there might even be many more questions and twists, but I'll stop here to be sure I'm getting close to answering what you need ... and not rambling on based on some fundamental misunderstanding.

Thanks,
Re: Web Standard Tools (WST) Project SDK 3.0? [message #216283 is a reply to message #216120] Fri, 27 June 2008 20:11 Go to previous messageGo to next message
John J. Barton is currently offline John J. BartonFriend
Messages: 311
Registered: July 2009
Senior Member
David Williams wrote:
> On Wed, 25 Jun 2008 20:32:17 -0400, John J Barton <johnjbarton@johnjbarton.com> wrote:
>
>> Windofkeltia wrote:
>>> John J Barton wrote:
>>>> On the ganymede page:
>>>> http://ganymede-mirror1.eclipse.org/webtools/downloads/drops /R3.0/R-3.0-20080616152118/
>>>>
>>>> it says to look for updates on
>>>> http://download.eclipse.org/webtools/updates/
>>>> But that update site has no 3.0 stuff. Does anyone know where to get
>>>> WST SDK 3.0?
>>>>
>>>> Thanks,
>>>> John.
>>> Maybe http://download.eclipse.org/webtools/downloads/ is what you're
>>> looking for?
>>>
>>> Russ Bateman
>> Thanks, but the 3.0 link on that page just ends up on the site I
>> reference above.
>>
>> The wst-sdk link on the referenced page seems promising but I don't know
>> how to use it. It seems to be a bunch of plugins and features, but then
>> what? I loaded it as a Local update site and tried to install Web
>> Developer Tools SDK, but I got a ton of not helpful errors (below).
>>
>> Eclipse needs something like debian apt-get....
>>
>> Cannot complete the request. See the details.
>> Cannot find a solution where both Match[requiredCapability:
>> org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.100.v200 806172000,3.3.100.v200806172000]]
>> and Match[requiredCapability:
>> org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.100.v200 806091311,3.3.100.v200806091311]]
>> can be satisfied.
>> Cannot find a solution where both Match[requiredCapability:
>> org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/[3.4.0 .v20080603-2000-7o7tEAXEFpPqqkXxfeBhgev,3.4.0.v20080603-2000 -7o7tEAXEFpPqqkXxfeBhgev]]
>> and Match[requiredCapability:
>> org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/[3.4.0 .v20080603-2000-7o7tEAXEFpPqqoXxgaBhhhq,3.4.0.v20080603-2000 -7o7tEAXEFpPqqoXxgaBhhhq]]
>> can be satisfied.
>
> Let's start at the beginning. And, if you don't mind ... I'll be a bit long winded, instead of giving a direct answer, then maybe you can help us figure out how to communicate better, for what people really need.

No problem...

>
> Do you _really_ need the SDK? Or, just WST 3.0?

I need the source for wst loaded into eclipse so when I break into the
code I can figure out what the API really means by watching it in action.

> I ask since you say "...The wst-sdk link on the referenced page seems promising but I don't know
> how to use it. It seems to be a bunch of plugins and features, but then what?"
> I suspect if you really needed the SDK, you would know what, but I could be wrong, so please correct.

Well I really need the source, and from past experience I conclude that
in eclipse "SDK" means "with source".

> (It is a zip file, not update site, and is used for constructing custom installs, along with many of
> the pre-reqs earlier on the page by merely unzipping into the same or proscribed locations).

Which makes it unhelpful in a world that works by incrementally adding
to existing installs.

>
> So, assuming WST suffices ... just to make sure ... do you really want "WST"?

Frankly I have no idea what WST means....

> We try not to use that term any more, instead calling it "Web Developer Tools" since it consist of the types of tools you need to develop non-java applications and "WST" is not longer a formal project but was re-organized into several pieces (but, I know we haven't cleaned up all our uses of the term).

ok by me

>
> So, assuming you really do want "Web Developer Tools" (and, only that, not the full Java EE Develoer tools) then the easiest way to get that, is from the Ganymede Update Site ... which comes built in as an update site in the base Eclipse. There you can browse for it, or try the text/type filter at the top ... try typing in "Web" to narrow the list.

I already have java EE. I want the source for the web developer tools
bit (and ideally the docs that but that seems to be too difficult).

>
> The advantage of the Ganymede site, is it has available all the prereqs you might need, and gets them automatically, based on your selection of "Web Developer Tools".

Too bad the ganymede site does not supply web developer tools source for
3.0.

>
> The Webtools speccific update site (currently) assumes you have all the right pre-reqs already installed.

Which site are do you mean?

> But, there should be plenty of 3.0 stuff there, so if you are not seeing that, then something else is amiss.
>
> And, just to be sure ... you are starting with Eclipse 3.4 .. right? Not Eclipse 3.3? (You need to start with a fresh Eclipse 3.4 so all the update stuff works correclty).

I started with eclipse SDK 3.4RC4 and added stuff for java ee. I can't
use the java ee package because it does not have the source.

>
> So ... I'm sure there might even be many more questions and twists, but I'll stop here to be sure I'm getting close to answering what you need ... and not rambling on based on some fundamental misunderstanding.

As an open source project, eclipse and all of its many variations
should, in my opinion, always have:
1) a source version of every built distro
2) a source update package for every update package.
That would make it easy for people to help find and fix bugs.

>
> Thanks,
>
>
Re: Web Standard Tools (WST) Project SDK 3.0? [message #216307 is a reply to message #216283] Sat, 28 June 2008 05:49 Go to previous messageGo to next message
David Williams is currently offline David WilliamsFriend
Messages: 701
Registered: July 2009
Senior Member
On Fri, 27 Jun 2008 16:11:23 -0400, John J Barton <johnjbarton@johnjbarton.com> wrote:


>
> I started with eclipse SDK 3.4RC4 and added stuff for java ee. I can't
> use the java ee package because it does not have the source.
>

Ok, if you already have Java EE Developer tools, you already have Web Developer Tools, so all you need is the source and docs ...

Once you have something like Java EE Tools installed, you should be able to go to the Web Tools Update site (which at this point will already be in your list of "available sites" (or, perhaps it's "sites to manage").

Click that box (in Manage) to enable it would then list things like "Web Developer Tools SDK". And/or "Java EE Developer Tools SDK".
So ... did you say you don't see those? That sounds like a bug, but I've done it several times, so if you are still having trouble, it might be worth a bug with exactly what steps you follow, attach log files, configuration, etc.


>
> As an open source project, eclipse and all of its many variations
> should, in my opinion, always have:
> 1) a source version of every built distro

The reason we don't, always, is that it would be a lot more than many people want to download, and then double the list if we provided both (such as 7 packages currently to 14 packages). There are many distros available though, (even outside of Eclispe proper) and there are people I know working on improved ways of installing Eclipse, but if you wanted to log a request, a good place to do that is in the Technology's EPP project in bugzilla.


> 2) a source update package for every update package.

This is sort of what we have ... just takes two trips, so far.

> That would make it easy for people to help find and fix bugs.
>

Don't forget, to 'fix bugs' (and provide pathces) you actually need the cvs version, not source ...
but, I know what you mean and we all definitely know it's not great the way it is, and want to make it better. ... Of course, that could also be a way you decide to contribute to the project. :)
Re: Web Standard Tools (WST) Project SDK 3.0? [message #216451 is a reply to message #216307] Mon, 30 June 2008 23:54 Go to previous messageGo to next message
John J. Barton is currently offline John J. BartonFriend
Messages: 311
Registered: July 2009
Senior Member
David Williams wrote:
> On Fri, 27 Jun 2008 16:11:23 -0400, John J Barton <johnjbarton@johnjbarton.com> wrote:
>
>
>> I started with eclipse SDK 3.4RC4 and added stuff for java ee. I can't
>> use the java ee package because it does not have the source.
>>
>
> Ok, if you already have Java EE Developer tools, you already have Web Developer Tools, so all you need is the source and docs ...
>
> Once you have something like Java EE Tools installed, you should be able to go to the Web Tools Update site (which at this point will already be in your list of "available sites" (or, perhaps it's "sites to manage").
>
> Click that box (in Manage) to enable it would then list things like "Web Developer Tools SDK". And/or "Java EE Developer Tools SDK".
> So ... did you say you don't see those? That sounds like a bug, but I've done it several times, so if you are still having trouble, it might be worth a bug with exactly what steps you follow, attach log files, configuration, etc.

Yes I understand that is what should happen and it would be great if it
did. But it doesn't work. After while I get an undecipherable messages
back as I said before, eg:


Cannot complete the request. See the details.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform/]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform/]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.doc.user/]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.doc.user/]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui.intro/]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui.intro/]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.doc.user/]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.doc.user/]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.debug.core/]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.debug.core/]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.jar/]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.jar/]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.feature.jar/]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.feature.jar/]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.debug.core/]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.debug.core/]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.base/]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.help.base/]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.doc.user/]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.doc.user/]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.100.v200 806172000,3.3.100.v200806172000]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.100.v200 806091311,3.3.100.v2008060913
Re: Web Standard Tools (WST) Project SDK 3.0? [message #216509 is a reply to message #216451] Tue, 01 July 2008 16:06 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: dcarver.starstandard.org

John J Barton wrote:
> David Williams wrote:
>> On Fri, 27 Jun 2008 16:11:23 -0400, John J Barton
>> <johnjbarton@johnjbarton.com> wrote:
>>
>>
>>> I started with eclipse SDK 3.4RC4 and added stuff for java ee. I can't
>>> use the java ee package because it does not have the source.
>>>
>>
>> Ok, if you already have Java EE Developer tools, you already have Web
>> Developer Tools, so all you need is the source and docs ...
>> Once you have something like Java EE Tools installed, you should be
>> able to go to the Web Tools Update site (which at this point will
>> already be in your list of "available sites" (or, perhaps it's "sites
>> to manage").
>> Click that box (in Manage) to enable it would then list things like
>> "Web Developer Tools SDK". And/or "Java EE Developer Tools SDK". So
>> ... did you say you don't see those? That sounds like a bug, but I've
>> done it several times, so if you are still having trouble, it might be
>> worth a bug with exactly what steps you follow, attach log files,
>> configuration, etc.
>
> Yes I understand that is what should happen and it would be great if it
> did. But it doesn't work. After while I get an undecipherable messages
> back as I said before, eg:

For some reason it's looking for the Eclipse 3.3 specific binaries,
where you have eclipse 3.4 installed. Are you sure you have selected
the correct SDK package to install? David could there be a problem
with the packaging of the SDK feature and update site that is causing it
to try and resolve the eclipse 3.3 items instead of eclipse 3.4 items?

Dave



>
>
> Cannot complete the request. See the details.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.platform/]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.platform/]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.doc.user/]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.doc.user/]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.ui.intro/]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.ui.intro/]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.platform.doc.user/]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.platform.doc.user/]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.debug.core/]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.debug.core/]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.jar/]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.jar/]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.help.feature.jar/]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.help.feature.jar/]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.debug.core/]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.debug.core/]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.compiler.tool/]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.help.base/]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.help.base/]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.jar/]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.doc.user/]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.doc.user/]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.100.v200 806172000,3.3.100.v200806172000]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.platform/[3.3.100.v200 806091311,3.3.100.v2008060913
>
Re: Web Standard Tools (WST) Project SDK 3.0? [message #216525 is a reply to message #216509] Tue, 01 July 2008 16:59 Go to previous messageGo to next message
John J. Barton is currently offline John J. BartonFriend
Messages: 311
Registered: July 2009
Senior Member
David Carver wrote:
> John J Barton wrote:
>> David Williams wrote:
>>> On Fri, 27 Jun 2008 16:11:23 -0400, John J Barton
>>> <johnjbarton@johnjbarton.com> wrote:
>>>
>>>
>>>> I started with eclipse SDK 3.4RC4 and added stuff for java ee. I can't
>>>> use the java ee package because it does not have the source.
>>>>
>>>
>>> Ok, if you already have Java EE Developer tools, you already have Web
>>> Developer Tools, so all you need is the source and docs ...
>>> Once you have something like Java EE Tools installed, you should be
>>> able to go to the Web Tools Update site (which at this point will
>>> already be in your list of "available sites" (or, perhaps it's "sites
>>> to manage").
>>> Click that box (in Manage) to enable it would then list things like
>>> "Web Developer Tools SDK". And/or "Java EE Developer Tools SDK". So
>>> ... did you say you don't see those? That sounds like a bug, but I've
>>> done it several times, so if you are still having trouble, it might
>>> be worth a bug with exactly what steps you follow, attach log files,
>>> configuration, etc.
>>
>> Yes I understand that is what should happen and it would be great if
>> it did. But it doesn't work. After while I get an undecipherable
>> messages back as I said before, eg:
>
> For some reason it's looking for the Eclipse 3.3 specific binaries,
> where you have eclipse 3.4 installed. Are you sure you have selected
> the correct SDK package to install?

No, I just installed
Eclipse SDK

Version: 3.4.0
Build id: I20080609-1311

what is the correct one?
Re: Web Standard Tools (WST) Project SDK 3.0? [message #216531 is a reply to message #216525] Tue, 01 July 2008 18:01 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: dcarver.starstandard.org

John J Barton wrote:

> No, I just installed
> Eclipse SDK
>
> Version: 3.4.0
> Build id: I20080609-1311
>
> what is the correct one?

I think there is a bug, so I would suggest opening a bugzilla and
pasting the information that you are getting when trying to install.
The dependencies it is complaining about are because it's trying to find
some 3.3 dependencies, when it shouldn't be.
Re: Web Standard Tools (WST) Project SDK 3.0? [message #216619 is a reply to message #216525] Wed, 02 July 2008 12:46 Go to previous messageGo to next message
David Williams is currently offline David WilliamsFriend
Messages: 701
Registered: July 2009
Senior Member
On Tue, 01 Jul 2008 12:59:23 -0400, John J Barton <johnjbarton@johnjbarton.com> wrote:


>
> No, I just installed
> Eclipse SDK
>
> Version: 3.4.0
> Build id: I20080609-1311
>
> what is the correct one?
>


I downloaded the Java EE IDE package, from
http://phoenix.eclipse.org/packages/
unzipped it.
It reports
Build id: I20080617-2000

To check it works as intended, after unzipping it, I went to
software updates, available software, and first had to go to "manage sites" to
'enable' the webtools update site.

I then could see "Java EE Developer Tools SDK", selected it, and "installed" it, and it all all installed ok. Which means, by the way, it only installed the 'source' of what was already installed.

So, 1) why do you think the build ID is different. Are you using a slightly pre-release version?
I wouldn't think it'd matter so much ... but, could be a bug there that's not in the final version.
Or, are you getting yours from another source that might not be current?

2) More imporant, what are your exact steps? I suspect you are not starting with the the complete Java EE IDE package. But, if you start with _only_ the Eclipse SDK, then you need to install all the required pre-req's before installng the SDK.

BTW, I am not doubting something is a-miss here (either literally a bug, or just hard to understand what steps to follow) and I do want to help get to the bottom of this, so hope you keep trying! :)
Re: Web Standard Tools (WST) Project SDK 3.0? [message #216635 is a reply to message #216619] Wed, 02 July 2008 17:43 Go to previous messageGo to next message
John J. Barton is currently offline John J. BartonFriend
Messages: 311
Registered: July 2009
Senior Member
David Williams wrote:
> On Tue, 01 Jul 2008 12:59:23 -0400, John J Barton <johnjbarton@johnjbarton.com> wrote:
>
>
>> No, I just installed
>> Eclipse SDK
>>
>> Version: 3.4.0
>> Build id: I20080609-1311
>>
>> what is the correct one?
>>
>
>
> I downloaded the Java EE IDE package, from
> http://phoenix.eclipse.org/packages/
> unzipped it.
> It reports
> Build id: I20080617-2000

I didn't know about "phoenix", what is it and how did you find it? I
worked off eclipse.org and ganymede. I think. Actually there are so
many packages with slightly different contents and versions I can't
remember what is what.

>
> To check it works as intended, after unzipping it, I went to
> software updates, available software, and first had to go to "manage sites" to
> 'enable' the webtools update site.
>
> I then could see "Java EE Developer Tools SDK", selected it, and "installed" it, and it all all installed ok. Which means, by the way, it only installed the 'source' of what was already installed.
>
> So, 1) why do you think the build ID is different. Are you using a slightly pre-release version?

I installed eclipse-jee-ganymede-M6-win32,
eclipse-rcp-ganymede-m7-win32, eclipse-SDK-3.4RC2, eclipse-SDK-3.4RC4.
But this was at different times and I added stuff to each in an attempt
to get something to work. Eventually eclipse-SDK-3.4RC4 did the trick.


> I wouldn't think it'd matter so much ... but, could be a bug there that's not in the final version.
> Or, are you getting yours from another source that might not be current?
>
> 2) More imporant, what are your exact steps? I suspect you are not starting with the the complete Java EE IDE package. But, if you start with _only_ the Eclipse SDK, then you need to install all the required pre-req's before installng the SDK.

I tried jee early but I could get no work done with out the source. The
eclipse sdk was much closer.

I just don't get this idea that I need to install pre-reqs. This is
2008 right? Of course maybe this attitude makes me miss getting the
install correct...

>
> BTW, I am not doubting something is a-miss here (either literally a bug, or just hard to understand what steps to follow) and I do want to help get to the bottom of this, so hope you keep trying! :)
>

Thanks for your efforts, but now I think this is a lost cause. There are
too many paths and no real way to know which one I took. There is no
real incentive to retrace the steps because the likely out come will be
"oh don't do that" (I'm not being critical, I would say the same under
these circumstances).

Let's think about the simplest thing that we can suggest to avoid this
kind of problem generally. To me that would be an Eclipse Champion for
the major projects, a person who would be the go to person for the
question: what do I install to build a plugin for eclipse? They would
make sure that the diagram on
http://www.eclipse.org/downloads/moreinfo/compare.php
would have source packages all along the way. Is there already such a
resource?
Re: Web Standard Tools (WST) Project SDK 3.0? [message #216663 is a reply to message #216635] Wed, 02 July 2008 23:09 Go to previous messageGo to next message
David Williams is currently offline David WilliamsFriend
Messages: 701
Registered: July 2009
Senior Member
On Wed, 02 Jul 2008 13:43:29 -0400, John J Barton <johnjbarton@johnjbarton.com> wrote:

> Let's think about the simplest thing that we can suggest to avoid this kind of problem generally.

Fine with me ... I thought that's what we were doing :)


> To me that would be an Eclipse Champion for the major projects, a person who would be the go to person
> for the question: what do I install to build a plugin for eclipse?

Yeah, that's me. :) [well, as well as countless others on these newsgroups].

> They would make sure
> that the diagram on
> http://www.eclipse.org/downloads/moreinfo/compare.php
> would have source packages all along the way. Is there already such a resource?

No, no package has all the source for all things. [Some folks are working on improved download/install capabilities, where, for example, to include source or not would be a check box somewhere, but not sure when that page might be ready ... might be weeks, might be months, for all I know (last I heard, it was just an idea being discussed).

The reason I decide not to include the souce in the JEE Package is that I believe 80% of the users of that package are not building new plugins, they are just building web applications (so, they don't need the source, and would not like the 100 Megabytes of extra download for "not used" stuff). And, I was thinking ... apparetly mistakenly ... that those that needed the source would be able to get it easily, once they had JEE package installed.

I'll continue to look for ways to improve things, and look forward to hearing feedback.
Re: Web Standard Tools (WST) Project SDK 3.0? [message #216678 is a reply to message #216663] Thu, 03 July 2008 00:13 Go to previous messageGo to next message
John J. Barton is currently offline John J. BartonFriend
Messages: 311
Registered: July 2009
Senior Member
David Williams wrote:
> The reason I decide not to include the souce in the JEE Package is that I believe 80% of the users of that package are not building new plugins, they are just building web applications (so, they don't need the source, and would not like the 100 Megabytes of extra download for "not used" stuff). And, I was thinking ... apparetly mistakenly ... that those that needed the source would be able to get it easily, once they had JEE package installed.

I think that it could be much higher, say 99% of the users don't want
source. But the 1% that do are creating new value for the other 99%.

Just to wrap this up, let me give you my view of install with source,
even after I have decided that JEE is the right package (since WST was
my goal).

Download JEE from http://www.eclipse.org/downloads/index.php
(Is this my mistake?)
Then what?
If I click on Source Code on that page I end up on cvs info. This is not
what I want, I want the source which exactly corresponds to the download.

If I click on more info for JEE on that page I get a list of plugins,
but no source. Stuck.

Eventually some told me about
http://download.eclipse.org/webtools/updates/ and eventually it had the
3.0 SDK. Even at that I have doubts it may not be the same source as the
code I am running. And if I wanted any other part of JEE source I'd do what?

Maybe its just me,
John.
Re: Web Standard Tools (WST) Project SDK 3.0? [message #216684 is a reply to message #216678] Thu, 03 July 2008 00:13 Go to previous messageGo to next message
David Williams is currently offline David WilliamsFriend
Messages: 701
Registered: July 2009
Senior Member
On Wed, 02 Jul 2008 20:13:24 -0400, John J Barton <johnjbarton@johnjbarton.com> wrote:


>
> Maybe its just me,
>

No, all good points. Appreciate hearing the experiences (yours) being spelled out ... makes it easier to see what's "gone wrong" (on our end, not yours). I'm not positive how to fix, right now, but know we will eventually.

Thanks,
Re: Web Standard Tools (WST) Project SDK 3.0? [message #217736 is a reply to message #216081] Wed, 16 July 2008 20:51 Go to previous messageGo to next message
John J. Barton is currently offline John J. BartonFriend
Messages: 311
Registered: July 2009
Senior Member
John J Barton wrote:
> On the ganymede page:
> http://ganymede-mirror1.eclipse.org/webtools/downloads/drops /R3.0/R-3.0-20080616152118/
>
> it says to look for updates on
> http://download.eclipse.org/webtools/updates/
> But that update site has no 3.0 stuff. Does anyone know where to get
> WST SDK 3.0?
>
> Thanks,
> John.

Unfortunately I am back to the problem again, now that 3.4 is official.

The object of my desire seems like something at least any other person
working on extending WST would need to have:
the JEE package + all of its source + PDE

If I start with eclipse SDK, then I have a lot of the source and I have
PDE. So I just need to add:
the JEE layer + all of its source

But what is that?

I tried to use the Web Tools Update Site and select everything. But
this won't work, the install fails on a bad jar file from EMF. There
does not seem to be a way to fix this.
(https://bugs.eclipse.org/bugs/show_bug.cgi?id=241126)

I tried selecting a few things that made sense to me. But this won't
work, some JEE features are missing (and I don't know which ones since I
don't know the mapping between missing functionality in eclipse and text
in the update screen).

So I need to select just the right subset from the update site to get
JEE + source. How to find that ?

Thanks,
John.
Re: Web Standard Tools (WST) Project SDK 3.0? [message #217801 is a reply to message #217736] Fri, 18 July 2008 00:06 Go to previous message
David Williams is currently offline David WilliamsFriend
Messages: 701
Registered: July 2009
Senior Member
>
> So I need to select just the right subset from the update site to get
> JEE + source. How to find that ?
>

For Ganymede version, after installing runtime, or if using Java EE IDE,
you can go to webtols update site, expand the Web Tools Platfrom (WTP) category,
and select everything that has "SDK" in the name. You'd have to do something similar
for EMF, GEF, DTP, etc., ... whatever you wanted source for.


Many developers "hand build" their own dev. environment from the zips
listed on the download pages. For exmaple,


EMF v2.4 Runtime Minimum executable code. emf-runtime-2.4.0.zip
EMF XSD v2.4 Runtime Minimum executable code. xsd-runtime-2.4.0.zip
Graphical Editing Framework (GEF) GEF-SDK-3.4.0.zip or equivalent
EMF v2.4 Source and Docs ... emf-sourcedoc-2.4.0.zip or equivalent
EMF XSD v2.4 Source and Docs ... xsd-sourcedoc-2.4.0.zip or equivalent
Previous Topic:HTTP Preview Server?
Next Topic:Publishing to WS02
Goto Forum:
  


Current Time: Sat Dec 20 08:58:16 GMT 2014

Powered by FUDForum. Page generated in 0.02462 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software