Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Error loading tomcat server configuration
Error loading tomcat server configuration [message #216011] Tue, 24 June 2008 22:49 Go to next message
Eclipse UserFriend
Originally posted by: cuco2772.gmail.com

Hi,
I was having problems with the ubuntu packaged version of tomcat5.5
loading a blank page so I decided to download tomcat5.5 straight from the
site to the same directory, with a symlink from tomcat5.5 pointing to the
apache-tomcat-5.5.26
install directory so that things that were referencing tomcat5.5 would go
to the directory of the new install instead.

I was successful in adding the New Server runtime but when trying to
define a new
server for the WTP tutorial-1 project I got the following error:

This is in the window that's titled 'New Server'

'Could not load the Tomcat server configuration at
/usr/share/tomcat5.5/conf. The configuration may be corrupt or incomplete.'

Anyone have any ideas on what might be going wrong ? Thanks,

Adam Posner
Re: Error loading tomcat server configuration [message #216018 is a reply to message #216011] Wed, 25 June 2008 12:55 Go to previous messageGo to next message
Larry Isaacs is currently offline Larry IsaacsFriend
Messages: 1310
Registered: July 2009
Senior Member
Adam Posner wrote:
> Hi,
> I was having problems with the ubuntu packaged version of tomcat5.5
> loading a blank page so I decided to download tomcat5.5 straight from
> the site to the same directory, with a symlink from tomcat5.5 pointing
> to the apache-tomcat-5.5.26 install directory so that things that were
> referencing tomcat5.5 would go to the directory of the new install instead.
>
> I was successful in adding the New Server runtime but when trying to
> define a new
> server for the WTP tutorial-1 project I got the following error:
>
> This is in the window that's titled 'New Server'
>
> 'Could not load the Tomcat server configuration at
> /usr/share/tomcat5.5/conf. The configuration may be corrupt or incomplete.'
>
> Anyone have any ideas on what might be going wrong ? Thanks,
>
> Adam Posner
>

See if the following link helps:

http://wiki.eclipse.org/WTP_Tomcat_FAQ#When_I_try_to_create_ a_server.2C_it_says_that_it_.22Could_not_load_the_Tomcat_ser ver_configuration..22_What_is_the_problem.3F

Also, check the Error Log view to see if any more specific information
about the problem is revealed there.

Cheers,
Larry
Re: Error loading tomcat server configuration [message #216074 is a reply to message #216018] Wed, 25 June 2008 21:34 Go to previous message
Eclipse UserFriend
Originally posted by: cuco2772.gmail.com

Thanks, that's very informative and useful info.
Unfortunately I think I may have complicated my situation.
Rather than uninstall the Ubuntu packaged version of tomcat5.5, I
downloaded the
apache-tomcat-5.5.26 from the tomcat site, installed it in the same
directory as the packaged version, then moved the home directory of the
ubuntu tomcat5.5,
(called tomcat5.5) to ubuntu-tomcat5.5. After this I created a symlink
called
tomcat5.5 pointing to the real tomcat install directory,
(called apache-tomcat5.5.26), and proceeded to do the server
configurations for the new tomcat mentioned above within eclipse. Probably
too simplistic of an approach.

My guess is that those 4 configuration files that were mentioned above are
in different locations in the different installs, so eclipse is probably
trying to load the ones from the ubuntu packaged install.
I think I will try uninstalling that one and see what happens.
Previous Topic:[ANN] WTP 3.0 has been released!
Next Topic:Send by HttpClient, receive by IE ?
Goto Forum:
  


Current Time: Thu Nov 27 04:42:55 GMT 2014

Powered by FUDForum. Page generated in 0.03029 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software