Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » EJB 3.0 with eclipse 3.2.2?
EJB 3.0 with eclipse 3.2.2? [message #215725] Wed, 18 June 2008 12:35 Go to next message
Eclipse User
Originally posted by: fbondioli.autentiweb.com

I all

I'm currently stick with eclipse 3.2.2 because I need VE for many of my projects.
Now I need to develop a J2ee project with a Swing client. I would like to use the new J2EE 5.0 and EJB 3.0 features using glassfish.
I've installed the latest WTP 1.5.5 and the glassfish plugin but from what I can see, I can only create EJB 2.1 beans and j2EE 1.4 enterpriese applications

If I'm not wrong, WTP 1.5.5 should support J2EE 5.0 and EJB 3.0, or not?

How can I produce a J2EE 5.0 compliant project with Eclipse 3.2.2 and WTP 1.5.5?

Best regards
FB
Re: EJB 3.0 with eclipse 3.2.2? [message #215734 is a reply to message #215725] Wed, 18 June 2008 13:30 Go to previous messageGo to next message
Eclipse User
Originally posted by: jmordax.terra.es

Fabio B. wrote:
> I all
>
> I'm currently stick with eclipse 3.2.2 because I need VE for many of
> my projects.
> Now I need to develop a J2ee project with a Swing client. I would like
> to use the new J2EE 5.0 and EJB 3.0 features using glassfish.
> I've installed the latest WTP 1.5.5 and the glassfish plugin but from
> what I can see, I can only create EJB 2.1 beans and j2EE 1.4
> enterpriese applications
>
> If I'm not wrong, WTP 1.5.5 should support J2EE 5.0 and EJB 3.0, or not?
>
> How can I produce a J2EE 5.0 compliant project with Eclipse 3.2.2 and
> WTP 1.5.5?
>
> Best regards
> FB
AFAIK, just WTP 3.0 has Java EE 5.0 support. And I think it requires
Eclipse R3.4

Regards,

Chemi.
Re: EJB 3.0 with eclipse 3.2.2? [message #215820 is a reply to message #215734] Thu, 19 June 2008 13:53 Go to previous messageGo to next message
Kaloyan Raev is currently offline Kaloyan Raev
Messages: 188
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Java EE 5 support, including EJB 3.0, comes with WTP 2.0 (Europa).
WTP 3.0 (Ganymede) introduces new UI features to the Java EE 5 support.
WTP 1.5.5 (Callisto) does not support Java EE 5 projects.

Greetings,
Kaloyan

"Chemi" <jmordax@terra.es> wrote in message
news:g3b2k1$6em$1@build.eclipse.org...
> Fabio B. wrote:
>> I all
>>
>> I'm currently stick with eclipse 3.2.2 because I need VE for many of my
>> projects.
>> Now I need to develop a J2ee project with a Swing client. I would like to
>> use the new J2EE 5.0 and EJB 3.0 features using glassfish.
>> I've installed the latest WTP 1.5.5 and the glassfish plugin but from
>> what I can see, I can only create EJB 2.1 beans and j2EE 1.4 enterpriese
>> applications
>>
>> If I'm not wrong, WTP 1.5.5 should support J2EE 5.0 and EJB 3.0, or not?
>>
>> How can I produce a J2EE 5.0 compliant project with Eclipse 3.2.2 and WTP
>> 1.5.5?
>>
>> Best regards
>> FB
> AFAIK, just WTP 3.0 has Java EE 5.0 support. And I think it requires
> Eclipse R3.4
>
> Regards,
>
> Chemi.
Re: EJB 3.0 with eclipse 3.2.2? [message #215835 is a reply to message #215820] Fri, 20 June 2008 12:10 Go to previous message
Eclipse User
Originally posted by: jmordax.terra.es

Kaloyan Raev wrote:
> Java EE 5 support, including EJB 3.0, comes with WTP 2.0 (Europa).
> WTP 3.0 (Ganymede) introduces new UI features to the Java EE 5 support.
> WTP 1.5.5 (Callisto) does not support Java EE 5 projects.
>
> Greetings,
> Kaloyan
Ah, ok. Thanks. I was confused with RAD parallelism.
Previous Topic:jQuery
Next Topic:Stop the red wavy line thing in Javascript?
Goto Forum:
  


Current Time: Wed Sep 17 11:47:38 GMT 2014

Powered by FUDForum. Page generated in 0.03683 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software