Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Migrate to a new Database MySQL
Migrate to a new Database MySQL [message #1258392] Thu, 27 February 2014 10:34 Go to next message
louy koko is currently offline louy kokoFriend
Messages: 20
Registered: October 2013
Junior Member
Hallo all,

I was using the embedded database H2 in Jubula 7.1 and after I faced some troubles and heard from some of you that it is not effienct to our project using H2, then I decided to change to a new database MySQL.

I can now connect my MySQL database with Jubula, but I can not recover my whole project. I follow some instructions which are posted on Bredex Website
http://testing.bredex.de/migration-information.html

I could recover the following three modules, which were faulty before.

1-unbound_modules_concrete_[6.1]
2-unbound_modules_rcp_[6.1]
3-unbound_modules_swt_[6.1]

But some parts in my Project are empty, I tried to go through the instruction stated in the above website

(In the new versions of the unbound modules, check the category deprecated for any modules that are marked as deprecated for this version number. You should find these modules (using e.g. F7 or Show where used) or any Test Steps that use these actions in your project and replace them with the newer version from the unbound modules. Where possible, the new module will be referenced in the deprecated modules. Otherwise, search in the relevant category of the unbound modules to find the newer version.)

It does not work?
Attached is a Foto for more declation of my problem.

Any one can help to update my project to the new database?

Thank you very much.

Louis
Re: Migrate to a new Database MySQL [message #1259266 is a reply to message #1258392] Fri, 28 February 2014 07:34 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1192
Registered: July 2009
Senior Member
Hi,

Could you post a picture of the information in the problems view and say what the tooltip is when you hover over one of the specific problems in the Test Suite browser?

Best regards,
Alex
Re: Migrate to a new Database MySQL [message #1259389 is a reply to message #1259266] Fri, 28 February 2014 10:22 Go to previous messageGo to next message
louy koko is currently offline louy kokoFriend
Messages: 20
Registered: October 2013
Junior Member
Hallo Alexandera,

I restarted Jubula today and connected it with my new MySQL database, I found it works.

That the Unbound_Module became 6.1 instead of 7.1 like the original version before connecting the database is not a problem, correct?

Another thing, I told you about before, As you see from the picture, I have many test suits, Can I run them all at once (Shape 1, Shape2 .....etc)? Every shapes takes around 6 minutes to be excuted.

I made so many test suits because I have them before in one test suit(in the brocken test suit) but always an error occur and I cant run the test till the end. but when I run every single shape alone it works fine.

Thank you for your support.

Louis
Re: Migrate to a new Database MySQL [message #1262399 is a reply to message #1259389] Mon, 03 March 2014 15:47 Go to previous messageGo to next message
louy koko is currently offline louy kokoFriend
Messages: 20
Registered: October 2013
Junior Member
Hallo Alex,

Please see the two attached file are the error file I got and captured file I made, when I lost the connection to my AUT.

After I run shape by shape it is going well. But at some point I am losing the connection to AUT.

For example:
Shape 1 was Ok. Took 5:11 minutes
Shape 2 was Ok. Took 5:05 minutes
Shape 3 was Ok. Took 4:51 minutes
Shape 4 was NOT ok.

Then when I restart Jubula or the computer it works again well.

Shape 5 was Ok. Took 5:07 minutes
Shape 6 was Ok. Took 5:20 minutes
Shape 7 was NOT ok.
I lost the connection again.

I hope you can help me.

Thank you

Louis
Re: Migrate to a new Database MySQL [message #1268456 is a reply to message #1262399] Mon, 10 March 2014 14:16 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1192
Registered: July 2009
Senior Member
Hi,

Can you say whether the test actually still continues even though the error occurs (I know it sounds strange, but I've seen something along those lines before).
Can you also say whether the test does a lot of restarts? It reminds me a little of this bug, maybe you can read and see whether the description sounds similar.

Best regards,
Alex
Re: Migrate to a new Database MySQL [message #1269131 is a reply to message #1268456] Tue, 11 March 2014 12:30 Go to previous messageGo to next message
louy koko is currently offline louy kokoFriend
Messages: 20
Registered: October 2013
Junior Member
Hallo Alex,

Yes. It seems that my problem is similar.

Just to make it clear, there are two ways, where the probelem occurs:

1-You have many test suits(in my example many shapes, each shape has a test suit) and at some point in any of these test suits the connection to AUT is failed.
2-You have only ONE test suit with all Shapes, again we lose the connection to AUT.

Thanks you.
Re: Migrate to a new Database MySQL [message #1272618 is a reply to message #1269131] Tue, 18 March 2014 10:45 Go to previous message
louy koko is currently offline louy kokoFriend
Messages: 20
Registered: October 2013
Junior Member
Hallo all,

If anyone has encountered such a problem, how we can deal with that?
Today I tried to put wait function between each two shapes(Two test cases) and run the test suit with many shapes, but at some point I lost the connection to AUT.
AUT is closed.


Shape1
Shape2
Wait function 3 second
Shape3
Shape4
Wait function 3 second
....
...
and so on

Any ideas or advices.

Thanks
Louis
Previous Topic:How can I select Tabbed Property Sheet Pages
Next Topic:Preparing for the Jubula tutorial at EclipseCon
Goto Forum:
  


Current Time: Thu Dec 18 04:18:47 GMT 2014

Powered by FUDForum. Page generated in 0.18412 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software