Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Gemini » Gemini Blueprint Milestone shipped with OSGi R4.2?
Gemini Blueprint Milestone shipped with OSGi R4.2? [message #1255807] Mon, 24 February 2014 21:03 Go to next message
Martin Baumgartner is currently offline Martin BaumgartnerFriend
Messages: 9
Registered: June 2013
Junior Member
According to this message http://www.eclipse.org/forums/index.php/mv/msg/642416/1237771/#msg_1237771 Gemini Blueprint 2 should be shipped with OSGi R4.3 level.

I downloaded the actual Snapshot and tried to use it in one of my projects, but couldn't without adaption. The problem is, that actual Gemini Blueprint 2 snapshots are shipped with org.osgi.core:4.2.0.

Gemini Blueprint 1.x is shipped org.osgi.core 3.7.2, gb-2 is shipped with version 4.2.0 but should be shipped with 4.3, right?

By taking a look at the sources on grepcode, i wonder why the API of 4.2 is reduced compared 4.3 and 3.7.2
4.3.1: grepcode.com/file/repo1.maven.org/maven2/org.osgi/org.osgi.core/4.3.1/org/osgi/framework/BundleContext.java#BundleContext
4.2.0: grepcode.com/file/repo1.maven.org/maven2/org.osgi/org.osgi.core/4.2.0/org/osgi/framework/BundleContext.java#BundleContext
3.7.2: grepcode.com/file/repository.grepcode.com/java/eclipse.org/3.7.2/org.eclipse/osgi/3.7.2/org/osgi/framework/BundleContext.java#BundleContext

Sorry for the bad links, your forum system says i have to write 5 posts to post external links.

BR
Martin

[Updated on: Mon, 24 February 2014 21:04]

Report message to a moderator

Re: Gemini Blueprint Milestone shipped with OSGi R4.2? [message #1256510 is a reply to message #1255807] Tue, 25 February 2014 14:09 Go to previous messageGo to next message
Dmitry Sklyut is currently offline Dmitry SklyutFriend
Messages: 276
Registered: January 2010
Senior Member
Hello Martin,

You should be getting SNAPSHOT versions for now. Milestones are at 4.2 still.
Looking at https://repo.eclipse.org/index.html#nexus-search;quick~gemini-blueprint, I see gemini-blueprint parent pom (https://repo.eclipse.org/service/local/repositories/gemini-blueprint-snapshots/content/org/eclipse/gemini/blueprint/gemini-blueprint/2.0.0.BUILD-SNAPSHOT/gemini-blueprint-2.0.0.BUILD-20140225.012502-113.pom) locking org.osgi.core at 4.3.1. org.eclipse.osgi 3.7.2 is an implementation of R4.3 spec. You can see if by looking at the manifest headers i.e.:

Export-Package: ...
  org.osgi.framework;version="1.6"


1.6 is R4.3 version, where R4.2 was 1.5 for org.osgi.framework.

if you are using Maven, add the following repository to your pom file:

<repository>
            <id>blueprint-snapshot-repo</id>
            <name>Blueprint Snapshot Repo</name>
            <url>https://repo.eclipse.org/content/repositories/gemini-blueprint-snapshots/</url>
            <snapshots>
                <enabled>true</enabled>
            </snapshots>
        </repository>


Proper version would 2.0.0.BUILD-SNAPSHOT.

Post back here or open a bugzilla issue if you are still facing issues. We will be cutting a new milestone within few weeks that will contain necessary changes for R4.3

Kind regards,

Dmitry

[Updated on: Tue, 25 February 2014 14:11]

Report message to a moderator

Re: Gemini Blueprint Milestone shipped with OSGi R4.2? [message #1263258 is a reply to message #1256510] Tue, 04 March 2014 10:18 Go to previous messageGo to next message
Martin Baumgartner is currently offline Martin BaumgartnerFriend
Messages: 9
Registered: June 2013
Junior Member
Hallo Dimitry,

In the gemini bluprint 2.0 .parent.pom there are repos defined which lead to maven.springframework.org, are those dead urls?

Are those dead repos?

At least, I got a few questions:
Is anyone working on gemini-bluprint-test to add junit4 support?
Is there any maven repository providing current release (1.0.2) of gemini-bueprint including all modules? Spring-EBR will not add any modules and doesnt contain gemini-bp-mock nor g-bp-test, but i need them. Can you upload them to the new eclipse repository?
Is there a release date or roadmap for GB-2.0?

BR,
Martin
Re: Gemini Blueprint Milestone shipped with OSGi R4.2? [message #1265027 is a reply to message #1263258] Wed, 05 March 2014 17:50 Go to previous messageGo to next message
Dmitry Sklyut is currently offline Dmitry SklyutFriend
Messages: 276
Registered: January 2010
Senior Member
Hello Martin,

maven.springframework.org - You are right. Dead as 404 can be.

Junit 4 - not sure if this will be a good time investment. At the time when initial implementation was created - it was something that filled a void. I am actually considering deprecating it and moving to something like paxexam (https://ops4j1.jira.com/wiki/display/PAXEXAM3/Pax+Exam).

I will try to upload 1.0.2 to the nexus repo later today otherwise I will publish it to here http://download.eclipse.org/gemini/mvn/. Will reply back to let you know where it is.

I will send out a roadmap for 2.0 later this week. Its been on my to-do for a while now. Was trying to finish R4.3 update first.

Dmitry

Re: Gemini Blueprint Milestone shipped with OSGi R4.2? [message #1265796 is a reply to message #1265027] Thu, 06 March 2014 15:19 Go to previous message
Martin Baumgartner is currently offline Martin BaumgartnerFriend
Messages: 9
Registered: June 2013
Junior Member
Dmitry Sklyut wrote on Wed, 05 March 2014 12:50

Junit 4 - not sure if this will be a good time investment. At the time when initial implementation was created - it was something that filled a void. I am actually considering deprecating it and moving to something like paxexam (https://ops4j1.jira.com/wiki/display/PAXEXAM3/Pax+Exam).

Hello Dmitry,

you are right, its a void requirement.

I have taken a look to pax exam a few weeks ago and tried to understand how to combine it with gemini blueprint and failed. So I tried GB-Test for the first time and it seems great to me - ok documenation could be better. But by reading a bit of the code i understood it faster than i did with pax exam. And well, i think that is the main requirement of a test framework, right?

Are there issues with gb-test to set it to deprecated? If so, I couldn't find them in bugzilla.

BR,
Martin

[Updated on: Thu, 06 March 2014 15:24]

Report message to a moderator

Previous Topic:Is Eclipse Gemini Blueprint still active?
Next Topic:Problems when using ApsectJ and Gemini EclipseLink weaving for LazyLoading
Goto Forum:
  


Current Time: Tue Nov 25 02:04:46 GMT 2014

Powered by FUDForum. Page generated in 0.09779 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software