Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » IE8 & Autosuggest does not work
IE8 & Autosuggest does not work [message #1252751] Fri, 21 February 2014 15:14 Go to next message
Martin Blühweis is currently offline Martin Blühweis
Messages: 11
Registered: February 2012
Location: Innsbruck, Austria
Junior Member
hi all,

i'm using RAP 2.2 and and the autosuggest addon (0.2.0). with firefox everything works perfectly, but not in IE8 - i don't get any suggestions.

every time i type a letter into the corresponding text widget the debugger says
Error: Error in scripting event type Modify: Das Objekt unterstützt diese Eigenschaft oder Methode nicht.

which means "the object does not support this property or method"

my javascript knowledge is not the best, but as i understand it the error happens in a function in Autosuggest.js:
function handleTextEvent( model, event ) {
  var userAction = getUserAction( event );
  switch( event.type ) {
    case SWT.Modify:
      syncTextText.apply( model, [ event.widget, event, userAction ] );
    break;
  }
  setUserAction( event );
}


i'm using autosuggest in a really simple way as shown here including a ColumnTemplate.

am i doing anything wrong, or could this be a bug? is there a workaround? any hints?

thanks in advance, martin
Re: IE8 & Autosuggest does not work [message #1255485 is a reply to message #1252751] Mon, 24 February 2014 13:41 Go to previous messageGo to next message
Stefan M is currently offline Stefan M
Messages: 29
Registered: September 2012
Junior Member
Hi Martin,

The error is located in function
function onChangeCurrentSuggestions( event )
in line
this.set( "currentSuggestionTexts", currentSuggestions.map( template ) );

The map-function is not supported by IE8.
You can replace it with:
this.set( "currentSuggestionTexts", map( currentSuggestions, template ) );

Then it works.
Did you open a bug for it?


Re: IE8 & Autosuggest does not work [message #1278605 is a reply to message #1255485] Thu, 27 March 2014 15:28 Go to previous message
Martin Blühweis is currently offline Martin Blühweis
Messages: 11
Registered: February 2012
Location: Innsbruck, Austria
Junior Member
Many thanks, Stefan!

it took me a while to come back to here (low prio bug). your fix works for me.
i filed a bug

regards, martin
Previous Topic:RWT Standalone - WEB.XML help
Next Topic:Chrome and RAP 2.1
Goto Forum:
  


Current Time: Thu Oct 30 18:59:25 GMT 2014

Powered by FUDForum. Page generated in 0.02190 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software