Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » handling of internal errors in WTP
handling of internal errors in WTP [message #205070] Wed, 28 November 2007 10:19 Go to next message
Eclipse User
Originally posted by: sentwr.live.de

Hi all,

I'm using Eclipse Fall version 2 and my workspace
contains at the moment 40+ projects (different utilitiy modules, a few
WAR files and one EAR). I've made some merges of my source code and
at the moment I'm not able to work with WTP. For example a window
with "The currently displayed page contains invalid values" is opened
when I try to see properties of Utility module. Few errors from Error Log
view are attached at the end. That's all I get. There's no single hint
about possible cause of the problem.

My question is:
Why there's no detailed information in the log file what caused the problem
(project name, file name, whatever)?
There's just error message and the stacktrace (usually NullPointerException
or something like that).

It is quite difficult for developer to find possible reason with that
kind
of information.

Best Regards,

Tomasz


Error
Wed Nov 28 15:57:39 CET 2007
Problems occurred when invoking code from plug-in: "org.eclipse.jface".

java.lang.NullPointerException
at
org.eclipse.jst.j2ee.application.internal.operations.ClassPa thSelection.setProjectValues(ClassPathSelection.java:915)
at
org.eclipse.jst.j2ee.application.internal.operations.ClassPa thSelection.createElement(ClassPathSelection.java:202)
at
org.eclipse.jst.j2ee.application.internal.operations.ClassPa thSelection.initializeElements(ClassPathSelection.java:636)
at





Error
Wed Nov 28 15:31:21 CET 2007

*** ERROR ***: Wed Nov 28 15:31:21 CET 2007
org.eclipse.wst.validation.internal.core.ValidationException : The
validator WSDL Validator is a delegating validator but no delegate can
found for it.
at
org.eclipse.wst.validation.internal.delegates.DelegatingVali dator.validateInJob(DelegatingValidator.java:228)
at
org.eclipse.wst.validation.internal.operations.ValidatorJob. run(ValidatorJob.java:75)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)




I like this one, it says what's the problem but there's no mention which
file caused that.

Error
Wed Nov 28 15:23:54 CET 2007
*** ERROR ***: Wed Nov 28 15:23:54 CET 2007
org.eclipse.wst.validation.internal.core.ValidationException : CHKJ1000E:
Validation failed because the application client file is not valid. Ensure
that the deployment descriptor is valid.
at
org.eclipse.jst.j2ee.model.internal.validation.ApplicationCl ientValidator.validateInJob(ApplicationClientValidator.java: 147)
at
org.eclipse.jst.j2ee.internal.validation.UIApplicationClient Validator.validateInJob(UIApplicationClientValidator.java:54 )
at
org.eclipse.wst.validation.internal.operations.ValidatorJob. run(ValidatorJob.java:75)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)




This one is also nice:

Error
Wed Nov 28 15:23:54 CET 2007
Exception thrown.

java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at
org.eclipse.wst.validation.internal.operations.WorkbenchCont ext.loadModel(WorkbenchContext.java:583)
at
Re: handling of internal errors in WTP [message #205088 is a reply to message #205070] Thu, 29 November 2007 04:51 Go to previous message
Eclipse User
Originally posted by: wknauf_NO_._INSIDE_hg-online.de

Hi Tomasz,

seems you are hit by this bug: https://bugs.eclipse.org/bugs/show_bug.cgi?id=205004

This is fixed in wtp-M-2.0.2-20071018074037 and later, so you have to build
your own Eclipse with a non stable WTP release.

Best regards

Wolfgang

Tomasz wrote:
> Hi all,
>
> I'm using Eclipse Fall version 2 and my workspace
> contains at the moment 40+ projects (different utilitiy modules, a few
> WAR files and one EAR). I've made some merges of my source code and
> at the moment I'm not able to work with WTP. For example a window
> with "The currently displayed page contains invalid values" is opened
> when I try to see properties of Utility module. Few errors from Error Log
> view are attached at the end. That's all I get. There's no single hint
> about possible cause of the problem.
>
> My question is:
> Why there's no detailed information in the log file what caused the problem
> (project name, file name, whatever)?
> There's just error message and the stacktrace (usually NullPointerException
> or something like that).
>
> It is quite difficult for developer to find possible reason with that kind
> of information.
>
> Best Regards,
>
> Tomasz
>
>
Previous Topic:Simple servlet problem: web.xml woes
Next Topic:xml binding for structured document
Goto Forum:
  


Current Time: Tue Jul 29 06:46:53 EDT 2014

Powered by FUDForum. Page generated in 0.01534 seconds