Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » [Acceleo] Error creating plugin: failed to create task or type apitooling.apigeneration
[Acceleo] Error creating plugin: failed to create task or type apitooling.apigeneration [message #1247735] Sun, 16 February 2014 09:45
Luís de Sousa is currently offline Luís de Sousa
Messages: 126
Registered: July 2009
Senior Member
I am trying to create an Acceleo plugin from existing projects and always get back this error message:

'Export Plug-ins' has encountered a problem.
/media/Data/users/lads/Trabalho/Eclipse/Workspace.Acceleo/.metadata/.plugins/org.eclipse.pde.core/temp/org.eclipse.pde.container.feature/assemble.org.eclipse.pde.container.feature.linux.gtk.x86.xml:88: The following error occurred while executing this line:
/media/Data/users/lads/Trabalho/Eclipse/Workspace.Acceleo/.metadata/.plugins/org.eclipse.pde.core/temp/org.eclipse.pde.container.feature/assemble.org.eclipse.pde.container.feature.linux.gtk.x86.xml:103: The following error occurred while executing this line:
/media/Data/users/lads/Trabalho/Eclipse/Workspace.Acceleo/.metadata/.plugins/org.eclipse.pde.core/temp/org.eclipse.pde.container.feature/assemble.org.eclipse.pde.container.feature.linux.gtk.x86.xml:26: The following error occurred while executing this line:
/media/Data/users/lads/Trabalho/Eclipse/Workspace.Acceleo/org.eclipse.acceleo.module.sample/build.xml:315: The following error occurred while executing this line:
/media/Data/users/lads/Trabalho/Eclipse/Workspace.Acceleo/org.eclipse.acceleo.module.sample/build.xml:422: Problem: failed to create task or type apitooling.apigeneration
Cause: The name is undefined.
Action: Check the spelling.
Action: Check that any custom tasks/types have been declared.
Action: Check that any <presetdef>/<macrodef> declarations have taken place.


This build.xml file seems to be created on the fly, when Acceleo is trying to generate the plugin. When it fails the file is deleted, so I can't check what may be wrong.

I have this same error with any Acceleo project, even newly created projects. I'm using Acceleo 3.3.0 on Eclipse Indigo. Thanks.
Previous Topic:[Acceleo] generate code from a model in Java Class (run-time)
Next Topic:[Acceleo] Random order in UML for sequence of datatypes
Goto Forum:
  


Current Time: Mon Jul 28 10:34:00 EDT 2014

Powered by FUDForum. Page generated in 0.02671 seconds