Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » QVT-OML » Error with abstract mapping with lastest version of QVTo
Error with abstract mapping with lastest version of QVTo [message #1245207] Thu, 13 February 2014 13:13 Go to next message
Thibault Le Ouay is currently offline Thibault Le OuayFriend
Messages: 1
Registered: February 2014
Junior Member
Hey,

I had a transformartion which ran great on Eclipse Luna M4 but since i have upgraded to the M5 and the lastest version of QVTo i cant run this transformation anymore.

I have a AbstractTransfo.qvto with mostly abstract mapping which looked like that :

abstract mapping Node::toOwnNode() : Nodeinherits View::toView;

it worked great on the last version but with the latest one i have that kind of error :

Multiple markers at this line - Unsupported inherited mapping 'View::toView' on blackbox mapping
'Node::toOwnNode' - No blackbox implementation found for operation 'Node::toOwnNode'. Make sure
that an implementation is available when running the transformation.

I have to add a blank implementation to make it works

Is it a bug ?

Best,

Thibault
Re: Error with abstract mapping with lastest version of QVTo [message #1245240 is a reply to message #1245207] Thu, 13 February 2014 14:01 Go to previous messageGo to next message
Adolfo Sanchez-Barbudo Herrera is currently offline Adolfo Sanchez-Barbudo HerreraFriend
Messages: 254
Registered: July 2009
Senior Member
Hi Thibault,

Feel free to join the discussion at:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=428028

Cheers,
Adolfo.

On 13/02/2014 13:33, Thibault Le Ouay wrote:
> Hey,
> I had a transformartion which ran great on Eclipse Luna M4 but since i
> have upgraded to the M5 and the lastest version of QVTo i cant run this
> transformation anymore.
> I have a AbstractTransfo.qvto with mostly abstract mapping which looked
> like that :
>
> abstract mapping Node::toOwnNode() : Nodeinherits View::toView;
> it worked great on the last version but with the latest one i have that
> kind of error :
>
> Multiple markers at this line - Unsupported inherited mapping
> 'View::toView' on blackbox mapping 'Node::toOwnNode' - No blackbox
> implementation found for operation 'Node::toOwnNode'. Make sure that an
> implementation is available when running the transformation.
>
> I have to add a blank implementation to make it works
> Is it a bug ?
> Best,
>
> Thibault
Re: Error with abstract mapping with lastest version of QVTo [message #1298726 is a reply to message #1245207] Wed, 16 April 2014 13:04 Go to previous messageGo to next message
Vincent DUGRAS is currently offline Vincent DUGRASFriend
Messages: 1
Registered: April 2014
Junior Member
Hi Thibault

Can you help me please ?
Re: Error with abstract mapping with lastest version of QVTo [message #1301542 is a reply to message #1245240] Fri, 18 April 2014 06:43 Go to previous message
Sergey Boyko is currently offline Sergey BoykoFriend
Messages: 162
Registered: July 2009
Senior Member
Adolfo Sanchez-Barbudo Herrera wrote on Thu, 13 February 2014 09:01
Hi Thibault,

Feel free to join the discussion at:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=428028

Cheers,
Adolfo.

On 13/02/2014 13:33, Thibault Le Ouay wrote:
> Hey,
> I had a transformartion which ran great on Eclipse Luna M4 but since i
> have upgraded to the M5 and the lastest version of QVTo i cant run this
> transformation anymore.
> I have a AbstractTransfo.qvto with mostly abstract mapping which looked
> like that :
>
> abstract mapping Node::toOwnNode() : Nodeinherits View::toView;
> it worked great on the last version but with the latest one i have that
> kind of error :
>
> Multiple markers at this line - Unsupported inherited mapping
> 'View::toView' on blackbox mapping 'Node::toOwnNode' - No blackbox
> implementation found for operation 'Node::toOwnNode'. Make sure that an
> implementation is available when running the transformation.
>
> I have to add a blank implementation to make it works
> Is it a bug ?
> Best,
>
> Thibault


Consequently you should switch to M6 build. Mentioned regression was fixed there.

Regards,
Sergey.
Previous Topic:I want to give you a QVTo test coverage plugin
Next Topic:Use of Libraries in different Projects
Goto Forum:
  


Current Time: Sun Nov 23 17:14:40 GMT 2014

Powered by FUDForum. Page generated in 0.15722 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software