Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » [SOLVED] Can't install Aptana plugin due to missing requirement(Missing requirement: Aptana Editor Infrastructure 1.2.7.024747 )
[SOLVED] Can't install Aptana plugin due to missing requirement [message #1244571] Wed, 12 February 2014 09:37 Go to next message
Renato V is currently offline Renato V
Messages: 8
Registered: February 2014
Junior Member
Hello everyone, I'm currently using Eclipse 4.3.1 (Kepler Service Release 1, Build ID: 20130919-0819) on OpenSUSE 13.1 and I'm trying to install Aptana 3.2/3.3 from the following update repository (which I got from Aptana's official site instructions):

http : // update. aptana. com /update /studio/ 3.2
(I had to put spaces to be able to post it here, sorry)

I select all packages (Eclipse integration + all features), but I can't install and it returns the following error:

Cannot complete the install because one or more required items could not be found.
  Software being installed: Aptana CSS Editor 1.2.7.024747 (com.aptana.ide.feature.editor.css.feature.group 1.2.7.024747)
  Missing requirement: Aptana Editor Infrastructure 1.2.7.024747 (com.aptana.ide.feature.editors.feature.group 1.2.7.024747) requires 'org.eclipse.update.ui 0.0.0' but it could not be found
  Cannot satisfy dependency:
    From: Aptana CSS Editor 1.2.7.024747 (com.aptana.ide.feature.editor.css.feature.group 1.2.7.024747)
    To: com.aptana.ide.feature.editors.feature.group [1.2.7.024747]


Could someone please help me? I'm a newcomer and I'm a bit lost.

[Updated on: Thu, 13 February 2014 02:25]

Report message to a moderator

Re: Can't install Aptana plugin due to missing requirement [message #1245026 is a reply to message #1244571] Thu, 13 February 2014 02:25 Go to previous messageGo to next message
Renato V is currently offline Renato V
Messages: 8
Registered: February 2014
Junior Member
Don't follow Aptana's instalation instructions or it will fail. I found another update repository on their site:

http :// download.aptana.com/ studio3/plugin/install
(sorry, I had to put spaces)

This one works just fine. But note that Aptana comes with PyDev, so you must uninstall PyDev first in order to install Aptana (don't worry, PyDev will be installed again with Aptana Studio).
Re: Can't install Aptana plugin due to missing requirement [message #1277378 is a reply to message #1245026] Tue, 25 March 2014 19:10 Go to previous message
Dennis Forcier is currently offline Dennis Forcier
Messages: 17
Registered: July 2009
Junior Member
Thanks. The Aptana instructions are opaque at best.

But tell me something. It looks like Aptana is intent on installing a plug-in that supports Ruby on Rails. Well, I don't want to develop for Rails. I just was to work in Ruby. So just what comes in the Aptana plug-in?

TIA,
Dennis
Previous Topic:Eclipse For Java 8
Next Topic:Eclipse cannot create Java class?
Goto Forum:
  


Current Time: Fri Aug 22 23:39:51 EDT 2014

Powered by FUDForum. Page generated in 0.01628 seconds