Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » WTP, JBOSS 4.2 and EJB 2
WTP, JBOSS 4.2 and EJB 2 [message #203615] Mon, 05 November 2007 15:53
Waldyn Benbenek is currently offline Waldyn BenbenekFriend
Messages: 24
Registered: July 2009
Junior Member
I want to target JBOSS 4.2 with EJB 2 beans. EJB 3.0 is not fully
supported in JBOSS until 5.0. When I create an EJB project as part of at
the same time I create an enterprise archive project which targets JBOSS 4.2
it insists on making it EJB 3.0. I have to physically alter the facet
preference files to make it 2.1 or 2.0.

If I don't make the EJB (and client) project when I make the EAR project,
it's OK. I can choose the EJB level, etc, when I create the EJB project.

This is a definite limitation in the Enterprise Application Project wizard.
If anything, the default for JBOSS 4.2 should still be EJB 2.1. Ideally, it
should give one a choice when creating the new modules during the wizard.

Wally
Previous Topic:Re: Mylyn 2.1 is now available
Next Topic:Re: Where is org.apache.xerces.jaxp.SAXParserFactoryImpl?
Goto Forum:
  


Current Time: Sat Nov 29 06:30:54 GMT 2014

Powered by FUDForum. Page generated in 0.13659 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software