Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Fileupload addon and dependency to Commons IO
Fileupload addon and dependency to Commons IO [message #1239643] Tue, 04 February 2014 17:26 Go to next message
Ken Wenzel is currently offline Ken Wenzel
Messages: 39
Registered: July 2009
Member
Hello,

I have a bundle that exports Commons IO in version 2.4. This bundle
is NOT named 'org.apache.commons.io'.

Due to some bundle that uses both, another bundle with a dependency to version 2.4 of Commons IO and 'org.eclipse.rap.addons.fileupload' with a Require-Bundle dependency to 'org.apache.commons.io' 2.0.1, a LinkageError is thrown.

If 'org.apache.commons.io' is imported with Import-Package instead of Require-Bundle the mentioned error can be fixed.

Is it possible to use Import-Package instead of Require-Bundle for the dependency of 'org.eclipse.rap.addons.fileupload' to 'org.apache.commons.io'?

Thank you and best regards,
Ken

Re: Fileupload addon and dependency to Commons IO [message #1240387 is a reply to message #1239643] Thu, 06 February 2014 10:43 Go to previous message
Ivan Furnadjiev is currently offline Ivan Furnadjiev
Messages: 1821
Registered: July 2009
Senior Member
Hi Ken,
thank you for your suggestion. It's fixed in master with commit [1].

[1]
http://git.eclipse.org/c/rap/incubator/org.eclipse.rap.incubator.fileupload.git/commit/?id=ef2c05f373d8c8a1e727a14c7156e1967dc43c8f

Best,
Ivan

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Previous Topic:[POLL] BDD with RAP
Next Topic:keybindings and mouse events with a browser widget
Goto Forum:
  


Current Time: Tue Sep 30 16:00:24 GMT 2014

Powered by FUDForum. Page generated in 0.01729 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software