Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » WTP 2.0.1 - Perm gen space errors
WTP 2.0.1 - Perm gen space errors [message #202270] Mon, 15 October 2007 15:44 Go to next message
mark streit is currently offline mark streit
Messages: 11
Registered: July 2009
Junior Member
I know this is not the first post of this kind since the WTP 2.0.1 release
but I have 2 Eclipse installs on my machine - both are the "all-in-one"
packages for WTP 2.X - the one for WTP 2.0.0 appears to run fine. The one
for the most recent WTP 2.0.1 release also runs ok but then at some point, I
start getting this garbage:

!ENTRY org.eclipse.ui.workbench 4 0 2007-10-15 11:29:30.765
!MESSAGE Widget disposed too early!
!SESSION Mon Oct 15 11:29:42 EDT
2007 ------------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2007-10-15 11:29:42.421
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.OutOfMemoryError: PermGen space

It's odd because I only see this repeatedly w/ the newer release and the
eclipse.ini file contents for each installation look exactly the same:

-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
-vmargs
-Xms40m
-Xmx256m

-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
-vmargs
-Xms40m
-Xmx256m

Any ideas as to why the behavior between the 2 releases would be the same
re: memory. If the .ini file for the newer release required different
values, were they not packaged w/ those changes?

Thanks
Re: WTP 2.0.1 - Perm gen space errors [message #202285 is a reply to message #202270] Mon, 15 October 2007 16:02 Go to previous messageGo to next message
Eclipse User
Originally posted by: merks.ca.ibm.com

This is a multi-part message in MIME format.
--------------080006090407050604070502
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

Mark,

Lots of people are being affected by this bug:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=203325

I'm hoping that a decision will be made to spin an Eclipse 3.3.1a build
to fix this. I believe the above bug report describes a simple
workaround...


mark streit wrote:
> I know this is not the first post of this kind since the WTP 2.0.1 release
> but I have 2 Eclipse installs on my machine - both are the "all-in-one"
> packages for WTP 2.X - the one for WTP 2.0.0 appears to run fine. The one
> for the most recent WTP 2.0.1 release also runs ok but then at some point, I
> start getting this garbage:
>
> !ENTRY org.eclipse.ui.workbench 4 0 2007-10-15 11:29:30.765
> !MESSAGE Widget disposed too early!
> !SESSION Mon Oct 15 11:29:42 EDT
> 2007 ------------------------------------------
> !ENTRY org.eclipse.equinox.launcher 4 0 2007-10-15 11:29:42.421
> !MESSAGE Exception launching the Eclipse Platform:
> !STACK
> java.lang.OutOfMemoryError: PermGen space
>
> It's odd because I only see this repeatedly w/ the newer release and the
> eclipse.ini file contents for each installation look exactly the same:
>
> -showsplash
> org.eclipse.platform
> --launcher.XXMaxPermSize
> 256m
> -vmargs
> -Xms40m
> -Xmx256m
>
> -showsplash
> org.eclipse.platform
> --launcher.XXMaxPermSize
> 256m
> -vmargs
> -Xms40m
> -Xmx256m
>
> Any ideas as to why the behavior between the 2 releases would be the same
> re: memory. If the .ini file for the newer release required different
> values, were they not packaged w/ those changes?
>
> Thanks
>
>
>


--------------080006090407050604070502
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Mark,<br>
<br>
Lots of people are being affected by this bug:<br>
<blockquote><a
href="https://bugs.eclipse.org/bugs/show_bug.cgi?id=203325">https://bugs.eclipse.org/bugs/show_bug.cgi?id=203325</a>&nbsp;
<br>
</blockquote>
I'm hoping that a decision will be made to spin an Eclipse 3.3.1a build
to fix this.&nbsp;&nbsp; I believe the above bug report describes a simple
workaround...<br>
<br>
<br>
mark streit wrote:
<blockquote cite="mid:ff01ol$i6b$1@build.eclipse.org" type="cite">
<pre wrap="">I know this is not the first post of this kind since the WTP 2.0.1 release
but I have 2 Eclipse installs on my machine - both are the "all-in-one"
packages for WTP 2.X - the one for WTP 2.0.0 appears to run fine. The one
for the most recent WTP 2.0.1 release also runs ok but then at some point, I
start getting this garbage:

!ENTRY org.eclipse.ui.workbench 4 0 2007-10-15 11:29:30.765
!MESSAGE Widget disposed too early!
!SESSION Mon Oct 15 11:29:42 EDT
2007 ------------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2007-10-15 11:29:42.421
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.OutOfMemoryError: PermGen space

It's odd because I only see this repeatedly w/ the newer release and the
eclipse.ini file contents for each installation look exactly the same:

-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
-vmargs
-Xms40m
-Xmx256m

-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
-vmargs
-Xms40m
-Xmx256m

Any ideas as to why the behavior between the 2 releases would be the same
re: memory. If the .ini file for the newer release required different
values, were they not packaged w/ those changes?

Thanks


</pre>
</blockquote>
<br>
</body>
</html>

--------------080006090407050604070502--
Re: WTP 2.0.1 - Perm gen space errors [message #203118 is a reply to message #202270] Fri, 26 October 2007 08:07 Go to previous message
Eclipse User
Originally posted by: baldervancamp.telenet.be

QuickFix: add next line to your eclipse.ini after other vmargs.

-XX:MaxPermSize=256m


Thanks to the bug report !

mark streit schreef:
> I know this is not the first post of this kind since the WTP 2.0.1 release
> but I have 2 Eclipse installs on my machine - both are the "all-in-one"
> packages for WTP 2.X - the one for WTP 2.0.0 appears to run fine. The one
> for the most recent WTP 2.0.1 release also runs ok but then at some point, I
> start getting this garbage:
>
> !ENTRY org.eclipse.ui.workbench 4 0 2007-10-15 11:29:30.765
> !MESSAGE Widget disposed too early!
> !SESSION Mon Oct 15 11:29:42 EDT
> 2007 ------------------------------------------
> !ENTRY org.eclipse.equinox.launcher 4 0 2007-10-15 11:29:42.421
> !MESSAGE Exception launching the Eclipse Platform:
> !STACK
> java.lang.OutOfMemoryError: PermGen space
>
> It's odd because I only see this repeatedly w/ the newer release and the
> eclipse.ini file contents for each installation look exactly the same:
>
> -showsplash
> org.eclipse.platform
> --launcher.XXMaxPermSize
> 256m
> -vmargs
> -Xms40m
> -Xmx256m
>
> -showsplash
> org.eclipse.platform
> --launcher.XXMaxPermSize
> 256m
> -vmargs
> -Xms40m
> -Xmx256m
>
> Any ideas as to why the behavior between the 2 releases would be the same
> re: memory. If the .ini file for the newer release required different
> values, were they not packaged w/ those changes?
>
> Thanks
>
>
Previous Topic:unable to .wtpmodules file
Next Topic:XDoclet Enterprise Javabean - Container Managed Entity Bean - Import attributes from table = problem
Goto Forum:
  


Current Time: Sat Sep 20 12:03:57 GMT 2014

Powered by FUDForum. Page generated in 0.01791 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software