Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Linked resources not updated if .project changes(Linked resources not updated if .project changes)
Linked resources not updated if .project changes [message #1234769] Wed, 22 January 2014 19:13 Go to next message
Udo Eberhardt is currently offline Udo Eberhardt
Messages: 3
Registered: January 2014
Junior Member
Hi,

I'm running Eclipse/CDT on Windows 7 and I have a problem which occurs if .project files are transferred between different developer machines via svn, for example. The project contains .c files as linked resources, relative to the project. If anyone else removed such a linked file from the project, .project gets updated via svn. If I open my local workspace then project explorer still shows the files that have been deleted in .project. These are broken links now. When I build the project the files will still be added to the makefile causing the build to fail.

Refreshing the workspace via F5 does not help.

Obviously Eclipse does not notice that the .project file is newer than cached information in the workspace.

Any ideas?

Thanks
Udo
Re: Linked resources not updated if .project changes [message #1235463 is a reply to message #1234769] Fri, 24 January 2014 12:36 Go to previous messageGo to next message
Axel Mueller is currently offline Axel Mueller
Messages: 1964
Registered: July 2009
Senior Member
This is a Eclipse platform problem and not related to CDT. I suggest you ask your question there
http://www.eclipse.org/forums/index.php/f/11/

BTW, I found a bugzilla entry similar to your report.
https://bugs.eclipse.org/bugs/show_bug.cgi?id=392637
Do you have "refresh using native hooks or polling" enabled in preferences?


Before you ask
- search this forum
- see the FAQ http://wiki.eclipse.org/CDT/User/FAQ
- google
Re: Linked resources not updated if .project changes [message #1236485 is a reply to message #1235463] Mon, 27 January 2014 10:25 Go to previous message
Udo Eberhardt is currently offline Udo Eberhardt
Messages: 3
Registered: January 2014
Junior Member
Thank you for your reply. Turning on the option "refresh using native hooks or polling" does not solve the problem, I just double checked. I will ask the question in the other forum.

Udo
Previous Topic:Problem with JFace!
Next Topic:Cannot add thirty-party libraries into PostgreSQl source code under eclipse.
Goto Forum:
  


Current Time: Sat Oct 25 07:51:48 GMT 2014

Powered by FUDForum. Page generated in 0.01700 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software