Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » cannot set breakpoint(I have solved this problem deleting a jar file!)
icon12.gif  cannot set breakpoint [message #1230357] Sat, 11 January 2014 14:30 Go to next message
edgar pullen parente is currently offline edgar pullen parente
Messages: 2
Registered: January 2014
Junior Member
I have had recently a very strange problem with eclipse: Suddenly , from nowhere, I was not able any more to set break points in my project.
I have tried after this my Eclipse with other projects and the same happened.
I have checked in all forums and I have tried all the clues given.
So, I decided to re-install Eclipse. I have tried either with Kepler version or Ganymede version. The same has happened.
I re-installed Eclipse again and instead of testing with my project, created a new one with a HelloWorld class. I was able to set the breakpoints. I Decided to create a new project with my files, in another work place. I was not any more able to set breakpoints. I came back to the HelloWord class and the break point was not setting anymore.
Then I decided to reinstall Eclipse, recreate my project, adding one by one all the files. And, surprise, when I have added a jar file, Eclipse stopped to recognize break points!
So, I discovered that Eclipse was affected by a jar file regarding to simple break point setting.
To solve my problem, I only need to take out that particular jar file.
Re: cannot set breakpoint [message #1230387 is a reply to message #1230357] Sat, 11 January 2014 16:43 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26010
Registered: July 2009
Senior Member
There is no question mark in this post.

On 11/01/2014 8:59 PM, edgar pullen parente wrote:
> I have had recently a very strange problem with eclipse: Suddenly ,
> from nowhere, I was not able any more to set break points in my
> project. I have tried after this my Eclipse with other projects and
> the same happened. I have checked in all forums and I have tried all
> the clues given.
> So, I decided to re-install Eclipse. I have tried either with Kepler
> version or Ganymede version. The same has happened.
> I re-installed Eclipse again and instead of testing with my project,
> created a new one with a HelloWorld class. I was able to set the
> breakpoints. I Decided to create a new project with my files, in
> another work place. I was not any more able to set breakpoints. I came
> back to the HelloWord class and the break point was not setting
> anymore. Then I decided to reinstall Eclipse, recreate my project,
> adding one by one all the files. And, surprise, when I have added a
> jar file, Eclipse stopped to recognize break points!
> So, I discovered that Eclipse was affected by a jar file regarding to
> simple break point setting. To solve my problem, I only need to take
> out that particular jar file.
Re: cannot set breakpoint [message #1232366 is a reply to message #1230387] Thu, 16 January 2014 14:26 Go to previous messageGo to next message
bryan blake is currently offline bryan blake
Messages: 4
Registered: January 2014
Junior Member
There is no question mark in the thread, but I believe that is because Edgar doesn't speak English and didn't think about the importance of the question mark. The question he is asking is if taking out that particular jar file will solve his problem and allow him to again use break points within Eclipse. I have had the same problem and hunted high and low for an answer. This is the problem with technology and programming. One small tiny piece of code, or even just a period can be enough to derail the entire project and make everything work poorly. I am curious if I have the same problem and if finding the same jar file will help me, as well.
Re: cannot set breakpoint [message #1232394 is a reply to message #1232366] Thu, 16 January 2014 16:16 Go to previous message
edgar pullen parente is currently offline edgar pullen parente
Messages: 2
Registered: January 2014
Junior Member
Simplifying: (I hope you can understand my English).

Eclipse has been not allowed anymore to set any break point, in any project, after I have incorporated in the work-space my project.

I have discovered that a jar file, of my project, which had probably a class with the same name did all this damage. I have needed to start my project with no jar files, and put every jar file, step by step, in the project until I had the same problem again.

I am sure that I needed to restart Eclipse after taking out the particular jar file. Simply taking out it was not enough.

[Updated on: Thu, 16 January 2014 16:17]

Report message to a moderator

Previous Topic:Project handling
Next Topic:Brand New, Total Noob, Having Trouble With Install
Goto Forum:
  


Current Time: Wed Aug 27 11:11:49 EDT 2014

Powered by FUDForum. Page generated in 0.01645 seconds