Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Can't Install PDT on kepler 20130919-0819(Error message in post. Artifact file not found)
Can't Install PDT on kepler 20130919-0819 [message #1229511] Thu, 09 January 2014 15:49 Go to next message
Justin Campo is currently offline Justin CampoFriend
Messages: 2
Registered: January 2014
Junior Member
I can't find this error/issue anywhere on this forum or google. I would appreciate any help you could provide.

An error occurred while installing the items
session context was:(profile=epp.package.standard, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]org.eclipse.php.core 3.2.0.201306051924, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
The artifact file for osgi.bundle,org.eclipse.php.core,3.2.0.201306051924 was not found.

Thanks - J
Re: Can't Install PDT on kepler 20130919-0819 [message #1229571 is a reply to message #1229511] Thu, 09 January 2014 18:37 Go to previous messageGo to next message
Justin Campo is currently offline Justin CampoFriend
Messages: 2
Registered: January 2014
Junior Member
Sorry I should have provided more information on initial post.

I am on a windows 7 64 bit machine.
I have a fresh unzipped version of kepler 20130919-0819 (tried unpacking twice / starting over again with different workplace locations).

Upon first start I follow the initial setup requests (set work place) I immediately attempt to install PDT via help->install software and get the error above.

Also please note: It seems like the forum system has some bugs where a page, once it loads a guest doesn't recognize you are logged in when you return to it. I was going around in loops trying to reply, loggining, trying to reply logging in etc. On each page I had to do a hard refresh to get it to notice I was logged in until I got to this thread page.

[Updated on: Thu, 09 January 2014 18:37]

Report message to a moderator

Re: Can't Install PDT on kepler 20130919-0819 [message #1229760 is a reply to message #1229571] Fri, 10 January 2014 06:51 Go to previous messageGo to next message
Toshihiro Izumi is currently offline Toshihiro IzumiFriend
Messages: 359
Registered: July 2009
Location: Japan
Senior Member
Just a question, can you install any other plugins from kepler repository?
Re: Can't Install PDT on kepler 20130919-0819 [message #1229960 is a reply to message #1229760] Fri, 10 January 2014 17:03 Go to previous messageGo to next message
John Jarvis is currently offline John JarvisFriend
Messages: 1
Registered: January 2014
Junior Member
Having exact same problem. Yes I am able to install additional plugins from the Kepler repository.

Steps I've tried - under .metadata\.plugins I manually deleted the PHP plugin and three org.eclipse.dltk.* plugins. The re-install went through seemingly OK but still no PHP perspective or editor in Eclipse. Here is a snippet of the output from my log:


!ENTRY org.eclipse.equinox.p2.engine 4 4 2014-01-10 11:05:13.337
!MESSAGE An error occurred while installing the items
!SUBENTRY 1 org.eclipse.equinox.p2.engine 4 0 2014-01-10 11:05:13.337
!MESSAGE session context was:(profile=profile, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]org.eclipse.php.debug.core 3.2.0.201306051924, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
!SUBENTRY 1 org.eclipse.equinox.p2.touchpoint.eclipse 4 0 2014-01-10 11:05:13.337
!MESSAGE The artifact file for osgi.bundle,org.eclipse.php.debug.core,3.2.0.201306051924 was not found.

!ENTRY org.eclipse.equinox.p2.engine 4 4 2014-01-10 11:07:26.925
!MESSAGE An error occurred while installing the items
!SUBENTRY 1 org.eclipse.equinox.p2.engine 4 0 2014-01-10 11:07:26.925
!MESSAGE session context was:(profile=profile, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]org.eclipse.php.debug.ui 3.2.0.201306051924, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
!SUBENTRY 1 org.eclipse.equinox.p2.touchpoint.eclipse 4 0 2014-01-10 11:07:26.925
!MESSAGE The artifact file for osgi.bundle,org.eclipse.php.debug.ui,3.2.0.201306051924 was not found.
!SESSION 2014-01-10 11:09:15.560 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_45
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments:  -os win32 -ws win32 -arch x86


Thanks
Re: Can't Install PDT on kepler 20130919-0819 [message #1230123 is a reply to message #1229960] Sat, 11 January 2014 02:50 Go to previous messageGo to next message
Toshihiro Izumi is currently offline Toshihiro IzumiFriend
Messages: 359
Registered: July 2009
Location: Japan
Senior Member
>eclipse.buildId=unknown
This indicates you have a bad installation.

Though I don't know how did you install Eclipse, since Eclipse is portable, try having new installation and new workspace(not re-install/re-use) within full-control-rights(all permissions).

Or...
You can try all-in-one packages, (I never recommend them though)
Zend PDT http://www.zend.com/en/company/community/pdt/downloads
Milestone(alpha version) for next release http://www.eclipse.org/downloads/index-developer.php
Re: Can't Install PDT on kepler 20130919-0819 [message #1239638 is a reply to message #1229511] Tue, 04 February 2014 17:12 Go to previous message
Jim Mayer is currently offline Jim MayerFriend
Messages: 18
Registered: July 2009
Junior Member
I have a very similar problem with a known eclipse.buildId. This is on a I7 based system running Fedora Core 20. I was building a 32 bit Kepler SR1 installation.

org.eclipse.m2e.logback.configuration: The org.eclipse.m2e.logback.configuration bundle was activated before the state location was initialized. Will retry after the state location is initialized.
!SESSION 2014-02-04 11:44:35.973 -----------------------------------------------
eclipse.buildId=4.3.0.M20130911-1000
java.version=1.6.0_24
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Framework arguments: -product org.eclipse.epp.package.java.product -application org.eclipse.equinox.p2.director -repository http://bitstrings.github.com/m2e-connectors-p2/milestones,http://download.eclipse.org/eclipse/updates/4.3,http://download.eclipse.org/mylyn/releases/kepler,http://download.eclipse.org/releases/kepler,http://download.eclipse.org/technology/epp/packages/kepler/,http://e-p-i-c.sf.net/updates/,http://eclipserunnerplugin.googlecode.com/svn/trunk/EclipseRunnerSite,http://moreunit.sourceforge.net/update-site/,http://repo1.maven.org/maven2/.m2e/connectors/m2eclipse-buildhelper/0.15.0/N/0.15.0.201207090124/,http://update.eclemma.org/,http://workspacemechanic.eclipselabs.org.codespot.com/git.update/mechanic/,http://www.accurev.com/download/eclipseupdate,http://xui.sdsp.mc.xerox.com/vorpal/update,http://zapletnev.github.io/eclipse-regexp/repository/ -installIU EclipseRunnerFeature.feature.group,com.accurev.eclipse.feature.group,com.google.eclipse.mechanic.feature.group,com.mountainminds.eclemma.feature.feature.group,com.xerox.vorpal.wb.plugin_feature.feature.group,epp.package.java,org.bitstrings.eclipse.m2e.connectors.dependencypath.feature.feature.group,org.bitstrings.eclipse.m2e.connectors.jaxb2.feature.feature.group,org.eclipse.cdt.autotools.feature.group,org.eclipse.cdt.feature.group,org.eclipse.cdt.mylyn.feature.group,org.eclipse.cdt.sdk.feature.group,org.eclipse.cdt.testsrunner.feature.feature.group,org.eclipse.jdt.source.feature.group,org.eclipse.linuxtools.callgraph.feature.feature.group,org.eclipse.linuxtools.cdt.libhover.feature.feature.group,org.eclipse.mylyn.hudson.feature.group,org.eclipse.mylyn.ide_feature.feature.group,org.eclipse.mylyn.java_feature.feature.group,org.eclipse.pde.source.feature.group,org.eclipse.php.feature.group,org.eclipse.platform.sdk,org.eclipse.rcp.source.feature.group,org.eclipse.regexp.feature.feature.group,org.eclipse.sdk.ide,org.eclipse.tm.terminal.local.feature.group,org.eclipse.wb.core.xml.feature.feature.group,org.eclipse.wb.doc.user.feature.feature.group,org.eclipse.wb.rcp.doc.user.feature.feature.group,org.eclipse.wb.rcp.feature.feature.group,org.eclipse.wb.swt.feature.feature.group,org.eclipse.wst.jsdt.feature.feature.group,org.eclipse.wst.web_ui.feature.feature.group,org.eclipse.wst.xsl.feature.feature.group,org.epic.feature.main.feature.group,org.moreunit.feature.group,org.moreunit.light.feature.group,org.moreunit.mock.feature.group,org.sonatype.m2e.buildhelper.feature.feature.group
Command-line arguments: -os linux -ws gtk -arch x86 -product org.eclipse.epp.package.java.product -consolelog -application org.eclipse.equinox.p2.director -repository http://bitstrings.github.com/m2e-connectors-p2/milestones,http://download.eclipse.org/eclipse/updates/4.3,http://download.eclipse.org/mylyn/releases/kepler,http://download.eclipse.org/releases/kepler,http://download.eclipse.org/technology/epp/packages/kepler/,http://e-p-i-c.sf.net/updates/,http://eclipserunnerplugin.googlecode.com/svn/trunk/EclipseRunnerSite,http://moreunit.sourceforge.net/update-site/,http://repo1.maven.org/maven2/.m2e/connectors/m2eclipse-buildhelper/0.15.0/N/0.15.0.201207090124/,http://update.eclemma.org/,http://workspacemechanic.eclipselabs.org.codespot.com/git.update/mechanic/,http://www.accurev.com/download/eclipseupdate,http://xui.sdsp.mc.xerox.com/vorpal/update,http://zapletnev.github.io/eclipse-regexp/repository/ -installIU EclipseRunnerFeature.feature.group,com.accurev.eclipse.feature.group,com.google.eclipse.mechanic.feature.group,com.mountainminds.eclemma.feature.feature.group,com.xerox.vorpal.wb.plugin_feature.feature.group,epp.package.java,org.bitstrings.eclipse.m2e.connectors.dependencypath.feature.feature.group,org.bitstrings.eclipse.m2e.connectors.jaxb2.feature.feature.group,org.eclipse.cdt.autotools.feature.group,org.eclipse.cdt.feature.group,org.eclipse.cdt.mylyn.feature.group,org.eclipse.cdt.sdk.feature.group,org.eclipse.cdt.testsrunner.feature.feature.group,org.eclipse.jdt.source.feature.group,org.eclipse.linuxtools.callgraph.feature.feature.group,org.eclipse.linuxtools.cdt.libhover.feature.feature.group,org.eclipse.mylyn.hudson.feature.group,org.eclipse.mylyn.ide_feature.feature.group,org.eclipse.mylyn.java_feature.feature.group,org.eclipse.pde.source.feature.group,org.eclipse.php.feature.group,org.eclipse.platform.sdk,org.eclipse.rcp.source.feature.group,org.eclipse.regexp.feature.feature.group,org.eclipse.sdk.ide,org.eclipse.tm.terminal.local.feature.group,org.eclipse.wb.core.xml.feature.feature.group,org.eclipse.wb.doc.user.feature.feature.group,org.eclipse.wb.rcp.doc.user.feature.feature.group,org.eclipse.wb.rcp.feature.feature.group,org.eclipse.wb.swt.feature.feature.group,org.eclipse.wst.jsdt.feature.feature.group,org.eclipse.wst.web_ui.feature.feature.group,org.eclipse.wst.xsl.feature.feature.group,org.epic.feature.main.feature.group,org.moreunit.feature.group,org.moreunit.light.feature.group,org.moreunit.mock.feature.group,org.sonatype.m2e.buildhelper.feature.feature.group

!ENTRY org.eclipse.equinox.p2.repository 2 0 2014-02-04 11:45:05.850
!MESSAGE Server returned lastModified <= 0 for http://workspacemechanic.eclipselabs.org.codespot.com/git.update/mechanic/artifacts.jar

!ENTRY org.eclipse.equinox.p2.repository 2 0 2014-02-04 11:45:15.243
!MESSAGE Server returned lastModified <= 0 for http://workspacemechanic.eclipselabs.org.codespot.com/git.update/mechanic/content.jar
Installing EclipseRunnerFeature.feature.group 1.3.0.
Installing com.accurev.eclipse.feature.group 2013.5.802206.
Installing com.google.eclipse.mechanic.feature.group 0.3.4.
Installing com.mountainminds.eclemma.feature.feature.group 2.2.1.201306092145.
Installing com.xerox.vorpal.wb.plugin_feature.feature.group 2.3.0.201402031237.
Installing epp.package.java 2.0.1.20130919-0803.
Installing org.bitstrings.eclipse.m2e.connectors.dependencypath.feature.feature.group 3.0.0.20130330-0126.
Installing org.bitstrings.eclipse.m2e.connectors.jaxb2.feature.feature.group 3.0.0.20130330-0126.
Installing org.eclipse.cdt.autotools.feature.group 3.2.0.201309180223.
Installing org.eclipse.cdt.feature.group 8.2.1.201309180223.
Installing org.eclipse.cdt.mylyn.feature.group 5.6.0.20131008-0520.
Installing org.eclipse.cdt.sdk.feature.group 8.2.1.201309180223.
Installing org.eclipse.cdt.testsrunner.feature.feature.group 7.2.0.201309180223.
Installing org.eclipse.jdt.source.feature.group 3.9.1.v20130911-1000.
Installing org.eclipse.linuxtools.callgraph.feature.feature.group 1.1.0.201309171939.
Installing org.eclipse.linuxtools.cdt.libhover.feature.feature.group 1.0.0.201309171939.
Installing org.eclipse.mylyn.hudson.feature.group 1.2.0.20131006-0226.
Installing org.eclipse.mylyn.ide_feature.feature.group 3.10.0.20131008-0520.
Installing org.eclipse.mylyn.java_feature.feature.group 3.10.0.20131008-2202.
Installing org.eclipse.pde.source.feature.group 3.9.1.v20130911-1000.
Installing org.eclipse.php.feature.group 3.2.0.201306051924.
Installing org.eclipse.platform.sdk 4.3.1.M20130911-1000.
Installing org.eclipse.rcp.source.feature.group 4.3.1.v20130911-1000.
Installing org.eclipse.regexp.feature.feature.group 0.3.0.
Installing org.eclipse.sdk.ide 4.3.1.M20130911-1000.
Installing org.eclipse.tm.terminal.local.feature.group 0.2.300.201307231220.
Installing org.eclipse.wb.core.xml.feature.feature.group 1.6.1.r43x201309092330.
Installing org.eclipse.wb.doc.user.feature.feature.group 1.6.1.r43x201309092334.
Installing org.eclipse.wb.rcp.doc.user.feature.feature.group 1.6.1.r43x201309100019.
Installing org.eclipse.wb.rcp.feature.feature.group 1.6.1.r43x201309100008.
Installing org.eclipse.wb.swt.feature.feature.group 1.6.1.r43x201309092350.
Installing org.eclipse.wst.jsdt.feature.feature.group 1.5.1.v201307171524-7H7FFhVFC7sResSz-gpggbs.
Installing org.eclipse.wst.web_ui.feature.feature.group 3.5.1.v201307171524-7O7QG2NEMkBS3C2az0gQwwALctEj3DZPgTEZceV4.
Installing org.eclipse.wst.xsl.feature.feature.group 1.3.300.v201302282018-7T7_F_uFIqUoKCGIeb62mhZKaH_Lg.
Installing org.epic.feature.main.feature.group 0.5.46.
Installing org.moreunit.feature.group 3.0.3.
Installing org.moreunit.light.feature.group 3.0.3.
Installing org.moreunit.mock.feature.group 3.0.3.
Installing org.sonatype.m2e.buildhelper.feature.feature.group 0.15.0.201207090124.
Installation failed.
An error occurred while installing the items
session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]org.eclipse.php.core 3.2.0.201306051924, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
The artifact file for osgi.bundle,org.eclipse.php.core,3.2.0.201306051924 was not found.
Application failed, log file location: /tmp/create-eclipse-release.VOvfaUMTraoj/kepler-sr1-32bit/eclipse/configuration/1391532276256.log

!ENTRY org.eclipse.equinox.p2.engine 4 4 2014-02-04 11:48:06.140
!MESSAGE An error occurred while installing the items
!SUBENTRY 1 org.eclipse.equinox.p2.engine 4 0 2014-02-04 11:48:06.140
!MESSAGE session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]org.eclipse.php.core 3.2.0.201306051924, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
!SUBENTRY 1 org.eclipse.equinox.p2.touchpoint.eclipse 4 0 2014-02-04 11:48:06.140
!MESSAGE The artifact file for osgi.bundle,org.eclipse.php.core,3.2.0.201306051924 was not found.

Previous Topic:commas first
Next Topic:Eclipse PDT (PHP Dev Tools) Code Assist
Goto Forum:
  


Current Time: Fri Dec 19 03:22:44 GMT 2014

Powered by FUDForum. Page generated in 0.11471 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software