Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » WTP Book: Deployment descriptor of the module NNN cannot be loaded.
WTP Book: Deployment descriptor of the module NNN cannot be loaded. [message #199576] Tue, 11 September 2007 12:38 Go to next message
Steve Jones is currently offline Steve Jones
Messages: 95
Registered: July 2009
Member
Hi,

Following the LeaguePlanet example in the WTP book I've now got as far
as chapter 8, page 352. I have three errors relating to the
LeaguePlanetEAR project:

1. IWAE0053E An internal error has occurred running validation on
project:LeaguePlanetEAR] deployment descriptor of the module
'LeaguePlanetEJB.jar' cannot be loaded.

2. The deployment descriptor of the module 'LeaguePlanetEJB.jar'
cannot be loaded.

3. The deployment descriptor of the module 'LeaguePlanetWeb.war'
cannot be loaded.

In LeaguePlanetEAR/.settings/org.eclipse.wst.common.component, if I
remove the dependency:

<dependent-module deploy-path="/"
handle="module:/resource/LeaguePlanetWeb/LeaguePlanetWeb">
<dependent-object>WebModule_1189505806557</dependent-object >
<dependency-type>uses</dependency-type>
</dependent-module>

Only error 3 remains and magically the internal error is no longer
reported. I can only assume the error is somthing to do with the
location or content of the LeaguePlanetWeb deployment file:

LeaguePlanetWeb\WebContent\WEB-INF\web.xml

This file exists and seems to have sensible things in it.

I've redone the example several time using a clean workspace with the
same result each time.

This is all on Europa/WTP 2.0.

Any clue as to how I might resolve this would be much appreciated.


Thanks, Steve.
Re: WTP Book: Deployment descriptor of the module NNN cannot be loaded. [message #199622 is a reply to message #199576] Tue, 11 September 2007 17:42 Go to previous messageGo to next message
Steve Jones is currently offline Steve Jones
Messages: 95
Registered: July 2009
Member
Steve Jones wrote:
> Hi,
>
> Following the LeaguePlanet example in the WTP book I've now got as far
> as chapter 8, page 352. I have three errors relating to the
> LeaguePlanetEAR project:
>
> 1. IWAE0053E An internal error has occurred running validation on
> project:LeaguePlanetEAR] deployment descriptor of the module
> 'LeaguePlanetEJB.jar' cannot be loaded.
>
> 2. The deployment descriptor of the module 'LeaguePlanetEJB.jar'
> cannot be loaded.
>
> 3. The deployment descriptor of the module 'LeaguePlanetWeb.war'
> cannot be loaded.
>
> In LeaguePlanetEAR/.settings/org.eclipse.wst.common.component, if I
> remove the dependency:
>
> <dependent-module deploy-path="/"
> handle="module:/resource/LeaguePlanetWeb/LeaguePlanetWeb">
> <dependent-object>WebModule_1189505806557</dependent-object >
> <dependency-type>uses</dependency-type>
> </dependent-module>
>
> Only error 3 remains and magically the internal error is no longer
> reported. I can only assume the error is somthing to do with the
> location or content of the LeaguePlanetWeb deployment file:
>
> LeaguePlanetWeb\WebContent\WEB-INF\web.xml
>
> This file exists and seems to have sensible things in it.
>
> I've redone the example several time using a clean workspace with the
> same result each time.
>
> This is all on Europa/WTP 2.0.
>
> Any clue as to how I might resolve this would be much appreciated.
>
>
> Thanks, Steve.

Hi,

Having gone and got the WTP 2.0 source and run up the eclipse debugger
it would appear that the reported errors are due to the EAR version in
the LeaguePlanetEAR project NOT being set to 5.0.

Following the book, when creating the projects I set the EAR version to
1.4. WTP lets you do this without complaint.

Unfortunately the project properties dialog "project facets" will not
let you simply change an exiting EAR 1.4 project to 5.0. You have to
scrub the projects and start over.

Having got an error free LeaguePlanet solution JBoss 4.2.1 is happy to
run it.

Steve.
Re: WTP Book: Deployment descriptor of the module NNN cannot be loaded. [message #199686 is a reply to message #199576] Thu, 13 September 2007 13:30 Go to previous message
Naci Dai is currently offline Naci Dai
Messages: 55
Registered: July 2009
Member
Steve,

The book is based on WTP 1.5.x. However, there are some readers who
used 2.0 to complete the exercises. Thx for reporting your experiences
with it.

A common problem is related to using JEE5 level facets for Ear/Web/Ejb
projects (5/2.5/3.0). WTP 2.0 has bare minimum support for JEE5. If
that is the problem, you can use versions that are fully supported (Ear
1.4, Servlet 2.4, Ejb 2.1)

There are some notes we keep at the book site to answer common problems

http://www.eclipsewtp.org/errata.html
feedback at eclicpse.wtp.org



> Hi,
>
> Following the LeaguePlanet example in the WTP book I've now got as far
> as chapter 8, page 352. I have three errors relating to the
> LeaguePlanetEAR project:
>
> 1. IWAE0053E An internal error has occurred running validation on
> project:LeaguePlanetEAR] deployment descriptor of the module
> 'LeaguePlanetEJB.jar' cannot be loaded.
>
> 2. The deployment descriptor of the module 'LeaguePlanetEJB.jar'
> cannot be loaded.
>
> 3. The deployment descriptor of the module 'LeaguePlanetWeb.war'
> cannot be loaded.
>
> In LeaguePlanetEAR/.settings/org.eclipse.wst.common.component, if I
> remove the dependency:
>
> <dependent-module deploy-path="/"
> handle="module:/resource/LeaguePlanetWeb/LeaguePlanetWeb">
> <dependent-object>WebModule_1189505806557</dependent-object >
> <dependency-type>uses</dependency-type>
> </dependent-module>
>
> Only error 3 remains and magically the internal error is no longer
> reported. I can only assume the error is somthing to do with the
> location or content of the LeaguePlanetWeb deployment file:
>
> LeaguePlanetWeb\WebContent\WEB-INF\web.xml
>
> This file exists and seems to have sensible things in it.
>
> I've redone the example several time using a clean workspace with the
> same result each time.
>
> This is all on Europa/WTP 2.0.
>
> Any clue as to how I might resolve this would be much appreciated.
>
>
> Thanks, Steve.
Previous Topic:Dynamially adding version for project facet version
Next Topic:Struts Plugin for Eclipse 3.3
Goto Forum:
  


Current Time: Thu Oct 23 12:42:42 GMT 2014

Powered by FUDForum. Page generated in 0.11926 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software