Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » The preferences for the xdoclet runtime does not point to a valid installation
The preferences for the xdoclet runtime does not point to a valid installation [message #198198] Tue, 14 August 2007 10:36 Go to next message
Udo Rader is currently offline Udo Rader
Messages: 12
Registered: July 2009
Junior Member
Hi,

despite of what I do, I keep getting this nasty error making me mad. I
have all the latest and greatest (stable) releases, yet still I keep
getting this error.

What I have done so far without success:

1. right click on the project
2. properties
3. xdoclet
4. uncheck "use global xdoclet"
5. uncheck "enable xdoclet builder"

=> result: I still get the error

this is how my org.eclipse.jst.j2ee.ejb.annotations.xdoclet.prefs file for
the project looks like after disabling the builder:

------CUT------
#Tue Aug 14 12:21:16 CEST 2007
XDOCLETBUILDERACTIVE=false
XDOCLETHOME=/usr/bestsolution/lib/java/xdoclet-1.2.3
XDOCLETUSEGLOBAL=false
XDOCLETVERSION=1.2.3
eclipse.preferences.version=1
------CUT------

Then I tried to globally disable the builder via the global preferences,
but still no success.

To make it even worse, I even have a valid xdoclet 1.2.3 installation
available (and have of course specified once for the project and
globally), but the error still keeps nagging me ...

any ideas?
Re: The preferences for the xdoclet runtime does not point to a valid installation [message #520524 is a reply to message #198198] Fri, 12 March 2010 17:55 Go to previous messageGo to next message
Sanjeev  is currently offline Sanjeev
Messages: 1
Registered: March 2010
Junior Member
I got the same problem and i did download xdoclet 1.2.3 from sourceforge and made available to eclipse and enabled it globally. than i cleaned the selected project and build it. The problem got resolved.
icon14.gif  Re: The preferences for the xdoclet runtime does not point to a valid installation [message #698004 is a reply to message #520524] Mon, 18 July 2011 15:31 Go to previous messageGo to next message
alexis.krier is currently offline alexis.krier
Messages: 2
Registered: May 2011
Junior Member
Indeed it do the job.
Xdoclet must be set in Eclipse in global preferences (window->preferences->xdoclet) not only in the project preferences.
Re: The preferences for the xdoclet runtime does not point to a valid installation [message #1276869 is a reply to message #198198] Tue, 25 March 2014 05:59 Go to previous message
Gopi Meesala is currently offline Gopi Meesala
Messages: 1
Registered: March 2014
Junior Member
Thanks, It resolved the issue !!!
Previous Topic:JSP JDK Issues Eclipse Kepler
Next Topic:JSDT Refactoring support
Goto Forum:
  


Current Time: Sun Sep 21 04:07:11 GMT 2014

Powered by FUDForum. Page generated in 0.04738 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software