Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » RAP TabFolder getClientArea incorrect(getClientArea for TabFolder incorrect)
RAP TabFolder getClientArea incorrect [message #1220406] Wed, 11 December 2013 09:36 Go to next message
John Gymer is currently offline John Gymer
Messages: 185
Registered: November 2012
Location: UK
Senior Member
getClientArea() for a TabFolder gives the wrong results in some situations in RAP...

First example has TabItems along the top of the TabFolder, with different TabItems having different heights:

index.php/fa/16994/0/

The clientArea returned for the TabFolder is too tall. However, I can work-around this (just required for RAP) because the rect.Y part is populated and I can simply subtract rect.Y from rect.H to get the true height of the clientArea.

Next example has TabItems along the bottom of the TabTolder, where one or more of the TabItems has a larger-than-default height (my example has the same tall image on all TabItems):

index.php/fa/16995/0/

I have no workaround for this.

I presume that this is a RAP bug in getClientArea for TabFolders with non-default height TabItems?


---
Just because you can doesn't mean you should
Re: RAP TabFolder getClientArea incorrect [message #1220410 is a reply to message #1220406] Wed, 11 December 2013 09:59 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan Furnadjiev
Messages: 1773
Registered: July 2009
Senior Member
Hi John,
this is a bug. TabFolder#getTabBarHeight does not respect item image
size. Please file a bugzilla about this issue.
Thanks,
Ivan

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: RAP TabFolder getClientArea incorrect [message #1220411 is a reply to message #1220410] Wed, 11 December 2013 10:03 Go to previous message
John Gymer is currently offline John Gymer
Messages: 185
Registered: November 2012
Location: UK
Senior Member
Thanks Ivan... raised:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=423824


---
Just because you can doesn't mean you should
Previous Topic:FocusIn/Out on Composites
Next Topic:Deploying a RAP Application to tomcat6.0, How to configure a context path?
Goto Forum:
  


Current Time: Tue Jul 22 05:24:59 EDT 2014

Powered by FUDForum. Page generated in 0.01512 seconds