Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Support for Xulrunner 25 (It would be really great to get Xulrunner 25 compatibility for eclipse kepler)
icon5.gif  Support for Xulrunner 25 [message #1220309] Wed, 11 December 2013 02:23 Go to next message
Shyamnath R is currently offline Shyamnath R
Messages: 4
Registered: December 2013
Junior Member
Hi Team,

I am working on a Eclipse RCP project where we embed the XULRunner to use as a browser component for our tool.We use lot of SVG images in the browser content and would like the text selection and copy feature in SVG text.

Since from 25th version of XUlRunner we have text selection. we would like to make use of it.
We are currently using version 10.But higher version(above 10) is not supported with even eclipse kepler.

bugzilla.mozilla.org/show_bug.cgi?id=292498

I saw a MOM done in December 11, 2013, where there is a plan to give a support for XUlrunner 24 and awaiting Foundation legal clearance.

wiki.eclipse.org/Eclipse/Status_meetings/Minutes


But SVG text selection feature is present from XUlrunner version 25 and it is very useful for many of us who uses SVG content as part of the browser.

It would be really great to have version 25 compatibility with Eclipse.

Also attaching a reply mail received related to this query with Mr.Benjamin Smedberg who is the lead developer of XULRunner.
  • Attachment: reply.bmp
    (Size: 1.75MB, Downloaded 101 times)
Re: Support for Xulrunner 25 [message #1220503 is a reply to message #1220309] Thu, 12 December 2013 08:58 Go to previous messageGo to next message
Christian Sell is currently offline Christian Sell
Messages: 51
Registered: August 2010
Member
Benjamin Smedbergs mail relates to JavaXPCOM, which already isn't present with XULRunner 10, I believe. In any case, JavaXPCOM always was an optional component, and I suppose you are not using it. So that doesn't have much to do with the issue at hand here. I do think, however, that you would be better off posting this in the SWT forum, as the Browser widget is a SWT component and not in any way special to Eclipse 4.

[Updated on: Thu, 12 December 2013 09:11]

Report message to a moderator

Re: Support for Xulrunner 25 [message #1220523 is a reply to message #1220309] Thu, 12 December 2013 10:54 Go to previous messageGo to next message
Shyamnath R is currently offline Shyamnath R
Messages: 4
Registered: December 2013
Junior Member
Hi Christian ,

Thanks a lot for the reply.

I was actually referring to this link here.
http://eclipse.org/swt/faq.php#browserlinux
Here it was mentioned which version of eclipse can support which version of Xulrunner.

Thanks
Shyam
Re: Support for Xulrunner 25 [message #1220541 is a reply to message #1220523] Thu, 12 December 2013 13:03 Go to previous message
Christian Sell is currently offline Christian Sell
Messages: 51
Registered: August 2010
Member
have a look at https://bugs.eclipse.org/bugs/show_bug.cgi?id=422561.

[Updated on: Thu, 12 December 2013 13:04]

Report message to a moderator

Previous Topic: Debug Perspective not switching after clicking Yes on "Confirm Perspective switch"
Next Topic:Rendering an SWT Menu from MMenu?
Goto Forum:
  


Current Time: Wed Oct 22 03:31:00 GMT 2014

Powered by FUDForum. Page generated in 0.01818 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software