Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Rap Export-Version(Rap does not export jface with versions)
Rap Export-Version [message #1219027] Fri, 29 November 2013 14:57 Go to next message
Dave Smith is currently offline Dave Smith
Messages: 30
Registered: July 2009
Member
I am using bnd/bndtools to build my bundles. When they are built against the swt version of jface the manifest has an import package of org.eclipse.jface.viewers;version="[3.5,4)" however in your org.eclipse.rap.jface.databinding you simply export the package with out a version thus my bundles do not resolve. Since you must be supporting some version of the API does it not make sense to add a version?
Re: Rap Export-Version [message #1219034 is a reply to message #1219027] Fri, 29 November 2013 17:43 Go to previous messageGo to next message
Ralf Sternberg is currently offline Ralf Sternberg
Messages: 1286
Registered: July 2009
Senior Member

AFAIR, we copied the bundle manifests from SWT/JFace at a time when they
didn't have export versions. But I agree that all packages should be
exported with a version now. Would you mind to open a bug report [1]?

Regards,
Ralf

[1] http://eclipse.org/rap/bugs

--
Ralf Sternberg

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Rap Export-Version [message #1219036 is a reply to message #1219034] Fri, 29 November 2013 19:01 Go to previous messageGo to next message
Dave Smith is currently offline Dave Smith
Messages: 30
Registered: July 2009
Member
Done

https://bugs.eclipse.org/bugs/show_bug.cgi?id=422885
Re: Rap Export-Version [message #1219141 is a reply to message #1219036] Mon, 02 December 2013 05:55 Go to previous messageGo to next message
Ralf Sternberg is currently offline Ralf Sternberg
Messages: 1286
Registered: July 2009
Senior Member

Thanks for the bug report! I'm just looking at the SWT and JFace bundles
in Luna M3, and they still export their packages without versions. So
your example

> org.eclipse.jface.viewers;version="[3.5,4)"

would neither work with RCP. We're willing to add package versions but
obviously, this wouldn't help unless the platform does that too. Did you
/ could you open a bug for the platform [1] as well?

Regards,
Ralf

[1] https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Platform

--
Ralf Sternberg

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Rap Export-Version [message #1219261 is a reply to message #1219141] Mon, 02 December 2013 19:34 Go to previous message
Dave Smith is currently offline Dave Smith
Messages: 30
Registered: July 2009
Member
My bad. we have some custom jface bundles that we had versioned for another application I was running. I used the jface bundles that ship with eclipse and all was fine Sorry for the noise...
Previous Topic:Send "WWW-Authenticate: Negotiate" on first RAP request
Next Topic:Calendar in some months shows wrong weekdays (only in IE)
Goto Forum:
  


Current Time: Sat Apr 19 02:54:55 EDT 2014

Powered by FUDForum. Page generated in 0.01577 seconds