Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » [MWE] Dependency issues in 2.4.1 release
[MWE] Dependency issues in 2.4.1 release [message #1214289] Wed, 27 November 2013 16:27 Go to next message
Victor Roldan Betancort is currently offline Victor Roldan BetancortFriend
Messages: 524
Registered: July 2009
Senior Member
Hi folks,

first of all, not sure if this is the right place to ask abour MWE2. Could not find a dedicated forum. My apologies in advance.

We're moving on to Kepler, so that means, among other things, regenerating our Xtext grammars. My first build on jenkins failed due to a dependency with EMF 2.10. But wait... 2.10? How could that happen if I've only downloaded Kepler releases (actually SR1 releases).

Well, aparently bundle org.eclipse.emf.mwe2.language, on the 2.4.1 release, depends on 2.10 (emf.ecore 2.10 and emf.common 2.10). That seems as an inconsistency to me, as the 2.4.1 should not be breaking clients, and specially not to depend on a EMF version that has not been released yet.

I checked it, and in the 2.4.0, the dependency is over the 2.9 release

So, is this an unintended client breakage?

I fetched if from http://www.eclipse.org/modeling/emft/downloads/?project=mwe
2.4.1 (2013/09/03) release

Best Regards,
Víctor Roldán [Open Canarias]

Re: [MWE] Dependency issues in 2.4.1 release [message #1219179 is a reply to message #1214289] Mon, 02 December 2013 13:50 Go to previous messageGo to next message
Dennis Huebner is currently offline Dennis HuebnerFriend
Messages: 221
Registered: July 2009
Senior Member

Hi Victor,
thanks for reporting this. We noticed the wrong constraint right after releasing, but it was to late to fix it.
This issue was fixed in the meantime, sorry for the inconvenience.

Regards,
Dennis.


Re: [MWE] Dependency issues in 2.4.1 release [message #1229028 is a reply to message #1219179] Wed, 08 January 2014 15:12 Go to previous messageGo to next message
Victor Roldan Betancort is currently offline Victor Roldan BetancortFriend
Messages: 524
Registered: July 2009
Senior Member
No prob Dennis, glad to help! Thanks for the support Smile

Cheers,
Víctor Roldán [Open Canarias]
Re: [MWE] Dependency issues in 2.4.1 release [message #1232673 is a reply to message #1219179] Fri, 17 January 2014 13:17 Go to previous messageGo to next message
Aaron Digulla is currently offline Aaron DigullaFriend
Messages: 258
Registered: July 2009
Location: Switzerland
Senior Member
It's good to hear that is has been fixed but in the meantime, what should I do as a consumer of Xtext/MWE2? Which versions should I install in my target platform?

Will the fix be included in SR2? If not, is there something that I can do locally to make my code work?
Re: [MWE] Dependency issues in 2.4.1 release [message #1232714 is a reply to message #1232673] Fri, 17 January 2014 14:52 Go to previous messageGo to next message
Dennis Huebner is currently offline Dennis HuebnerFriend
Messages: 221
Registered: July 2009
Senior Member

If you use the Kepler update site you should already get a fixed version.
If you use emft download site (which was also fixed now) you should get a new zip file (feature qualifier ends with 201309030840).

Here is a direct link:
http://www.eclipse.org/modeling/emft/downloads/?showAll=1&hlbuild=R201309030840&project=mwe#R201309030840

Please let me now if it works for you or not.


Re: [MWE] Dependency issues in 2.4.1 release [message #1232747 is a reply to message #1232714] Fri, 17 January 2014 16:10 Go to previous messageGo to next message
Aaron Digulla is currently offline Aaron DigullaFriend
Messages: 258
Registered: July 2009
Location: Switzerland
Senior Member
Dennis Huebner wrote on Fri, 17 January 2014 15:52
If you use the Kepler update site you should already get a fixed version.
If you use emft download site (which was also fixed now) you should get a new zip file (feature qualifier ends with 201309030840).

Here is a direct link:
http://www.eclipse.org/modeling/emft/downloads/?showAll=1&hlbuild=R201309030840&project=mwe#R201309030840


That's the version I tried (2.4.1) and which has the bug.

My SHA1 checksums are:

139aa402ca831d56e9b6d1e54c42aa5c4edb09cd  emft-mwe-Update-2.4.1.zip
95daf7f00ffe9ea5604b967d9757d00f6e139750  emft-mwe-2-lang-Update-2.4.1.zip


Features included are:

   31730  Defl:N    31063   2% 2013-09-03 04:26 f46291db  features/org.eclipse.emf.mwe.core.source_1.3.1.v201309030422.jar
   32479  Defl:N    31813   2% 2013-09-03 04:26 10b86ea9  features/org.eclipse.emf.mwe.core_1.3.1.v201309030422.jar
   31716  Defl:N    31045   2% 2013-09-03 04:26 7ed4e98d  features/org.eclipse.emf.mwe.doc.source_1.2.1.v201309030422.jar
   32382  Defl:N    31707   2% 2013-09-03 04:26 0e41094f  features/org.eclipse.emf.mwe.doc_1.2.1.v201309030422.jar
   31802  Defl:N    31122   2% 2013-09-03 04:26 40f27f99  features/org.eclipse.emf.mwe.sdk.source_1.3.1.v201309030422.jar
   32377  Defl:N    31707   2% 2013-09-03 04:26 7ae2e13b  features/org.eclipse.emf.mwe.sdk_1.3.1.v201309030422.jar
   31740  Defl:N    31075   2% 2013-09-03 04:26 7eacecb4  features/org.eclipse.emf.mwe.ui.source_1.2.1.v201309030422.jar
   32518  Defl:N    31848   2% 2013-09-03 04:26 50a1c244  features/org.eclipse.emf.mwe.ui_1.2.1.v201309030422.jar
   31781  Defl:N    31109   2% 2013-09-03 04:26 e2c2f4e8  features/org.eclipse.emf.mwe2.runtime.sdk.source_2.4.1.v201309030422.jar
   32531  Defl:N    31862   2% 2013-09-03 04:26 a4f543a9  features/org.eclipse.emf.mwe2.runtime.sdk_2.4.1.v201309030422.jar


These files are broken.

I then downgraded to 2.4.0 and those files work (same download link, just the next item in the tree).

[Updated on: Fri, 17 January 2014 16:11]

Report message to a moderator

Re: [MWE] Dependency issues in 2.4.1 release [message #1232778 is a reply to message #1232747] Fri, 17 January 2014 18:14 Go to previous messageGo to next message
Dennis Huebner is currently offline Dennis HuebnerFriend
Messages: 221
Registered: July 2009
Senior Member

checksum for emft-mwe-2-lang-Update-2.4.1.zip should be d4613a0fbebf1f93a81452e35a0f2034619afa4c:

dhubner@build:~/downloads-mwe/downloads/drops/2.4.1> sha1sum R201309030840/emft-mwe-2-lang-Update-2.4.1.zip
d4613a0fbebf1f93a81452e35a0f2034619afa4c R201309030840/emft-mwe-2-lang-Update-2.4.1.zip

checksum for emft-mwe-Update-2.4.1.zip matches:

dhubner@build:~/downloads-mwe/downloads/drops/2.4.1> sha1sum R201309030840/emft-mwe-Update-2.4.1.zip
139aa402ca831d56e9b6d1e54c42aa5c4edb09cd R201309030840/emft-mwe-Update-2.4.1.zip


*.v201309030422 features are not broken. This is because mwe build has to steps, so mwe and mwe2.runtime have an another timestamp as mwe2.languge. If you get both zips with checksums above, you are good to go.


[Updated on: Fri, 17 January 2014 18:40]

Report message to a moderator

Re: [MWE] Dependency issues in 2.4.1 release [message #1233680 is a reply to message #1232778] Mon, 20 January 2014 09:11 Go to previous messageGo to next message
Aaron Digulla is currently offline Aaron DigullaFriend
Messages: 258
Registered: July 2009
Location: Switzerland
Senior Member
Hi Denis,

Thanks for the information. I have now downloaded the file again and this time, the checksum matches. Also, the dependencies look correct.

I tried to download it from the mirrors manually to find the one which served me the wrong file 4 days ago but couldn't find it. Just to be safe, I'd suggest that you "touch" the file to force the mirrors to download it again.

Something else that I noticed: I switch to HTTP mirrors since FTP doesn't work. When I click on the link "Georgia Tech Software Library (http)", I'm forwarded to ftp://ftp.gtlib.gatech.edu/pub/eclipse/modeling/emft/mwe/downloads/drops/2.4.1/R201309030840/emft-mwe-2-lang-Update-2.4.1.zip

Any idea where I should report this?
Re: [MWE] Dependency issues in 2.4.1 release [message #1233710 is a reply to message #1233680] Mon, 20 January 2014 10:16 Go to previous message
Dennis Huebner is currently offline Dennis HuebnerFriend
Messages: 221
Registered: July 2009
Senior Member

I think the best is to send an E-Mail to webmaster@eclipse.org.
Or open a bugzilla here: https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Community&component=Website


Previous Topic:How to get existing Xtext project from google code sync to eclipse
Next Topic:Converting to Docx using xtext/xtend and docx4j
Goto Forum:
  


Current Time: Thu Nov 27 17:38:28 GMT 2014

Powered by FUDForum. Page generated in 0.02373 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software