Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » requires plug-in "org.eclipse.wst.server.core (1.0.103)", or equivalent.
requires plug-in "org.eclipse.wst.server.core (1.0.103)", or equivalent. [message #196221] Thu, 12 July 2007 01:39 Go to next message
Eclipse User
Originally posted by: dingfelder_nospam.gmail.com

I posted a message in the main platform area but have not gotten any
responses... I'm wondering if this is a webtools issue, as lots of the
errors I am seeing refer to wst, and say they require plug-in
"org.eclipse.wst.server.core (1.0.103)", or equivalent.

I do have wst org.eclipse.wst.server.core installed and have version 1.1.101

Thoughts?

this is my post from the other section:

I have an error in my log when starting eclipse

eclipse.buildId=I20070625-1500
java.version=1.6.0_01
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86

Error
Fri Jul 13 00:13:58 NZST 2007
Digest could not be parsed:Element type "includes" must be followed by
either attribute specifications, ">" or "/>".

then, when trying to update anything in the update mgr, I get:

Current configuration contains errors that are not corrected by the
requested operation and more errors would be introduced. See details for
more information.
----- Current configuration problems -----
JST Server UI (2.0.0.v200706041905-77-Ao9yJX9kueNPfPjeUCMFH3648)
requires plug-in "org.eclipse.wst.server.core (1.0.103)", or equivalent.
Java Persistence API Tools
(1.0.0.v200706250000-77--CYQCCz-CoRPCCCH) requires plug-in
"org.eclipse.jem.util".
WTP Web Page Editor (1.0.0.v200706110802-3--9oA55P5M98) requires
plug-in "org.eclipse.wst.common.ui (1.1.0)", or equivalent.
JST Web UI (2.0.0.v200706080001-7B1_BCkuMa8l8kBY3z0ZhX6ZupBP)
requires plug-in "org.eclipse.jem.util (2.0.0)", or compatible.
JST Common Core (2.0.0.v200706041905-1007w311817231426) requires
plug-in "org.eclipse.wst.common.project.facet.core (1.1.1)", or compatible.
JST Server Core (2.0.0.v200706041905-56CL9rC7EK_PAQ7G_92537)
requires plug-in "org.eclipse.wst.server.core (1.0.103)", or equivalent.
JST Enterprise Core (2.0.0.v200706041905-42Am_kE77Y7U9NAPH8)
requires plug-in "org.eclipse.wst.common.frameworks (1.1.0)", or equivalent.
OCL 2.0 Binding for UML (1.1.0.v200706071450-10-7w311817182561)
requires plug-in "org.eclipse.uml2.uml (2.1.0)", or equivalent.
JST Enterprise UI
(2.0.0.v200706200200-7b7_ErUEU6AXGM40HZCO6nkOjnZQ) requires plug-in
"org.eclipse.wst.command.env (1.0.101)", or equivalent.
JST Server Adapters (2.0.0.v200706041905-787KE8RDUUEF6ExNsAAAJ)
requires plug-in "org.eclipse.wst.server.core (1.0.204)", or equivalent.
JST Web Core (2.0.0.v200706080101-7Q7ACQEHhHegvgW5YtoAO) requires
plug-in "org.eclipse.jem.util (2.0.0)", or compatible.
----- Configuration problems after the operation -----
JST Server UI (2.0.0.v200706041905-77-Ao9yJX9kueNPfPjeUCMFH3648)
requires plug-in "org.eclipse.wst.server.core (1.0.103)", or equivalent.
Java Persistence API Tools
(1.0.0.v200706250000-77--CYQCCz-CoRPCCCH) requires plug-in
"org.eclipse.jem.util".
WTP Web Page Editor (1.0.0.v200706110802-3--9oA55P5M98) requires
plug-in "org.eclipse.wst.common.ui (1.1.0)", or equivalent.
JST Web UI (2.0.0.v200706080001-7B1_BCkuMa8l8kBY3z0ZhX6ZupBP)
requires plug-in "org.eclipse.jem.util (2.0.0)", or compatible.
JST Common Core (2.0.0.v200706041905-1007w311817231426) requires
plug-in "org.eclipse.wst.common.project.facet.core (1.1.1)", or compatible.
JST Server Core (2.0.0.v200706041905-56CL9rC7EK_PAQ7G_92537)
requires plug-in "org.eclipse.wst.server.core (1.0.103)", or equivalent.
JST Enterprise Core (2.0.0.v200706041905-42Am_kE77Y7U9NAPH8)
requires plug-in "org.eclipse.wst.common.frameworks (1.1.0)", or equivalent.
OCL 2.0 Binding for UML (1.1.0.v200706071450-10-7w311817182561)
requires plug-in "org.eclipse.uml2.uml (2.1.0)", or equivalent.
JST Enterprise UI
(2.0.0.v200706200200-7b7_ErUEU6AXGM40HZCO6nkOjnZQ) requires plug-in
"org.eclipse.wst.command.env (1.0.101)", or equivalent.
JST Server Adapters (2.0.0.v200706041905-787KE8RDUUEF6ExNsAAAJ)
requires plug-in "org.eclipse.wst.server.core (1.0.204)", or equivalent.
JST Web Core (2.0.0.v200706080101-7Q7ACQEHhHegvgW5YtoAO) requires
plug-in "org.eclipse.jem.util (2.0.0)", or compatible.
Resource Monitoring Server Feature (Incubation)
(1.0.0.v20070510-7F47_E9IgKLWLDUZ5G8E) requires feature
"org.eclipse.equinox.jmx.common.feature (1.0.0.qualifier)", or compatible.

I assume the 2nd set of error is because of the bad "digest" ?

How can I correct this?
Re: requires plug-in "org.eclipse.wst.server.core (1.0.103)", or equivalent. [message #196320 is a reply to message #196221] Thu, 12 July 2007 14:00 Go to previous message
Angel Vera is currently offline Angel Vera
Messages: 63
Registered: July 2009
Member

It seems that one or more plugins that you are using require a higher
level of WTP. I would recomend downloading a new WTP, and replace
org.eclipse.wst.server.core with a new higher release.

You probably want to download 1.5.4.


dingfelder <dingfelder_nospam@gmail.com> wrote in
news:f740oh$5h7$1@build.eclipse.org:

> I posted a message in the main platform area but have not gotten any
> responses... I'm wondering if this is a webtools issue, as lots of the
> errors I am seeing refer to wst, and say they require plug-in
> "org.eclipse.wst.server.core (1.0.103)", or equivalent.
>
> I do have wst org.eclipse.wst.server.core installed and have version
> 1.1.101
>
> Thoughts?
>
> this is my post from the other section:
>
> I have an error in my log when starting eclipse
>
> eclipse.buildId=I20070625-1500
> java.version=1.6.0_01
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
> Command-line arguments: -os linux -ws gtk -arch x86
>
> Error
> Fri Jul 13 00:13:58 NZST 2007
> Digest could not be parsed:Element type "includes" must be followed by
> either attribute specifications, ">" or "/>".
>
> then, when trying to update anything in the update mgr, I get:
>
> Current configuration contains errors that are not corrected by the
> requested operation and more errors would be introduced. See details
> for more information.
> ----- Current configuration problems -----
> JST Server UI (2.0.0.v200706041905-77-Ao9yJX9kueNPfPjeUCMFH3648)
> requires plug-in "org.eclipse.wst.server.core (1.0.103)", or
> equivalent.
> Java Persistence API Tools
> (1.0.0.v200706250000-77--CYQCCz-CoRPCCCH) requires plug-in
> "org.eclipse.jem.util".
> WTP Web Page Editor (1.0.0.v200706110802-3--9oA55P5M98) requires
> plug-in "org.eclipse.wst.common.ui (1.1.0)", or equivalent.
> JST Web UI (2.0.0.v200706080001-7B1_BCkuMa8l8kBY3z0ZhX6ZupBP)
> requires plug-in "org.eclipse.jem.util (2.0.0)", or compatible.
> JST Common Core (2.0.0.v200706041905-1007w311817231426) requires
> plug-in "org.eclipse.wst.common.project.facet.core (1.1.1)", or
> compatible.
> JST Server Core (2.0.0.v200706041905-56CL9rC7EK_PAQ7G_92537)
> requires plug-in "org.eclipse.wst.server.core (1.0.103)", or
> equivalent.
> JST Enterprise Core (2.0.0.v200706041905-42Am_kE77Y7U9NAPH8)
> requires plug-in "org.eclipse.wst.common.frameworks (1.1.0)", or
> equivalent.
> OCL 2.0 Binding for UML (1.1.0.v200706071450-10-7w311817182561)
> requires plug-in "org.eclipse.uml2.uml (2.1.0)", or equivalent.
> JST Enterprise UI
> (2.0.0.v200706200200-7b7_ErUEU6AXGM40HZCO6nkOjnZQ) requires plug-in
> "org.eclipse.wst.command.env (1.0.101)", or equivalent.
> JST Server Adapters (2.0.0.v200706041905-787KE8RDUUEF6ExNsAAAJ)
> requires plug-in "org.eclipse.wst.server.core (1.0.204)", or
> equivalent.
> JST Web Core (2.0.0.v200706080101-7Q7ACQEHhHegvgW5YtoAO) requires
> plug-in "org.eclipse.jem.util (2.0.0)", or compatible.
> ----- Configuration problems after the operation -----
> JST Server UI (2.0.0.v200706041905-77-Ao9yJX9kueNPfPjeUCMFH3648)
> requires plug-in "org.eclipse.wst.server.core (1.0.103)", or
> equivalent.
> Java Persistence API Tools
> (1.0.0.v200706250000-77--CYQCCz-CoRPCCCH) requires plug-in
> "org.eclipse.jem.util".
> WTP Web Page Editor (1.0.0.v200706110802-3--9oA55P5M98) requires
> plug-in "org.eclipse.wst.common.ui (1.1.0)", or equivalent.
> JST Web UI (2.0.0.v200706080001-7B1_BCkuMa8l8kBY3z0ZhX6ZupBP)
> requires plug-in "org.eclipse.jem.util (2.0.0)", or compatible.
> JST Common Core (2.0.0.v200706041905-1007w311817231426) requires
> plug-in "org.eclipse.wst.common.project.facet.core (1.1.1)", or
> compatible.
> JST Server Core (2.0.0.v200706041905-56CL9rC7EK_PAQ7G_92537)
> requires plug-in "org.eclipse.wst.server.core (1.0.103)", or
> equivalent.
> JST Enterprise Core (2.0.0.v200706041905-42Am_kE77Y7U9NAPH8)
> requires plug-in "org.eclipse.wst.common.frameworks (1.1.0)", or
> equivalent.
> OCL 2.0 Binding for UML (1.1.0.v200706071450-10-7w311817182561)
> requires plug-in "org.eclipse.uml2.uml (2.1.0)", or equivalent.
> JST Enterprise UI
> (2.0.0.v200706200200-7b7_ErUEU6AXGM40HZCO6nkOjnZQ) requires plug-in
> "org.eclipse.wst.command.env (1.0.101)", or equivalent.
> JST Server Adapters (2.0.0.v200706041905-787KE8RDUUEF6ExNsAAAJ)
> requires plug-in "org.eclipse.wst.server.core (1.0.204)", or
> equivalent.
> JST Web Core (2.0.0.v200706080101-7Q7ACQEHhHegvgW5YtoAO) requires
> plug-in "org.eclipse.jem.util (2.0.0)", or compatible.
> Resource Monitoring Server Feature (Incubation)
> (1.0.0.v20070510-7F47_E9IgKLWLDUZ5G8E) requires feature
> "org.eclipse.equinox.jmx.common.feature (1.0.0.qualifier)", or
> compatible.
>
> I assume the 2nd set of error is because of the bad "digest" ?
>
> How can I correct this?
>


Regards,
--
Angel Vera
WTP Server Tools Developer
Previous Topic:Why MySQL DataSource Configuration not working in eclipse wtp 2
Next Topic:Beginner Help: Europa and Preview Server
Goto Forum:
  


Current Time: Mon Sep 22 04:28:58 GMT 2014

Powered by FUDForum. Page generated in 0.07897 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software