Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Hudson » Build fails when running ant target having javascript
Build fails when running ant target having javascript [message #1211436] Tue, 26 November 2013 07:37 Go to next message
Lakshmi Shanmugam
Messages: 274
Registered: July 2009
Location: India
Senior Member
Hi all,

I'm using Hudson 3.1. When I try to run a ant target which has javascript, the build fails with the following exception:

init_fragment:

BUILD FAILED
/var/lib/hudson/userContent/repos/master/eclipse.platform.swt/bundles/org.eclipse.swt/buildSWT.xml:794: java.lang.NoClassDefFoundError: org/mozilla/javascript/EvaluatorException
at java.lang.Class.getDeclaredConstructors0(Native Method)
at java.lang.Class.privateGetDeclaredConstructors(Class.java:2404)
at java.lang.Class.getConstructor0(Class.java:2714)
at java.lang.Class.newInstance0(Class.java:343)
at java.lang.Class.newInstance(Class.java:325)
at org.apache.bsf.BSFManager.loadScriptingEngine(BSFManager.java:697)
at org.apache.bsf.BSFManager.exec(BSFManager.java:485)
at org.apache.tools.ant.util.optional.ScriptRunner.executeScript(ScriptRunner.java:100)
at org.apache.tools.ant.taskdefs.optional.Script.execute(Script.java:52)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:601)
at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
at org.apache.tools.ant.Task.perform(Task.java:348)
at org.apache.tools.ant.Target.execute(Target.java:392)
at org.apache.tools.ant.Target.performTasks(Target.java:413)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1399)
at org.apache.tools.ant.Project.executeTarget(Project.java:1368)
at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
at org.apache.tools.ant.Project.executeTargets(Project.java:1251)
at org.apache.tools.ant.Main.runBuild(Main.java:811)
at org.apache.tools.ant.Main.startAnt(Main.java:217)
at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)
Caused by: java.lang.ClassNotFoundException: org.mozilla.javascript.EvaluatorException
at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
... 25 more

Looks like some dependency is missing, but I'm not sure which one. Can someone please help me out. Thanks in advance.


Lakshmi P Shanmugam
Re: Build fails when running ant target having javascript [message #1212117 is a reply to message #1211436] Tue, 26 November 2013 14:26 Go to previous messageGo to next message
Winston Prakash is currently offline Winston Prakash
Messages: 406
Registered: August 2011
Location: Fremont, CA USA
Senior Member
I think this is because the Mozilla rhino jar is missing in your ant build path.

Winston Prakash
Eclipse Hudson team
Re: Build fails when running ant target having javascript [message #1213805 is a reply to message #1212117] Wed, 27 November 2013 06:56 Go to previous message
Lakshmi Shanmugam
Messages: 274
Registered: July 2009
Location: India
Senior Member
Thanks for your response. I have the following rhino packages installed - apache-commons-jci-rhino.noarch and rhino.noarch. How do I include rhino in the ant build path?

Lakshmi P Shanmugam
Previous Topic:How to get email on triggering a build if it gets success/failure
Next Topic:Jenkins plugins on Hudson
Goto Forum:
  


Current Time: Thu Aug 28 05:13:18 EDT 2014

Powered by FUDForum. Page generated in 0.52840 seconds