Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Process Manager (Stardust) » Getting ClassCastException while deploying a model
Getting ClassCastException while deploying a model [message #1202776] Fri, 22 November 2013 10:05 Go to next message
Aleksandar Toshovski is currently offline Aleksandar Toshovski
Messages: 38
Registered: December 2011
Member
When I try to deploy my model I get the following exception:

Exception in thread "main" java.lang.ClassCastException: javax.swing.JSeparator cannot be cast to javax.swing.JPanel
	at org.eclipse.stardust.engine.core.compatibility.gui.ErrorDialog.init(ErrorDialog.java:115)
	at org.eclipse.stardust.engine.core.compatibility.gui.ErrorDialog.<init>(ErrorDialog.java:70)
	at org.eclipse.stardust.engine.core.compatibility.gui.ErrorDialog.showDialog(ErrorDialog.java:199)
	at org.eclipse.stardust.modeling.deploy.ModelDeploymentTool.deployModel(ModelDeploymentTool.java:315)
	at org.eclipse.stardust.modeling.deploy.ModelDeploymentTool.<init>(ModelDeploymentTool.java:206)
	at org.eclipse.stardust.modeling.deploy.ModelDeploymentTool.main(ModelDeploymentTool.java:137)


I'm using Kepler SR1 with the following installed features:
Eclipse IDE for Java EE Developers 2.0.1.20130919-0803
Eclipse Process Manager - 3rd-Party Dependencies 1.0.1.v20130918-0714 Eclipse Process Manager - Core Modeling 1.0.1.v20130918-0714
Eclipse Process Manager - Documentation 1.0.1.v20130918-0714
Eclipse Process Manager - Engine Dependencies 1.0.1.v20130918-0714
Eclipse Process Manager - Message Modeling 1.0.1.v20130918-0714
Eclipse Process Manager - Process Model 1.0.1.v20130918-0714
Eclipse Process Manager - Reporting Modeler Integration 1.0.1.v20130918-0714
Eclipse Process Manager - Reporting Runtime 1.0.1.v20130918-0714
Eclipse Process Manager - Reporting UI 1.0.1.v20130918-0714
Eclipse Process Manager - Simulation 1.0.1.v20130918-0714
Eclipse Process Manager - Web Tools Integration 1.0.1.v20130918-0714

Re: Getting ClassCastException while deploying a model [message #1210775 is a reply to message #1202776] Tue, 26 November 2013 05:26 Go to previous message
Tanmoy Roy is currently offline Tanmoy Roy
Messages: 18
Registered: September 2013
Junior Member
Hi Aleksandar,

What is the java version?
Also can you check if Core Modeling component installation?

Eclipse Process Manager - Core Modeling 1.0.1.v20130918-0714

regards,
Tanmoy Roy
Previous Topic:Cannot find Audit Trail Datasource on Tomcat settings
Next Topic:Web project doesn't run on Eclipse's Tomcat
Goto Forum:
  


Current Time: Fri Oct 24 12:47:04 GMT 2014

Powered by FUDForum. Page generated in 0.17750 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software