Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Strange Eclipse Behavior on OS X v10.4.8
Strange Eclipse Behavior on OS X v10.4.8 [message #188411] Wed, 21 February 2007 18:38
Eclipse User
Originally posted by: arnie.morein.mac.com

Running Eclispe 3.2.1, Build id: M20060921-0945. JBoss IDE 1.6.0.GA. JBoss
is installed under /usr/local/jboss/jbossStnd (I have different versions). I
own and have full rights to the folders. Java 1.5.0.6-64

Working on a JSF/JBoss application. Program compiles and deploys. Server
object is a JBOSS 4.0 object. When the IDE starts server (regular or debug
mode), the log shows the JBoss server gets to about point where Web Services
are starting when it suddenly starts shutting down. The IDE shows no errors,
just that the server shutdown. JBoss log shows errors I've never seen before
and I cannot find any answers to. This same JBoss setup and war runs just
fine if started from the command line.

One thing I've noticed is that the JBOSS 4.0 server object in Eclipse
appears to be read-only. I cannot make any changes to it whatsoever. No
errors, just no * in the filename tab and any changes via the IDE are
discarded.

Never seen anything like this before. This same code base and Eclipse base
work fine on Windows.

Not sure how to turn the debugging log ON for Eclipse or where it may be
located. I'll forward any information you might need, just tell me where to
find it.

Partial JBoss Log


Code:
2007-02-10 11:41:55,720 DEBUG
[org.jboss.deployment.scanner.URLDeploymentScanner] Unable to obtain w
atchUrl from deployer. Use url:
file:/usr/local/jboss/jbossStnd/server/default/deploy/securi ty.sar/
java.lang.NullPointerException
at
org.jboss.deployment.scanner.AbstractDeploymentScanner.getDe ployer(AbstractDeploymentScanner.jav
a:88)
at
org.jboss.deployment.scanner.URLDeploymentScanner$DeployedUR L.getLastModified(URLDeploymentScann
er.java:762)
at
org.jboss.deployment.scanner.URLDeploymentScanner$DeployedUR L.deployed(URLDeploymentScanner.java
:734)
at
org.jboss.deployment.scanner.URLDeploymentScanner.deploy(URL DeploymentScanner.java:432)
at
org.jboss.deployment.scanner.URLDeploymentScanner.scan(URLDe ploymentScanner.java:634)
Previous Topic:Target Group Question
Next Topic:WTP 1.5.3 released!
Goto Forum:
  


Current Time: Sat Oct 25 23:46:58 GMT 2014

Powered by FUDForum. Page generated in 0.01854 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software