Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » HTTP or SOAP protocol for Port
HTTP or SOAP protocol for Port [message #187746] Wed, 07 February 2007 20:06 Go to next message
Srini is currently offline Srini
Messages: 1
Registered: July 2009
Junior Member
Hi,
I am using
Eclipse:Version: 3.3.0 , Build id: I20061214-1445.
WTP : 1.1.10v200612130807

I tried to create a WSDL using New-->Other-->XML-->WSDL and chose HTTP as
the protocol instead of SOAP, to understand the difference between the two
options, in practise. When I try to create a new
webservice(New-->Other-->Web services-->Web service) choosing top down Java
bean service, when I start tomcat, I get the following error:

"IWAB0054E Web project URL for deployment of web service is not set in the
AutoDeploycommand"

Anyone seen this before?

Regards,
Srini
Re: HTTP or SOAP protocol for Port [message #191134 is a reply to message #187746] Thu, 05 April 2007 13:21 Go to previous message
Chris Brealey is currently offline Chris Brealey
Messages: 104
Registered: July 2009
Senior Member
This is a multipart message in MIME format.
--=_alternative 00496BF5852572B4_=
Content-Type: text/plain; charset="US-ASCII"

Srini,
although the "New WSDL" wizard lets you create WSDL with the HTTP binding,
most of the rest of the Web service tools in WTP do not support that
binding since it is not endorsed by WS-I (which the "New WSDL" wizard
should have mentioned the moment you picked the HTTP binding), has never
gained any traction, and is virtually unused in the WS-* industry. That
said, the Web service tools should certainly not produce such a
meaningless message in this case. I'd encourage you to please open a bug
for that:
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Web%20To ols&component=wst.ws&rep_platform=all&op_sys=all .

Thanks - CB.
--=_alternative 00496BF5852572B4_=
Content-Type: text/html; charset="US-ASCII"


<br><font size=2 face="sans-serif">Srini,</font>
<br><font size=2 face="sans-serif">although the &quot;New WSDL&quot; wizard
lets you create WSDL with the HTTP binding, most of the rest of the Web
service tools in WTP do not support that binding since it is not endorsed
by WS-I (which the &quot;New WSDL&quot; wizard should have mentioned the
moment you picked the HTTP binding), has never gained any traction, and
is virtually unused in the WS-* industry. That said, the Web service tools
should certainly not produce such a meaningless message in this case. I'd
encourage you to please open a bug for that: https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Web%20To ols&amp ;component=wst.ws&amp;rep_platform=all&amp;op_sys=al l. </font>
<br>
<br><font size=2 face="sans-serif">Thanks - CB.</font>
--=_alternative 00496BF5852572B4_=--
Previous Topic:Web Service pure java client
Next Topic:Authentication?
Goto Forum:
  


Current Time: Thu Oct 30 17:47:04 GMT 2014

Powered by FUDForum. Page generated in 0.16799 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software