Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Bogus API Errors?
Bogus API Errors? [message #1172067] Tue, 05 November 2013 17:29
Eike Stepper is currently offline Eike Stepper
Messages: 5538
Registered: July 2009
Senior Member
Hi,

During the last 2 or 3 weeks I experience some flaky behaviour with API Tools. It recently started to add a bunch of
version and since tag errors when I (for example) switch HEAD to another branch. By disabling the baseline, full
compile, re-enable and another fully compile I can get rid of them. But they tend to come back soon. Some of them *could
be* valid (almost impossible to find out why a minor version bump is suggested) but some are definitely not, e.g.,

Missing @since tag on org.eclipse.net4j.util.io.IOUtil

That implies that either the class is completely new or missing from the baseline. Both is not the case. I can easily
create more of these errors in any 10 years old class by simply adding a space somewhere and save it.

And neither the Gerrit nor the main Hudson build (which both use the API builder) seem to complain. So I'm reluctant to
change any code to address the errors.

Is it imaginable that a recent update came with a regression of some sort? My current version is:

Eclipse PDE Plug-in Developer Resources
org.eclipse.pde.source.feature.group
3.10.0.v20130918-2000


Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper
Previous Topic:RCP .product.root.feature doesn't have provider name
Next Topic:Including jars in a new project created with a custom wizard
Goto Forum:
  


Current Time: Thu Oct 23 09:35:49 GMT 2014

Powered by FUDForum. Page generated in 0.03415 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software