Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Downloading Geronimo 1.1 support a second time fails
Downloading Geronimo 1.1 support a second time fails [message #183193] Fri, 24 November 2006 16:09 Go to next message
Michael Moser is currently offline Michael Moser
Messages: 914
Registered: July 2009
Senior Member
I am trying to download Geronimo 1.1 support via Servers view => New =>
"Don't see your server listed - click here" => selecting Apache -
Geronimo 1.1.
I accept the license and then I get a box telling me that support for
Geronimo will now be downloaded and installed and that I will be
prompted to restart afterwards. After OKing that I almost immediately
(i.e. certainly before anything got downloaded) get two errors:

one reads:
Duplicate conflicts
An exception stack trace is not available

the other:
org.eclipse.core.runtime.CoreException: Could not download and install
update feature.
at
org.eclipse.wst.server.core.internal.InstallableServer.insta ll(InstallableServer.java:165)
at
org.eclipse.wst.server.ui.internal.wizard.NewInstallableServ erWizard$5.run(NewInstallableServerWizard.java:120)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)

I had downloaded and installed this once before but then got stuck. I
thought I have removed everything to be able to start over but
apparently not. Any idea what else but all features and plugins that
contain the name geronimo one has to wipe to allow re-installation of
this?

Michael
Re: Downloading Geronimo 1.1 support a second time fails [message #183210 is a reply to message #183193] Fri, 24 November 2006 16:32 Go to previous messageGo to next message
Michael Moser is currently offline Michael Moser
Messages: 914
Registered: July 2009
Senior Member
I now even re-installed eclipse 3.3M3 plus WTP2.0M3 (plus all its
prereq's). I also removed all directories beginning with
org.eclipse.wst... from the .metadata directory of my workspace.
Still, after restarting when I open the Servers-view and try to download
support for Geronimo 1.1 and end up with the same error message.

Where/what does this downloading of Geronimo-support change (obviously
outside the eclipse directory) that this fails when one comes the second
time around?

Michael

"Michael Moser" <mmo@zurich.ibm.com> wrote in message
news:ek75fh$51f$1@utils.eclipse.org...
>I am trying to download Geronimo 1.1 support via Servers view => New =>
>"Don't see your server listed - click here" => selecting Apache -
>Geronimo 1.1.
> I accept the license and then I get a box telling me that support for
> Geronimo will now be downloaded and installed and that I will be
> prompted to restart afterwards. After OKing that I almost immediately
> (i.e. certainly before anything got downloaded) get two errors:
>
> one reads:
> Duplicate conflicts
> An exception stack trace is not available
>
> the other:
> org.eclipse.core.runtime.CoreException: Could not download and install
> update feature.
> at
> org.eclipse.wst.server.core.internal.InstallableServer.insta ll(InstallableServer.java:165)
> at
> org.eclipse.wst.server.ui.internal.wizard.NewInstallableServ erWizard$5.run(NewInstallableServerWizard.java:120)
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)
>
> I had downloaded and installed this once before but then got stuck. I
> thought I have removed everything to be able to start over but
> apparently not. Any idea what else but all features and plugins that
> contain the name geronimo one has to wipe to allow re-installation of
> this?
>
> Michael
>
Re: Downloading Geronimo 1.1 support a second time fails [message #183290 is a reply to message #183193] Mon, 27 November 2006 17:18 Go to previous messageGo to next message
Sachin Patel is currently offline Sachin Patel
Messages: 75
Registered: July 2009
Member
I tried this on a clean WTP 1.5.2 image, and was able to sucessfully
install the Geronimo plugins and server.

To retry, you can delete the *geronimo* plugins and features and
relaunch with "-clean".

Michael Moser wrote:
> I am trying to download Geronimo 1.1 support via Servers view => New =>
> "Don't see your server listed - click here" => selecting Apache -
> Geronimo 1.1.
> I accept the license and then I get a box telling me that support for
> Geronimo will now be downloaded and installed and that I will be
> prompted to restart afterwards. After OKing that I almost immediately
> (i.e. certainly before anything got downloaded) get two errors:
>
> one reads:
> Duplicate conflicts
> An exception stack trace is not available
>
> the other:
> org.eclipse.core.runtime.CoreException: Could not download and install
> update feature.
> at
> org.eclipse.wst.server.core.internal.InstallableServer.insta ll(InstallableServer.java:165)
>
> at
> org.eclipse.wst.server.ui.internal.wizard.NewInstallableServ erWizard$5.run(NewInstallableServerWizard.java:120)
>
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)
>
> I had downloaded and installed this once before but then got stuck. I
> thought I have removed everything to be able to start over but
> apparently not. Any idea what else but all features and plugins that
> contain the name geronimo one has to wipe to allow re-installation of this?
>
> Michael
>
Re: Downloading Geronimo 1.1 support a second time fails [message #183334 is a reply to message #183290] Tue, 28 November 2006 11:03 Go to previous message
Michael Moser is currently offline Michael Moser
Messages: 914
Registered: July 2009
Senior Member
Seems to be a version issue. The download & re-installation with eclipse
3.2.1 & WTP 1.5.2 works, using eclipse 3.3M3 and
WTP-sdk-S-2.0M3-200611170109 always fails. So, I stepped back to the old
version - though that one has a few issues as well, which I had tried to
overcome by installing the new one.

Michael


"Sachin Patel" <sppatel2@gmail.com> wrote in message
news:ekf6kg$s33$1@utils.eclipse.org...
>I tried this on a clean WTP 1.5.2 image, and was able to sucessfully
>install the Geronimo plugins and server.
>
> To retry, you can delete the *geronimo* plugins and features and
> relaunch with "-clean".
>
> Michael Moser wrote:
>> I am trying to download Geronimo 1.1 support via Servers view => New
>> => "Don't see your server listed - click here" => selecting Apache -
>> Geronimo 1.1.
>> I accept the license and then I get a box telling me that support for
>> Geronimo will now be downloaded and installed and that I will be
>> prompted to restart afterwards. After OKing that I almost immediately
>> (i.e. certainly before anything got downloaded) get two errors:
>>
>> one reads:
>> Duplicate conflicts
>> An exception stack trace is not available
>>
>> the other:
>> org.eclipse.core.runtime.CoreException: Could not download and
>> install update feature.
>> at
>> org.eclipse.wst.server.core.internal.InstallableServer.insta ll(InstallableServer.java:165)
>> at
>> org.eclipse.wst.server.ui.internal.wizard.NewInstallableServ erWizard$5.run(NewInstallableServerWizard.java:120)
>> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)
>>
>> I had downloaded and installed this once before but then got stuck. I
>> thought I have removed everything to be able to start over but
>> apparently not. Any idea what else but all features and plugins that
>> contain the name geronimo one has to wipe to allow re-installation of
>> this?
>>
>> Michael
>>
Previous Topic:Extending HTML or JSP editors with minimal coding
Next Topic:J2EE module dependencies and virtual jar files
Goto Forum:
  


Current Time: Tue Oct 21 15:27:19 GMT 2014

Powered by FUDForum. Page generated in 0.02656 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software